You are not logged in.

#1 2006-12-05 13:39:02

kawa
Member
Registered: 2006-11-21
Posts: 23

gnome sound muted on logon

When I log into Gnome my sound is always set to 0 and it is muted. gnome-volume-manager is in my session startup but I always have to unmute and raise the volume each time. Is there something I can do keep my volume up?


Knowledge is power

Offline

#2 2006-12-05 13:47:03

Snarkout
Member
Registered: 2005-11-13
Posts: 542

Re: gnome sound muted on logon

I don't know how gnome handles things, but I had a similar issue on my lappy kde and kmix, and adding alsa to my daemons array fixed the issue.  I'm not sure why I was having the problem, and honestly just saw this suggestion in a search I did here in the forums so this may or may not be "the right way."


Unthinking respect for authority is the greatest enemy of truth.
-Albert Einstein

Offline

#3 2006-12-05 13:54:44

kawa
Member
Registered: 2006-11-21
Posts: 23

Re: gnome sound muted on logon

Snarkout wrote:

adding alsa to my daemons array fixed the issue.

How do I do that sad


Knowledge is power

Offline

#4 2006-12-05 14:43:10

harlekin
Member
From: Germany
Registered: 2006-07-13
Posts: 408

Re: gnome sound muted on logon

Just open the file /etc/rc.conf with a editor you like. For example nano:

# nano -w /etc/rc.conf

Note the root prompt!

At the bottom of the document you see a line that looks like this: (Maybe more or less daemons added)

DAEMONS=(syslog-ng !hotplug !pcmcia network netfs crond sshd !vsftpd mysqld cherokee alsa xinetd mpd urxvtd)

Just add alsa to your list and save the file. (Strg+O with nano)

After reboot your mixer settings should be remembered now.

I did and do not use gnome or kde but I think that gnome has its own way to handle mixer settings, doesn't it?


Hail to the thief!

Offline

#5 2006-12-05 18:01:43

oew
Member
From: Norway
Registered: 2006-11-08
Posts: 105

Re: gnome sound muted on logon

I use gnome, and I had to add alsa to the daemons list.


there's no place like ~/

Offline

#6 2006-12-05 19:43:21

Acid7711
Member
From: Chicago, IL
Registered: 2006-08-18
Posts: 300
Website

Re: gnome sound muted on logon

I set my volume, and then did this:

alsactl store

and then added alsa to the daemons list in rc.conf

Worked for me, maybe that's an extra unneeded step.

Offline

#7 2006-12-06 06:09:07

kawa
Member
Registered: 2006-11-21
Posts: 23

Re: gnome sound muted on logon

Thank you. Let me try that and I will give you feedback.


Knowledge is power

Offline

#8 2006-12-06 14:57:22

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,731

Re: gnome sound muted on logon

When you have alsa in the daemons array in rc.conf it automagicaly does a alsactl store at shutdown.


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#9 2006-12-06 15:47:35

Acid7711
Member
From: Chicago, IL
Registered: 2006-08-18
Posts: 300
Website

Re: gnome sound muted on logon

Mr.Elendig wrote:

When you have alsa in the daemons array in rc.conf it automagicaly does a alsactl store at shutdown.

Yes, it does, but I was under the impression that you were supposed to run the command once before the first restart/shutdown after adding alsa to the daemons list so that it would store the settings for sure.  Again, maybe I'm wrong, but I was trying to be helpful. It's what I read to do on the wiki back in the day.

Offline

#10 2006-12-07 06:03:52

kawa
Member
Registered: 2006-11-21
Posts: 23

Re: gnome sound muted on logon

Thanks guys it worked. I now have my Gnome sounds and I can play my XMMS music. I am trying to do the same thing on my Debian sid install but I can either Gnome sound or XMMS not both.


Knowledge is power

Offline

Board footer

Powered by FluxBB