You are not logged in.

#1 2022-04-11 05:09:26

FrankOz
Member
Registered: 2022-04-11
Posts: 1

there is an error in config for new users

Hi all -

IMA new user (used linux debian for years).
First pass to arch.

Package manager gui does not work OOB.

There is a reason: polkit is missing a rule
specifically allow org.manjaro.pamac.policy to install if user is in wheels group

like this:
polkit.addRule(function(action, subject) {
    if (action.id.indexOf("org.freedesktop.udisks2.") == 0 ||
        action.id == "org.manjaro.pamac.commit" &&
        subject.isInGroup("wheel")) {
        return polkit.Result.YES;
    }
});

I searched for how to fix and it appears many other users are stumbling over the same problem.

Might be a good idea to fix the base install so this will cascade thru and provide a better initial user experience?

Offline

#2 2022-04-11 06:39:39

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,202

Re: there is an error in config for new users

Is this a Manjaro or an Arch install? If this is Manjaro you are on the wrong boards, if this is Arch, then this is a detail of the pamac packages and you should probably ask on the AUR page whether a relevant polkit rule can be included.

Moving to AUR issues.

Offline

#3 2022-04-11 07:39:39

seth
Member
Registered: 2012-09-03
Posts: 28,888

Re: there is an error in config for new users

libpamac seems to ship a rule that requires auth_admin, so if that doesn't work either your session is broken or you don't run a polkit agent (to ask you for credentials)
Also you're not "OOB" in %wheel  … at least not on arch.

Online

#4 2022-04-11 07:48:01

Awebb
Member
Registered: 2010-05-06
Posts: 5,935

Re: there is an error in config for new users

There is no pacman GUI OOTB on Arch. Learning the difference between the AUR and the regular repositories is the primary reason why we discourage new users from relying on AUR helpers that wrap around pacman.

Offline

Board footer

Powered by FluxBB