You are not logged in.

#1 2022-04-18 17:16:07

Monero
Member
Registered: 2022-04-18
Posts: 4

Trying to install AirSim, but AUR is broken and installer script fails

Tried installing: https://aur.archlinux.org/packages/airsim

but that breaks and I already requested it to be updated to no avail. So instead I got the source from https://github.com/microsoft/AirSim and tried installing as per the instructions (which are for debian based systems unfortunately). After cleaning the setup.sh scripts from the various "apt-get" parts and installing all the dependencies myself (cross checking it with the AUR repo), I tried to compile/build it myself via the build.sh script. Then getting this error:

xxx@local ~/p/AirSim> ./build.sh
+ debug=false
+ gcc=false
+ [[ 0 -gt 0 ]]
+ RPC_VERSION_FOLDER=rpclib-2.3.0
+ '[' '!' -d ./external/rpclib/rpclib-2.3.0 ']'
+ '[' -d ./cmake_build ']'
++ which cmake
+ CMAKE=/usr/bin/cmake
+ false
+ build_dir=build_release
++ uname
+ '[' Linux == Darwin ']'
+ false
+ export CC=clang-8
+ CC=clang-8
+ export CXX=clang++-8
+ CXX=clang++-8
+ [[ ! -d ./AirLib/deps/eigen3/Eigen ]]
+ echo 'putting build in build_release folder, to clean, just delete the directory...'
putting build in build_release folder, to clean, just delete the directory...
+ [[ -f ./cmake/CMakeCache.txt ]]
+ [[ -d ./cmake/CMakeFiles ]]
+ [[ ! -d build_release ]]
+ mkdir -p build_release
+ CMAKE_VARS=
++ uname
+ '[' Linux == Darwin ']'
+ pushd build_release
+ false
+ folder_name=Release
+ /usr/bin/cmake ../cmake -DCMAKE_BUILD_TYPE=Release
-- The C compiler identification is Clang 8.0.1
CMake Error at /usr/share/cmake/Modules/CMakeDetermineCXXCompiler.cmake:48 (message):
  Could not find compiler set in environment variable CXX:

  clang++-8.

Call Stack (most recent call first):
  CMakeLists.txt:2 (project)


CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
-- Configuring incomplete, errors occurred!
See also "/home/xxx/projects/AirSim/build_release/CMakeFiles/CMakeOutput.log".
+ popd
~/projects/AirSim ~/projects/AirSim
+ rm -r build_release
+ exit 1

I thought that maybe the current installed version of clang was too new, so I specifically installed clang8 (and removed the conflicted clang) via yay, so not sure why this error would come up:

xxx@local ~/p/AirSim> yay -Qs clang
local/clang8 8.0.1-1
    C language family frontend for LLVM (8.x)
local/compiler-rt8 8.0.1-1
    Compiler runtime libraries for clang (8.x)

This is the build.sh script I was trying to execute: https://github.com/microsoft/AirSim/blo … r/build.sh

How can I make this work? (Or perhaps could someone make an AUR that works?)

Thanks!

Offline

#2 2022-04-18 17:37:38

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 26,706
Website

Re: Trying to install AirSim, but AUR is broken and installer script fails

Monero wrote:

Tried installing: https://aur.archlinux.org/packages/airsim

but that breaks and I already requested it to be updated to no avail.

How does is "break"?  Where have you requested it to be updated?  There are no comments on the AUR page nor issues on the github page that the maintainer's comment directs to.

Don't try to use that debian script.  The actual problem is the attempt to manually set "CC" to something that doesn't exist in arch.  There should be no need to set this at all anyways.  Use the PKGBUILD rather than the debian script - if you need to modify one or the other, you might as well start with the one written for arch that at least previously worked.

EDIT: that's weird.  I checked the issues tab of that github page when I first posted this and there were zero open issues - now there are dozens that have been around for quite some time.  I stand corrected.

Last edited by Trilby (2022-04-18 18:41:01)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#3 2022-04-18 18:21:52

Monero
Member
Registered: 2022-04-18
Posts: 4

Re: Trying to install AirSim, but AUR is broken and installer script fails

It's been mentioned here on the github already a month ago without any fix: https://github.com/acxz/pkgbuilds/issues/174

I believe it fails because the CMakeLists.patch file is "broken", i.e. the diffs cannot be applied because the file is entirely different.

Ok I will try it based on the PKGBUILD and report back. Thanks.

Offline

#4 2022-04-18 22:40:33

Monero
Member
Registered: 2022-04-18
Posts: 4

Re: Trying to install AirSim, but AUR is broken and installer script fails

I'm sorry, I can't figure it out.

Following PKGBUILD it seems that the prepare() function tries to apply the patch file from here: https://github.com/acxz/pkgbuilds/blob/ … ists.patch

However, the files are basically completely different, I am not able to fix this with my level of knowledge.

I tried adding it everywhere I can according to the diff file, and I DID manage to build/compile *something* (first doing the cmake, then make), but it won't load in Unreal Engine. At this point I spent way too much time on this, I reckon I'll just have to bite the bullet on do it on Windows...

Offline

#5 2022-04-19 07:21:52

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,711
Website

Re: Trying to install AirSim, but AUR is broken and installer script fails

Mod note: moving to AUR Issues


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#6 2022-04-24 18:19:23

Monero
Member
Registered: 2022-04-18
Posts: 4

Re: Trying to install AirSim, but AUR is broken and installer script fails

Is there any way I can run an old PKGBUILD file?

I would like to run the below, before the author updated the version (which rendered it broken).
https://aur.archlinux.org/cgit/aur.git/ … D?h=airsim

Offline

#7 2022-04-24 18:36:07

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,309
Website

Re: Trying to install AirSim, but AUR is broken and installer script fails

It's a git repository, just git-checkout the commit you want.

Last edited by Alad (2022-04-24 18:36:14)


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

Board footer

Powered by FluxBB