You are not logged in.

#1 2022-04-25 23:43:07

hackerHAO
Member
Registered: 2022-04-25
Posts: 2

Problem when I generate ISO file with Archiso

This is the part of the code that returns
I just added these three filenames gdm, xorg, gnome in the packages.x86_64 file
---------------------------------------
Enter a selection (default=all):
:: There are 60 members in group gnome:
:: Repository extra
   1) baobab  2) cheese  3) eog  4) epiphany  5) evince  6) file-roller  7) gdm
   8) gedit  9) gnome-backgrounds  10) gnome-books  11) gnome-calculator
   12) gnome-calendar  13) gnome-characters  14) gnome-clocks
   15) gnome-color-manager  16) gnome-contacts  17) gnome-control-center
   18) gnome-disk-utility  19) gnome-font-viewer  20) gnome-keyring
   21) gnome-logs  22) gnome-maps  23) gnome-menus  24) gnome-music
   25) gnome-photos  26) gnome-remote-desktop  27) gnome-session
   28) gnome-settings-daemon  29) gnome-shell  30) gnome-shell-extensions
   31) gnome-software  32) gnome-system-monitor  33) gnome-terminal
   34) gnome-user-docs  35) gnome-user-share  36) gnome-video-effects
   37) gnome-weather  38) grilo-plugins  39) gvfs  40) gvfs-afc  41) gvfs-goa
   42) gvfs-google  43) gvfs-gphoto2  44) gvfs-mtp  45) gvfs-nfs  46) gvfs-smb
   47) mutter  48) nautilus  49) orca  50) rygel  51) sushi  52) totem
   53) tracker  54) tracker-miners  55) tracker3-miners  56) vino
   57) xdg-user-dirs-gtk  58) yelp
:: Repository community
   59) gnome-boxes  60) simple-scan

Enter a selection (default=all):
resolving dependencies...
:: There are 2 providers available for libsystemd.so=0-64:
:: Repository archlinuxcn
   1) systemd-libs-git
:: Repository core
   2) systemd-libs

Enter a number (default=1):
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "pipewire", a dependency of "mutter"
warning: cannot resolve "mutter", a dependency of "gnome-shell"
:: There are 2 providers available for pipewire-session-manager:
:: Repository extra
   1) pipewire-media-session  2) wireplumber

Enter a number (default=1):
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "pipewire>=0.3.39", a dependency of "pipewire-media-session"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "libpipewire-0.3.so=0-64", a dependency of "pipewire-media-session"
warning: cannot resolve "pipewire-session-manager", a dependency of "gst-plugin-pipewire"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "libpipewire-0.3.so=0-64", a dependency of "gst-plugin-pipewire"
warning: cannot resolve "gst-plugin-pipewire", a dependency of "gnome-shell"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "pipewire", a dependency of "mutter"
warning: cannot resolve "libmutter-10.so=0-64", a dependency of "gnome-shell"
warning: cannot resolve "gnome-shell", a dependency of "gdm"
:: There are 2 providers available for libavcodec.so=59-64:
:: Repository archlinuxcn
   1) ffmpeg-vulkan
:: Repository extra
   2) ffmpeg

Enter a number (default=1):
:: There are 2 providers available for jack:
:: Repository extra
   1) jack2  2) pipewire-jack

Enter a number (default=1):
:: There are 3 providers available for emoji-font:
:: Repository archlinuxcn
   1) noto-fonts-emoji-blob
:: Repository extra
   2) noto-fonts-emoji
:: Repository community
   3) ttf-joypixels

Enter a number (default=1):
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "pipewire", a dependency of "gnome-remote-desktop"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "pipewire", a dependency of "mutter"
warning: cannot resolve "mutter", a dependency of "gnome-shell"
:: There are 2 providers available for pipewire-session-manager:
:: Repository extra
   1) pipewire-media-session  2) wireplumber

Enter a number (default=1):
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "pipewire>=0.3.39", a dependency of "pipewire-media-session"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "libpipewire-0.3.so=0-64", a dependency of "pipewire-media-session"
warning: cannot resolve "pipewire-session-manager", a dependency of "gst-plugin-pipewire"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "libpipewire-0.3.so=0-64", a dependency of "gst-plugin-pipewire"
warning: cannot resolve "gst-plugin-pipewire", a dependency of "gnome-shell"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "pipewire", a dependency of "mutter"
warning: cannot resolve "libmutter-10.so=0-64", a dependency of "gnome-shell"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "pipewire", a dependency of "mutter"
warning: cannot resolve "mutter", a dependency of "gnome-shell"
:: There are 2 providers available for pipewire-session-manager:
:: Repository extra
   1) pipewire-media-session  2) wireplumber

Enter a number (default=1):
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "pipewire>=0.3.39", a dependency of "pipewire-media-session"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "libpipewire-0.3.so=0-64", a dependency of "pipewire-media-session"
warning: cannot resolve "pipewire-session-manager", a dependency of "gst-plugin-pipewire"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "libpipewire-0.3.so=0-64", a dependency of "gst-plugin-pipewire"
warning: cannot resolve "gst-plugin-pipewire", a dependency of "gnome-shell"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "pipewire", a dependency of "mutter"
warning: cannot resolve "libmutter-10.so=0-64", a dependency of "gnome-shell"
warning: cannot resolve "gnome-shell", a dependency of "gnome-shell-extensions"
warning: cannot resolve "libsbc.so=1-64", a dependency of "pipewire"
warning: cannot resolve "pipewire", a dependency of "mutter"
:: There are 3 providers available for java-environment=11:
:: Repository archlinuxcn
   1) jdk11-graalvm-bin  2) liberica-jdk-11-full-bin
:: Repository extra
   3) jdk11-openjdk

Enter a number (default=1):
:: There are 2 providers available for java-runtime-openjdk=11:
:: Repository archlinuxcn
   1) liberica-jdk-11-full-bin
:: Repository extra
   2) jre11-openjdk

Enter a number (default=1):
:: There are 8 providers available for ttf-font:
:: Repository extra
   1) gnu-free-fonts  2) noto-fonts  3) ttf-bitstream-vera  4) ttf-croscore
:: Repository community
   5) ttf-dejavu  6) ttf-droid  7) ttf-ibm-plex  8) ttf-liberation

Enter a number (default=1):
:: The following packages cannot be upgraded due to unresolvable dependencies:
      gdm  gnome-remote-desktop  gnome-shell  gnome-shell-extensions  mutter

:: Do you want to skip the above packages for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'pipewire' required by mutter
:: unable to satisfy dependency 'mutter' required by gnome-shell
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'pipewire>=0.3.39' required by pipewire-media-session
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'libpipewire-0.3.so=0-64' required by pipewire-media-session
:: unable to satisfy dependency 'pipewire-session-manager' required by gst-plugin-pipewire
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'libpipewire-0.3.so=0-64' required by gst-plugin-pipewire
:: unable to satisfy dependency 'gst-plugin-pipewire' required by gnome-shell
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'pipewire' required by mutter
:: unable to satisfy dependency 'libmutter-10.so=0-64' required by gnome-shell
:: unable to satisfy dependency 'gnome-shell' required by gdm
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'pipewire' required by gnome-remote-desktop
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'pipewire' required by mutter
:: unable to satisfy dependency 'mutter' required by gnome-shell
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'pipewire>=0.3.39' required by pipewire-media-session
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'libpipewire-0.3.so=0-64' required by pipewire-media-session
:: unable to satisfy dependency 'pipewire-session-manager' required by gst-plugin-pipewire
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'libpipewire-0.3.so=0-64' required by gst-plugin-pipewire
:: unable to satisfy dependency 'gst-plugin-pipewire' required by gnome-shell
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'pipewire' required by mutter
:: unable to satisfy dependency 'libmutter-10.so=0-64' required by gnome-shell
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'pipewire' required by mutter
:: unable to satisfy dependency 'mutter' required by gnome-shell
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'pipewire>=0.3.39' required by pipewire-media-session
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'libpipewire-0.3.so=0-64' required by pipewire-media-session
:: unable to satisfy dependency 'pipewire-session-manager' required by gst-plugin-pipewire
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'libpipewire-0.3.so=0-64' required by gst-plugin-pipewire
:: unable to satisfy dependency 'gst-plugin-pipewire' required by gnome-shell
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'pipewire' required by mutter
:: unable to satisfy dependency 'libmutter-10.so=0-64' required by gnome-shell
:: unable to satisfy dependency 'gnome-shell' required by gnome-shell-extensions
:: unable to satisfy dependency 'libsbc.so=1-64' required by pipewire
:: unable to satisfy dependency 'pipewire' required by mutter
==> ERROR: Failed to install packages to new root

Offline

#2 2022-04-25 23:44:13

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,289
Website

Re: Problem when I generate ISO file with Archiso

Please edit your post and wrap the output in code tags: https://wiki.archlinux.org/title/Genera … s_and_code


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2022-04-25 23:59:07

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,812

Re: Problem when I generate ISO file with Archiso

What does `pacman -Si sbc` show?

It looks like you have archlinuxcn overriding core/extra/community. That's not a great idea, it should be below them.

Last edited by Scimmia (2022-04-26 00:00:59)

Offline

#4 2022-04-26 03:26:17

hackerHAO
Member
Registered: 2022-04-25
Posts: 2

Re: Problem when I generate ISO file with Archiso

Scimmia wrote:

What does `pacman -Si sbc` show?

It looks like you have archlinuxcn overriding core/extra/community. That's not a great idea, it should be below them.


----------------------------------
thanks i have solved it

Offline

Board footer

Powered by FluxBB