You are not logged in.

#1 2022-05-02 05:27:24

averageguy
Member
Registered: 2022-04-04
Posts: 3

cannot resolve "nvidia-utils=510.68.02", a dependency of "nvidia-lts"

Hello I tried to upgrade my system, but pacman -Syu dies with the following error

:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade...
:: Replace sdl with community/sdl12-compat? [Y/n] y
resolving dependencies...
warning: cannot resolve "nvidia-utils=510.68.02", a dependency of "nvidia-lts"
:: The following package cannot be upgraded due to unresolvable dependencies:
      nvidia-lts

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'nvidia-utils=510.68.02' required by nvidia-lts

Any idias what I can do? Thanks for help

Last edited by averageguy (2022-05-02 05:28:40)

Offline

#2 2022-05-02 05:40:15

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,999
Website

Re: cannot resolve "nvidia-utils=510.68.02", a dependency of "nvidia-lts"

Open a bug report. 68-02 is in [testing]


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2022-05-02 05:54:15

averageguy
Member
Registered: 2022-04-04
Posts: 3

Re: cannot resolve "nvidia-utils=510.68.02", a dependency of "nvidia-lts"

Hope I did it right, but here is the bug report: https://bugs.archlinux.org/task/74613

Offline

#4 2022-05-02 13:27:26

difri84
Member
Registered: 2021-12-09
Posts: 45

Re: cannot resolve "nvidia-utils=510.68.02", a dependency of "nvidia-lts"

i can confirm the bug, same issue. I'm not in testing and the package is the same version reported in the post

Offline

#5 2022-05-02 13:51:31

Master81
Member
Registered: 2022-01-12
Posts: 7

Re: cannot resolve "nvidia-utils=510.68.02", a dependency of "nvidia-lts"

I have the same issue.

:: Starting full system upgrade...
:: Replace sdl with community/sdl12-compat? [Y/n] 
resolving dependencies...
warning: cannot resolve "nvidia-utils=510.68.02", a dependency of "nvidia-lts"
:: The following package cannot be upgraded due to unresolvable dependencies:
      nvidia-lts

I'm on stable.

Last edited by Master81 (2022-05-02 13:52:06)

Offline

#6 2022-05-02 13:58:17

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,190

Re: cannot resolve "nvidia-utils=510.68.02", a dependency of "nvidia-lts"

yes which is the reason for the error. nvidia-lts was pushed out with the updated version from testing instead of being a plain rebuild of the previous version. If you don't want to wait you could rebuild nvidia-lts relevantly adjusted yourself or opt for nvidia-dkms and linux-lts-headers which will push the burden of the rebuild on your system but is generally less likely to run into disjoint issues like these.

Offline

Board footer

Powered by FluxBB