You are not logged in.

#1 2022-05-02 07:39:39

ds6pex
Member
Registered: 2022-03-14
Posts: 6

Pacstrap failed

Hi, I'm trying to install arch on my laptop.
But it keeps failed by pacstrap doesn't installed properly. And I guess it's because of PGP key.

Here is my picture of my log.
https://imgur.com/a/EHHI8zU

And here is my install log.
https://imgur.com/a/KMcJACc

Offline

#2 2022-05-02 07:54:05

Torxed
Member
Registered: 2013-01-10
Posts: 189

Re: Pacstrap failed

Hi.

I believe this is unrelated to archinstall unfortunately, and is a general issue with the Arch Linux ISO having an outdated keyring.
It presents itself when you get PGP signature issues on packages. The package is signed with either a really really old key that is no longer valid. But most likely a developer has signed the package with a new key that you don't have in your local `archlinux-keyring`.
You can try the following before running the installer or a manual install:

# pacman-key --init
# pacman -Sy archlinux-keyring

But most likely, using the latest ISO should also solve the issue and be better anyway.

Last edited by Torxed (2022-05-02 07:59:19)

Offline

Board footer

Powered by FluxBB