You are not logged in.

#1 2022-05-19 09:27:49

rep_movsd
Member
Registered: 2013-08-24
Posts: 115

Disabling a bad USB port on a Precision 7710 laptop

I have a Dell Precision 7710 which has developed some hardware issue with the USB ports

Two of the four USB ports on the laptop stopped functioning recenty - since then I see the "kworker" process eat up 84% CPU even when idle.

The other two ports work fine, but I rarely use anything except a wireless mouse.


If I run

sudo modprobe -r xhci_pci

the CPU problem goes away, and my touchpad and keyboard still work fine.
However I am used to using the mouse and want to find a way to circumvent the bad USBs

My question is - how do I selectively disable/poweroff the USB ports one by one to see if I can isolate the bad ones?
I believe this should be possible by power management or blacklisting somehow?

Thanks in advance

Offline

#2 2022-05-23 18:17:37

ua4000
Member
Registered: 2015-10-14
Posts: 259

Re: Disabling a bad USB port on a Precision 7710 laptop

This may or may not work for you:

run demsg and find the id of your specific usb device

May 23 19:44:46 kernel: usb 1-4.2: new high-speed USB device number 9 using ehci-pci
May 23 19:44:54 kernel: usb 1-4.2: New USB device found, idVendor=xxxx, idProduct=xxxx, bcdDevice= 0.01
May 23 19:44:54 kernel: usb 1-4.2: New USB device strings: Mfr=2, Product=3, SerialNumber=1
May 23 19:44:54 kernel: usb 1-4.2: Product: AS2105
May 23 19:44:54 kernel: usb 1-4.2: Manufacturer: ASMedia

with "id" I mean the digit 1-4.2 in this example.

Then try to unbind your usb port:

echo '1-4.2' | sudo tee /sys/bus/usb/drivers/usb/unbind

Offline

Board footer

Powered by FluxBB