You are not logged in.

#1 2022-06-06 18:31:25

moghaazi
Member
From: Egypt
Registered: 2021-03-02
Posts: 7

[Solved] I get this error while installing lapce 0.1.1-1 package from

warning: unused imports: `MenuItem`, `Menu`, `SysMods`
 --> lapce-ui/src/app.rs:2:69
  |
2 |     AppDelegate, AppLauncher, Command, Env, Event, LocalizedString, Menu, MenuItem,
  |                                                                     ^^^^  ^^^^^^^^
3 |     Point, Size, SysMods, Widget, WidgetExt, WindowDesc, WindowHandle, WindowId,
  |                  ^^^^^^^
  |
  = note: `#[warn(unused_imports)]` on by default

warning: unused imports: `WindowConfig`, `WindowState`
 --> lapce-ui/src/title.rs:9:32
  |
9 |     Target, UpdateCtx, Widget, WindowConfig, WindowState,
  |                                ^^^^^^^^^^^^  ^^^^^^^^^^^

warning: unused variable: `data`
  --> lapce-ui/src/title.rs:65:9
   |
65 |         data: &mut LapceWindowData,
   |         ^^^^ help: if this is intentional, prefix it with an underscore: `_data`
   |
   = note: `#[warn(unused_variables)]` on by default

warning: variable does not need to be mutable
  --> lapce-ui/src/app.rs:66:9
   |
66 |     let mut desc = WindowDesc::new_with_id(window_id, root)
   |         ----^^^^
   |         |
   |         help: remove this `mut`
   |
   = note: `#[warn(unused_mut)]` on by default

warning: `lapce-ui` (lib) generated 4 warnings
   Compiling lapce v0.1.1 (/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1)
error: could not compile `lapce`

Caused by:
  process didn't exit successfully: `rustc --crate-name lapce --edition=2021 lapce-ui/src/bin/lapce.rs --error-format=json --json=diagnostic-rendered-ansi,artifacts,future-incompat --crate-type bin --emit=dep-info,link -C opt-level=3 -C lto -C codegen-units=1 -C metadata=4805f115b0a54622 -C extra-filename=-4805f115b0a54622 --out-dir /home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/deps -L dependency=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/deps --extern lapce_proxy=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/deps/liblapce_proxy-b5405a0f14c1a394.rlib --extern lapce_ui=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/deps/liblapce_ui-2976e615fb7633a5.rlib -L native=/usr/lib -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/libssh2-sys-f86f8bee825a1647/out/build -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/openssl-sys-2e57765c870645c0/out/openssl-build/install/lib -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/ring-1cca7909ddaae6c8/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/wasmer-vm-a229fdd40b065e11/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/gl_loader-7e4c3590b70375fc/out -L native=/usr/lib -L native=/usr/lib -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-b13563a74a922b1c/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-c-de42f0da29bd8520/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-cpp-664ca30bf360494d/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-cpp-664ca30bf360494d/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-elixir-54df48201235a935/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-elixir-54df48201235a935/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-go-55e94f6af8561e91/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-html-0a9774aaf14063ad/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-html-0a9774aaf14063ad/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-java-222f455d232dcd36/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-javascript-f26fd76caba4ff65/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-json-60df5ed978c03714/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-md-7715d40ab7c9f109/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-md-7715d40ab7c9f109/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-php-4077d0d4f4db34d8/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-php-4077d0d4f4db34d8/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-python-b97056f0dd3063fd/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-python-b97056f0dd3063fd/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-ruby-0bf5b31342a21866/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-ruby-0bf5b31342a21866/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-rust-7e8a6577c395cd76/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-toml-203c126b50502c72/out -L native=/home/moghaazi/.cache/paru/clone/lapce/src/lapce-0.1.1/target/release-lto/build/tree-sitter-typescript-710ee140ae2e00f0/out` (signal: 9, SIGKILL: kill)
warning: build failed, waiting for other jobs to finish...
==> ERROR: A failure occurred in build().
    Aborting...
error: failed to build 'lapce-0.1.1-1':
error: packages failed to build: lapce-0.1.1-1

Last edited by moghaazi (2022-06-06 19:28:04)

Offline

#2 2022-06-06 18:40:18

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,334

Re: [Solved] I get this error while installing lapce 0.1.1-1 package from

Please edit your first post to use [⁣code] [/⁣code] tags around all commands and their outputs...
https://wiki.archlinux.org/title/Genera … s_and_code

Also take the AUR helper out of the equation and post a full log from using makepkg instead, but a SIGKILL suggests that you ended the process before it was finished.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2022-06-06 19:27:13

moghaazi
Member
From: Egypt
Registered: 2021-03-02
Posts: 7

Re: [Solved] I get this error while installing lapce 0.1.1-1 package from

I installed the lapce-bin version and it's working

Offline

#4 2022-06-06 19:37:27

loqs
Member
Registered: 2014-03-06
Posts: 14,869

Re: [Solved] I get this error while installing lapce 0.1.1-1 package from

   Compiling proc-macro2 v1.0.36
   Compiling unicode-xid v0.2.2
   Compiling syn v1.0.86
   Compiling libc v0.2.121
   Compiling cfg-if v1.0.0
   Compiling version_check v0.9.3
   Compiling autocfg v1.0.1
   Compiling pkg-config v0.3.19
   Compiling once_cell v1.10.0
   Compiling memchr v2.4.1
   Compiling anyhow v1.0.43
   Compiling serde_derive v1.0.130
   Compiling serde v1.0.130
   Compiling bitflags v1.3.2
   Compiling log v0.4.14
   Compiling unicode-segmentation v1.8.0
   Compiling smallvec v1.6.1
   Compiling either v1.6.1
   Compiling version-compare v0.0.11
   Compiling strum v0.21.0
   Compiling lazy_static v1.4.0
   Compiling regex-syntax v0.6.25
   Compiling adler v1.0.2
   Compiling stable_deref_trait v1.2.0
   Compiling fallible-iterator v0.2.0
   Compiling slab v0.4.4
   Compiling crc32fast v1.2.1
   Compiling pin-project-lite v0.2.7
   Compiling ucd-trie v0.1.3
   Compiling matches v0.1.9
   Compiling rustversion v1.0.6
   Compiling rustc-demangle v0.1.21
   Compiling bytecheck v0.6.7
   Compiling crossbeam-utils v0.8.5
   Compiling strsim v0.10.0
   Compiling ident_case v1.0.1
   Compiling fnv v1.0.7
   Compiling futures-core v0.3.21
   Compiling rend v0.3.6
   Compiling unicode-bidi v0.3.6
   Compiling scopeguard v1.1.0
   Compiling same-file v1.0.6
   Compiling rkyv v0.7.28
   Compiling futures-task v0.3.21
   Compiling arrayvec v0.5.2
   Compiling seahash v4.1.0
   Compiling target-lexicon v0.12.2
   Compiling futures-util v0.3.21
   Compiling proc-macro-hack v0.5.19
   Compiling pin-utils v0.1.0
   Compiling ryu v1.0.5
   Compiling futures-channel v0.3.21
   Compiling typenum v1.13.0
   Compiling byteorder v1.4.3
   Compiling rustc-hash v1.1.0
   Compiling cfg-if v0.1.10
   Compiling tinyvec_macros v0.1.0
   Compiling crossbeam-epoch v0.9.5
   Compiling more-asserts v0.2.2
   Compiling cranelift-entity v0.76.0
   Compiling serde_json v1.0.67
   Compiling cranelift-codegen-shared v0.76.0
   Compiling wasmparser v0.78.2
   Compiling xmlparser v0.13.3
   Compiling base64 v0.13.0
   Compiling unicode-bidi-mirroring v0.1.0
   Compiling percent-encoding v2.1.0
   Compiling rayon-core v1.9.1
   Compiling unicode-script v0.5.3
   Compiling linked-hash-map v0.5.4
   Compiling parking_lot_core v0.8.5
   Compiling unicode-general-category v0.4.0
   Compiling fixedbitset v0.2.0
   Compiling unicode-ccc v0.1.2
   Compiling itoa v0.4.8
   Compiling arrayvec v0.7.2
   Compiling unic-char-range v0.9.0
   Compiling unic-common v0.9.0
   Compiling adler32 v1.2.0
   Compiling spin v0.5.2
   Compiling gio v0.14.8
   Compiling ttf-parser v0.15.0
   Compiling tinystr v0.3.4
   Compiling const-cstr v0.3.0
   Compiling leb128 v0.2.5
   Compiling font-kit v0.11.0 (https://github.com/lapce/font-kit#23e28b06)
   Compiling untrusted v0.7.1
   Compiling unicode-width v0.1.8
   Compiling pico-args v0.4.2
   Compiling const_fn v0.4.8
   Compiling siphasher v0.3.10
   Compiling zeno v0.2.2
   Compiling float-cmp v0.9.0
   Compiling unicode-vo v0.1.0
   Compiling float-ord v0.2.0
   Compiling futures-io v0.3.21
   Compiling yazi v0.1.4
   Compiling xmlwriter v0.1.0
   Compiling unicode-general-category v0.2.0
   Compiling weezl v0.1.6
   Compiling signal-hook v0.3.13
   Compiling encoding_rs v0.8.30
   Compiling arrayref v0.3.6
   Compiling fastrand v1.7.0
   Compiling wasmer-compiler-cranelift v2.1.1
   Compiling color_quant v1.1.0
   Compiling rctree v0.4.0
   Compiling bytecount v0.6.2
   Compiling lazycell v1.3.0
   Compiling remove_dir_all v0.5.3
   Compiling glob v0.3.0
   Compiling rustls v0.20.4
   Compiling Inflector v0.11.4
   Compiling lexical-core v0.7.6
   Compiling jpeg-decoder v0.2.4
   Compiling opaque-debug v0.3.0
   Compiling cpufeatures v0.2.1
   Compiling druid-shell v0.7.0 (https://github.com/lapce/druid?branch=shell_opengl#e4ddc00f)
   Compiling static_assertions v1.1.0
   Compiling num_threads v0.1.6
   Compiling ttf-parser v0.12.3
   Compiling glow v0.11.2
   Compiling utf8parse v0.2.0
   Compiling siphasher v0.2.3
   Compiling dtoa v0.4.8
   Compiling rand_core v0.5.1
   Compiling ttf-parser v0.9.0
   Compiling float-cmp v0.5.3
   Compiling pulldown-cmark v0.9.1
   Compiling serde v0.8.23
   Compiling rctree v0.3.3
   Compiling chunked_transfer v1.4.0
   Compiling openssl-probe v0.1.4
   Compiling heck v0.4.0
   Compiling ansi_term v0.12.1
   Compiling xi-unicode v0.3.0
   Compiling home v0.5.3
   Compiling strum v0.24.0
   Compiling rust-ini v0.13.0
   Compiling bit-vec v0.5.1
   Compiling diff v0.1.12
   Compiling libloading v0.7.0
   Compiling instant v0.1.10
   Compiling keyboard-types v0.6.2
   Compiling tracing-core v0.1.26
   Compiling sharded-slab v0.1.3
   Compiling data-url v0.1.0
   Compiling miniz_oxide v0.5.1
   Compiling itertools v0.10.3
   Compiling thread_local v1.1.3
   Compiling pest v2.1.3
   Compiling lock_api v0.4.5
   Compiling cfg-expr v0.8.1
   Compiling walkdir v2.3.2
   Compiling tinyvec v1.3.1
   Compiling generational-arena v0.2.8
   Compiling type-map v0.4.0
   Compiling ahash v0.7.6
   Compiling proc-macro-error-attr v1.0.4
   Compiling proc-macro-error v1.0.4
   Compiling generic-array v0.14.4
   Compiling standback v0.2.17
   Compiling glam v0.10.2
   Compiling time v0.2.27
   Compiling unicase v2.6.0
   Compiling im v15.0.0
   Compiling nom v5.1.2
   Compiling heck v0.3.3
   Compiling indexmap v1.7.0
   Compiling miniz_oxide v0.4.4
   Compiling memoffset v0.6.4
   Compiling num-traits v0.2.14
   Compiling rayon v1.5.1
   Compiling num-integer v0.1.44
   Compiling form_urlencoded v1.0.1
   Compiling unic-char-property v0.9.0
   Compiling fxhash v0.2.1
   Compiling unic-ucd-version v0.9.0
   Compiling yaml-rust v0.4.5
   Compiling cranelift-codegen-meta v0.76.0
   Compiling deflate v1.0.0
   Compiling getopts v0.2.21
   Compiling wast v38.0.1
   Compiling yeslogic-fontconfig-sys v3.0.1
   Compiling gtk v0.14.3
   Compiling unic-langid-impl v0.9.0
   Compiling roxmltree v0.14.1
   Compiling cranelift-bforest v0.76.0
   Compiling svgtypes v0.8.0
   Compiling gif v0.11.3
   Compiling svgtypes v0.5.0
   Compiling rand_xoshiro v0.4.0
   Compiling dlib v0.5.0
   Compiling swash v0.1.4 (https://github.com/lapce/swash#1d9b8c70)
   Compiling fuzzy-matcher v0.3.7
   Compiling unic-ucd-bidi v0.9.0
   Compiling semver-parser v0.10.2
   Compiling unic-langid v0.9.0
   Compiling tracing-subscriber v0.3.6
   Compiling regex-automata v0.1.10
   Compiling fontconfig-parser v0.5.0
   Compiling regalloc v0.0.31
   Compiling simplecss v0.2.1
   Compiling fern v0.6.0
   Compiling unicode-normalization v0.1.19
   Compiling png v0.17.5
   Compiling crossbeam-channel v0.5.1
   Compiling aho-corasick v0.7.18
   Compiling object v0.26.2
   Compiling grep-matcher v0.1.5
   Compiling quote v1.0.15
   Compiling unic-bidi v0.9.0
   Compiling jobserver v0.1.24
   Compiling fluent-langneg v0.13.0
   Compiling intl-memoizer v0.5.1
   Compiling intl_pluralrules v7.0.1
   Compiling semver v0.11.0
   Compiling bitmaps v2.1.0
   Compiling bstr v0.2.17
   Compiling getrandom v0.2.3
   Compiling memmap2 v0.5.3
   Compiling region v3.0.0
   Compiling net2 v0.2.37
   Compiling inotify-sys v0.1.5
   Compiling iovec v0.1.4
   Compiling thread-id v4.0.0
   Compiling dirs-sys-next v0.1.2
   Compiling num_cpus v1.13.1
   Compiling filetime v0.2.15
   Compiling tempfile v3.3.0
   Compiling signal-hook-registry v1.4.0
   Compiling dirs-sys v0.3.6
   Compiling mio v0.8.2
   Compiling which v4.2.5
   Compiling memmap2 v0.2.3
   Compiling nix v0.22.3
   Compiling memmap2 v0.3.1
   Compiling time v0.3.9
   Compiling fs2 v0.4.3
   Compiling time v0.1.44
   Compiling vte_generate_state_changes v0.1.1
   Compiling cc v1.0.69
   Compiling regex v1.5.4
   Compiling flate2 v1.0.22
   Compiling idna v0.2.3
   Compiling encoding_rs_io v0.1.7
   Compiling rustc_version v0.3.3
   Compiling crossbeam-deque v0.8.1
   Compiling uuid v0.8.2
   Compiling fontdb v0.9.1
   Compiling digest v0.9.0
   Compiling block-buffer v0.9.0
   Compiling inotify v0.9.6
   Compiling inotify v0.7.1
   Compiling euclid v0.22.6
   Compiling sid v0.6.1
   Compiling float_next_after v0.1.5
   Compiling num-traits v0.1.43
   Compiling mio v0.6.23
   Compiling dirs-next v2.0.0
   Compiling dirs v3.0.2
   Compiling directories v4.0.1
   Compiling fontdb v0.5.4
   Compiling wat v1.0.40
   Compiling grep-searcher v0.1.8
   Compiling futures-executor v0.3.21
   Compiling toml v0.5.8
   Compiling hashbrown v0.11.2
   Compiling vte v0.10.1
   Compiling pathfinder_simd v0.5.1
   Compiling field-offset v0.3.4
   Compiling sha2 v0.9.8
   Compiling cmake v0.1.45
   Compiling openssl-src v111.16.0+1.1.1l
   Compiling chrono v0.4.19
   Compiling globset v0.4.8
   Compiling locale_config v0.3.0
   Compiling serde-hjson v0.9.1
   Compiling grep-regex v0.1.9
   Compiling mio-extras v2.0.6
   Compiling mio-uds v0.6.8
   Compiling lyon_geom v0.17.5
   Compiling tree-sitter v0.20.6
   Compiling backtrace v0.3.61
   Compiling wasmer-vm v2.1.1
   Compiling ring v0.16.20
   Compiling libz-sys v1.1.3
   Compiling libssh2-sys v0.2.21
   Compiling gl_loader v0.1.2
   Compiling libgit2-sys v0.12.24+1.3.0
   Compiling tree-sitter-javascript v0.20.0
   Compiling tree-sitter-json v0.19.0
   Compiling tree-sitter-python v0.19.1
   Compiling tree-sitter-elixir v0.19.0 (https://github.com/elixir-lang/tree-sitter-elixir.git#60863fc6)
   Compiling tree-sitter-c v0.20.1
   Compiling tree-sitter-cpp v0.20.0
   Compiling tree-sitter-ruby v0.19.0 (https://github.com/Liberatys/tree-sitter-ruby.git?branch=chore/allow-range-of-tree-sitter#26086eeb)
   Compiling tree-sitter-go v0.19.1
   Compiling tree-sitter-toml v0.20.0
   Compiling tree-sitter-html v0.19.0
   Compiling tree-sitter-java v0.20.0 (https://github.com/tree-sitter/tree-sitter-java.git#e7cb801e)
   Compiling tree-sitter-rust v0.20.0
   Compiling tree-sitter-md v0.0.1 (https://github.com/MDeiml/tree-sitter-markdown.git#6d112e7a)
   Compiling tree-sitter-typescript v0.20.0
   Compiling tree-sitter-php v0.19.1 (https://github.com/tree-sitter/tree-sitter-php.git#ead3e4cc)
   Compiling openssl-sys v0.9.72
   Compiling sized-chunks v0.6.5
   Compiling freetype-sys v0.13.1
   Compiling ignore v0.4.18
   Compiling notify v4.0.17
   Compiling signal-hook-mio v0.2.1
   Compiling lyon_path v0.17.6
   Compiling hotwatch v0.4.6
   Compiling lyon_tessellation v0.17.9
   Compiling lyon_algorithms v0.17.5
   Compiling pathfinder_geometry v0.5.1
   Compiling darling_core v0.13.1
   Compiling freetype v0.7.0
   Compiling lyon v0.17.5
   Compiling fount v0.1.0 (https://github.com/lapce/fount#bfe215c0)
   Compiling parley v0.1.0 (https://github.com/lapce/parley#eb4a912c)
   Compiling cranelift-codegen v0.76.0
   Compiling thiserror-impl v1.0.28
   Compiling strum_macros v0.21.1
   Compiling ptr_meta_derive v0.1.4
   Compiling bytecheck_derive v0.6.7
   Compiling bytemuck_derive v1.0.1
   Compiling loupe-derive v0.1.3
   Compiling rkyv_derive v0.7.28
   Compiling tracing-attributes v0.1.15
   Compiling time-macros-impl v0.1.2
   Compiling serde_repr v0.1.7
   Compiling include_dir_impl v0.6.1
   Compiling ouroboros_macro v0.9.5
   Compiling wasmer-derive v2.1.1
   Compiling alacritty_config_derive v0.1.0
   Compiling druid-derive v0.4.0 (https://github.com/lapce/druid?branch=shell_opengl#e4ddc00f)
   Compiling strum_macros v0.24.0
   Compiling darling_macro v0.13.1
   Compiling webpki v0.22.0
   Compiling sct v0.7.0
   Compiling ptr_meta v0.1.4
   Compiling webpki-roots v0.22.2
   Compiling bytemuck v1.8.0
   Compiling safe_arch v0.5.2
   Compiling rgb v0.8.32
   Compiling rustybuzz v0.5.0
   Compiling rustybuzz v0.3.0
   Compiling include_dir v0.6.1
   Compiling time-macros v0.1.1
   Compiling svgfilters v0.4.0
   Compiling tiny-skia v0.6.3
   Compiling darling v0.13.1
   Compiling enumset_derive v0.5.5
   Compiling structdesc v0.1.0 (https://github.com/lapce/structdesc#a6a2b8ab)
   Compiling thiserror v1.0.28
   Compiling system-deps v3.2.0
   Compiling proc-macro-crate v1.0.0
   Compiling fluent-syntax v0.11.0
   Compiling tracing v0.1.26
   Compiling ouroboros v0.9.5
   Compiling glib-macros v0.14.1
   Compiling gtk3-macros v0.14.0
   Compiling wasmer-vfs v2.1.1
   Compiling fluent-bundle v0.15.1
   Compiling glib-sys v0.14.0
   Compiling gobject-sys v0.14.0
   Compiling gio-sys v0.14.0
   Compiling pango-sys v0.14.0
   Compiling cairo-sys-rs v0.14.9
   Compiling gdk-pixbuf-sys v0.14.0
   Compiling gdk-sys v0.14.0
   Compiling atk-sys v0.14.0
   Compiling gtk-sys v0.14.0
   Compiling enumset v1.0.8
   Compiling glib v0.14.8
   Compiling tree-sitter-highlight v0.20.1
   Compiling serde_bytes v0.11.5
   Compiling kurbo v0.8.3
   Compiling url v2.2.2
   Compiling xi-rope v0.3.0 (https://github.com/lapce/xi-editor#5578c725)
   Compiling notify v5.0.0-pre.15
   Compiling gimli v0.25.0
   Compiling loupe v0.1.3
   Compiling petgraph v0.5.1
   Compiling object v0.27.1
   Compiling serde_yaml v0.8.21
   Compiling wasmer-types v2.1.1
   Compiling lsp-types v0.89.2
   Compiling jsonrpc-lite v0.5.0
   Compiling ureq v2.4.0
   Compiling usvg v0.22.0
   Compiling piet v0.4.0
   Compiling usvg v0.14.1
   Compiling pango v0.14.8
   Compiling cairo-rs v0.14.9
   Compiling atk v0.14.0
   Compiling config v0.11.0
   Compiling resvg v0.22.0
   Compiling piet-wgpu v0.1.0 (https://github.com/lapce/piet-wgpu?branch=shell_opengl#6e268b3b)
   Compiling wasmer-wasi-types v2.1.1
   Compiling addr2line v0.16.0
   Compiling parking_lot v0.11.2
   Compiling git2 v0.13.23
   Compiling alacritty_terminal v0.16.1
   Compiling sled v0.34.7
   Compiling wasmer-compiler v2.1.1
   Compiling wasmer-engine v2.1.1
   Compiling wasmer-object v2.1.1
   Compiling wasmer-engine-dylib v2.1.1
   Compiling wasmer-engine-universal v2.1.1
   Compiling lapce-rpc v0.1.1 (/build/lapce/src/lapce-0.1.1/lapce-rpc)
   Compiling lapce-core v0.1.1 (/build/lapce/src/lapce-0.1.1/lapce-core)
   Compiling gdk-pixbuf v0.14.0
   Compiling gdk v0.14.3
   Compiling cranelift-frontend v0.76.0
   Compiling wasmer v2.1.1
   Compiling druid v0.7.0 (https://github.com/lapce/druid?branch=shell_opengl#e4ddc00f)
   Compiling wasmer-wasi v2.1.1
   Compiling lapce-proxy v0.1.1 (/build/lapce/src/lapce-0.1.1/lapce-proxy)
   Compiling lapce-data v0.1.1 (/build/lapce/src/lapce-0.1.1/lapce-data)
   Compiling lapce-ui v0.1.1 (/build/lapce/src/lapce-0.1.1/lapce-ui)
warning: unused imports: `MenuItem`, `Menu`, `SysMods`
 --> lapce-ui/src/app.rs:2:69
  |
2 |     AppDelegate, AppLauncher, Command, Env, Event, LocalizedString, Menu, MenuItem,
  |                                                                     ^^^^  ^^^^^^^^
3 |     Point, Size, SysMods, Widget, WidgetExt, WindowDesc, WindowHandle, WindowId,
  |                  ^^^^^^^
  |
  = note: `#[warn(unused_imports)]` on by default

warning: unused imports: `WindowConfig`, `WindowState`
 --> lapce-ui/src/title.rs:9:32
  |
9 |     Target, UpdateCtx, Widget, WindowConfig, WindowState,
  |                                ^^^^^^^^^^^^  ^^^^^^^^^^^

warning: unused variable: `data`
  --> lapce-ui/src/title.rs:65:9
   |
65 |         data: &mut LapceWindowData,
   |         ^^^^ help: if this is intentional, prefix it with an underscore: `_data`
   |
   = note: `#[warn(unused_variables)]` on by default

warning: variable does not need to be mutable
  --> lapce-ui/src/app.rs:66:9
   |
66 |     let mut desc = WindowDesc::new_with_id(window_id, root)
   |         ----^^^^
   |         |
   |         help: remove this `mut`
   |
   = note: `#[warn(unused_mut)]` on by default

warning: `lapce-ui` (lib) generated 4 warnings
   Compiling lapce v0.1.1 (/build/lapce/src/lapce-0.1.1)
    Finished release-lto [optimized] target(s) in 6m 45s

Took over 5 minutes on the final compile step without any update.  Which you may have interpreted as the build hanging.

Offline

Board footer

Powered by FluxBB