You are not logged in.

#1 2022-06-17 14:55:04

Kabir
Member
From: India
Registered: 2016-12-06
Posts: 59

[SOLVED] Sound fails after waking from hibernation on 5.18 kernel

Hi,

When using kernel 5.18 there's no audio after waking from hibernation. This isn't the case while using the LTS kernel and after system suspend on either kernel. The DE on the system is GNOME

sound controller:

0000:00:1f.3 Multimedia audio controller: Intel Corporation Tiger Lake-LP Smart Sound Technology Audio Controller (rev 20)
	Subsystem: Hewlett-Packard Company Device 881d
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 32, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 150
	Region 0: Memory at 6003220000 (64-bit, non-prefetchable) [size=16K]
	Region 4: Memory at 6003000000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: <access denied>
	Kernel driver in use: sof-audio-pci-intel-tgl
	Kernel modules: snd_hda_intel, snd_sof_pci_intel_tgl

logs after waking from hibernation

Jun 17 20:08:30 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump start ]------------
Jun 17 20:08:30 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware boot failure due to timeout
Jun 17 20:08:30 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: fw_state: SOF_FW_BOOT_IN_PROGRESS (2)
Jun 17 20:08:30 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: invalid header size 0xffffffff. FW oops is bogus
Jun 17 20:08:30 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: unexpected fault 0x00000000 trace 0x00000000
Jun 17 20:08:30 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump end ]------------
Jun 17 20:08:30 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to boot DSP firmware after resume -5
Jun 17 20:08:30 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: PM: dpm_run_callback(): pci_pm_restore+0x0/0xe0 returns -5
Jun 17 20:08:30 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: PM: failed to restore async: error -5

Jun 17 20:08:44 kabirsarch pulseaudio[929]: Error opening PCM device _ucm0001.hw:sofhdadsp: Input/output error
Jun 17 20:08:44 kabirsarch pulseaudio[929]: Failed to create sink input: sink is suspended.
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump start ]------------
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware boot failure due to timeout
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: fw_state: SOF_FW_BOOT_IN_PROGRESS (2)
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: invalid header size 0xffffffff. FW oops is bogus
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: unexpected fault 0x00000000 trace 0x00000000
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump end ]------------
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to boot DSP firmware after resume -5
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00:1f.3: -5
Jun 17 20:08:44 kabirsarch kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-5)
Jun 17 20:08:44 kabirsarch kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-5)
Jun 17 20:08:44 kabirsarch kernel:  HDA Analog: dpcm_fe_dai_startup() failed (-5)
Jun 17 20:08:44 kabirsarch pulseaudio[929]: Error opening PCM device _ucm0001.hw:sofhdadsp: Invalid argument
Jun 17 20:08:44 kabirsarch pulseaudio[929]: Error opening PCM device _ucm0001.hw:sofhdadsp: Invalid argument
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00:1f.3: -22
Jun 17 20:08:44 kabirsarch kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-22)
Jun 17 20:08:44 kabirsarch kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-22)
Jun 17 20:08:44 kabirsarch kernel:  HDA Analog: dpcm_fe_dai_startup() failed (-22)
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00:1f.3: -22
Jun 17 20:08:44 kabirsarch kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-22)
Jun 17 20:08:44 kabirsarch kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-22)
Jun 17 20:08:44 kabirsarch kernel:  HDA Analog: dpcm_fe_dai_startup() failed (-22)
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00:1f.3: -22
Jun 17 20:08:44 kabirsarch kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-22)
Jun 17 20:08:44 kabirsarch kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-22)
Jun 17 20:08:44 kabirsarch kernel:  HDA Analog: dpcm_fe_dai_startup() failed (-22)
Jun 17 20:08:44 kabirsarch pulseaudio[929]: Error opening PCM device _ucm0001.hw:sofhdadsp: Invalid argument
Jun 17 20:08:44 kabirsarch pulseaudio[929]: Failed to create sink input: sink is suspended.
Jun 17 20:08:44 kabirsarch pulseaudio[929]: Error opening PCM device _ucm0001.hw:sofhdadsp: Invalid argument
Jun 17 20:08:44 kabirsarch kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00:1f.3: -22
Jun 17 20:08:44 kabirsarch kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-22)
Jun 17 20:08:44 kabirsarch kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-22)

I'm not sure if there's any other package I need or any file I need to edit to get it to work?
Any help if much appreciated.

Thanks!

Last edited by Kabir (2022-06-25 17:57:26)

Offline

#2 2022-06-17 15:29:24

logothete
Member
Registered: 2022-01-06
Posts: 43

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

Having the same issue with the same card but with a slightly different error; it yells at me about a widget:

sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to setup widget PIPELINE.9.HDA6.OUT

about 30 times, after the log you posted.

I've been having this trouble for months now, myself, so it isn't kernel 5.18, or kernel 5.17, and it isn't related to either the zen or standard arch kernels. No commands I have found seem able to activate the sound card, even though my DE at least still knows its there but off.

Last edited by logothete (2022-06-17 15:31:59)

Offline

#3 2022-06-19 11:03:52

Kabir
Member
From: India
Registered: 2016-12-06
Posts: 59

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

Any idea what else I could try? I tried unloading and loading the kernel module as suggested in another thread but that didn't fix it.

# rmod snd_sof_pci_intel_tgl 
# modprobe snd_sof_pci_intel_tgl

Thanks!

Offline

#4 2022-06-20 17:20:29

skrat
Member
Registered: 2013-05-10
Posts: 38

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

Same issue here, first this

Jun 20 11:12:48 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump start ]------------
Jun 20 11:12:48 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware boot failure due to timeout
Jun 20 11:12:48 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: fw_state: SOF_FW_BOOT_IN_PROGRESS (2)
Jun 20 11:12:48 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: invalid header size 0xffffffff. FW oops is bogus
Jun 20 11:12:48 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: unexpected fault 0x00000000 trace 0x00000000
Jun 20 11:12:48 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump end ]------------
Jun 20 11:12:48 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to boot DSP firmware after resume -5
Jun 20 11:12:48 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: PM: dpm_run_callback(): pci_pm_restore+0x0/0x1b0 returns -5
Jun 20 11:12:48 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: PM: failed to restore async: error -5

Then this

Jun 20 11:13:16 crowsnest pipewire[987]: spa.alsa: '_ucm0001.hw:sofhdadsp': playback open failed: Input/output error
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump start ]------------
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware boot failure due to timeout
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: fw_state: SOF_FW_BOOT_IN_PROGRESS (2)
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: invalid header size 0xffffffff. FW oops is bogus
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: unexpected fault 0x00000000 trace 0x00000000
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump end ]------------
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to boot DSP firmware after resume -5
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00>
Jun 20 11:13:16 crowsnest kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-5)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-5)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: dpcm_fe_dai_startup() failed (-5)
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00>
Jun 20 11:13:16 crowsnest kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-22)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-22)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: dpcm_fe_dai_startup() failed (-22)
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00>
Jun 20 11:13:16 crowsnest kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-22)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-22)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: dpcm_fe_dai_startup() failed (-22)
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00>
Jun 20 11:13:16 crowsnest kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-22)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-22)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: dpcm_fe_dai_startup() failed (-22)
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00>
Jun 20 11:13:16 crowsnest kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-22)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-22)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: dpcm_fe_dai_startup() failed (-22)
Jun 20 11:13:16 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00>
Jun 20 11:13:16 crowsnest kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-22)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-22)
Jun 20 11:13:16 crowsnest kernel:  HDA Analog: dpcm_fe_dai_startup() failed (-22)
Jun 20 11:13:16 crowsnest pipewire[987]: spa.alsa: '_ucm0001.hw:sofhdadsp': playback open failed: Invalid argument
Jun 20 11:13:16 crowsnest pipewire[987]: spa.audioadapter: params Spa:Enum:ParamId:EnumFormat: 0:0 (follower format) Invalid argument
Jun 20 11:13:16 crowsnest pipewire[987]: spa.audioadapter: there was no filter
Jun 20 11:13:16 crowsnest pipewire[987]: spa.alsa: '_ucm0001.hw:sofhdadsp': playback open failed: Invalid argument
Jun 20 11:13:16 crowsnest pipewire[987]: spa.audioadapter:   error: Invalid argument
Jun 20 11:13:16 crowsnest pipewire[987]: spa.audioadapter: could not get any follower format
Jun 20 11:13:16 crowsnest pipewire[987]: pw.node: (alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink->
Jun 20 11:13:16 crowsnest pipewire[987]: spa.alsa: '_ucm0001.hw:sofhdadsp': playback open failed: Invalid argument
Jun 20 11:13:16 crowsnest pipewire[987]: spa.alsa: '_ucm0001.hw:sofhdadsp': playback open failed: Invalid argument
Jun 20 11:13:16 crowsnest pipewire[987]: spa.audioadapter: params Spa:Enum:ParamId:EnumFormat: 0:0 (follower format) Invalid argument
Jun 20 11:13:16 crowsnest pipewire[987]: spa.audioadapter: there was no filter
Jun 20 11:13:16 crowsnest pipewire[987]: spa.alsa: '_ucm0001.hw:sofhdadsp': playback open failed: Invalid argument
Jun 20 11:13:16 crowsnest pipewire[987]: spa.audioadapter:   error: Invalid argument
Jun 20 11:13:16 crowsnest pipewire[987]: spa.audioadapter: could not get any follower format
Jun 20 11:13:19 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00>
Jun 20 11:13:19 crowsnest kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-22)
Jun 20 11:13:19 crowsnest kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-22)
Jun 20 11:13:19 crowsnest kernel:  HDA Analog: dpcm_fe_dai_startup() failed (-22)
Jun 20 11:13:19 crowsnest kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_pm_runtime_get on 0000:00>
Jun 20 11:13:19 crowsnest kernel:  Analog Playback and Capture: __soc_pcm_open() failed (-22)
Jun 20 11:13:19 crowsnest kernel:  HDA Analog: ASoC: dpcm_be_dai_startup() failed at Analog Playback and Capture (-22)

Offline

#5 2022-06-20 19:34:24

logothete
Member
Registered: 2022-01-06
Posts: 43

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

From the looks of it, we all have a different part fail out on us, but the uniting factor is that little bit from the DSP dump (and also the 0000:00:1f.3:  ID for the card).
Which looks to me like there's some line of code somewhere that isn't waiting long enough for the card to be reactivated; some countdown is reached, and each of us, on a slightly different machine, is at a different spot when that countdown is done. There doesn't seem to be some single component that hangs.

The question is, then: What controls this?


My logs, for reference, with non-relevant things yanked out.

[13469.009809] sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump start ]------------
[13469.009815] sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware boot failure due to timeout
[13469.009818] sof-audio-pci-intel-tgl 0000:00:1f.3: fw_state: SOF_FW_BOOT_IN_PROGRESS (2)
[13469.009917] sof-audio-pci-intel-tgl 0000:00:1f.3: invalid header size 0xffffffff. FW oops is bogus
[13469.009920] sof-audio-pci-intel-tgl 0000:00:1f.3: unexpected fault 0x00000000 trace 0x00000000
[13469.009924] sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump end ]------------
[13469.009926] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to boot DSP firmware after resume -5
[13469.009928] sof-audio-pci-intel-tgl 0000:00:1f.3: PM: dpm_run_callback(): pci_pm_restore+0x0/0x1b0 returns -5
[13469.009954] sof-audio-pci-intel-tgl 0000:00:1f.3: PM: failed to restore async: error -5
[13469.592611] sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to setup widget PIPELINE.9.HDA6.OUT
[13469.592614] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed widget list set up for pcm 5 dir 0
[13469.592615] sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_hw_params on 0000:00:1f.3: -19
[13469.592617]  HDMI3: ASoC: __soc_pcm_hw_params() failed (-19)
[13469.592642]  HDMI3: ASoC: dpcm_fe_dai_hw_params failed (-19)
[13469.592718] sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to setup widget PIPELINE.9.HDA6.OUT
[13469.592719] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed widget list set up for pcm 5 dir 0
[13469.592720] sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_hw_params on 0000:00:1f.3: -19
[13469.592720]  HDMI3: ASoC: __soc_pcm_hw_params() failed (-19)
[13469.592725]  HDMI3: ASoC: dpcm_fe_dai_hw_params failed (-19)
[13469.592789] sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to setup widget PIPELINE.9.HDA6.OUT
[13469.592790] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed widget list set up for pcm 5 dir 0
[13469.592791] sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_hw_params on 0000:00:1f.3: -19
[13469.592792]  HDMI3: ASoC: __soc_pcm_hw_params() failed (-19)
[13469.592797]  HDMI3: ASoC: dpcm_fe_dai_hw_params failed (-19)
[13469.592871] sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to setup widget PIPELINE.9.HDA6.OUT
[13469.592872] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed widget list set up for pcm 5 dir 0
[13469.592873] sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_hw_params on 0000:00:1f.3: -19
[13469.592874]  HDMI3: ASoC: __soc_pcm_hw_params() failed (-19)
[13469.592879]  HDMI3: ASoC: dpcm_fe_dai_hw_params failed (-19)
[13469.592942] sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to setup widget PIPELINE.9.HDA6.OUT
[13469.592943] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed widget list set up for pcm 5 dir 0
[13469.592944] sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_hw_params on 0000:00:1f.3: -19
[13469.592945]  HDMI3: ASoC: __soc_pcm_hw_params() failed (-19)
[13469.592951]  HDMI3: ASoC: dpcm_fe_dai_hw_params failed (-19)
[13469.593115] sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to setup widget PIPELINE.9.HDA6.OUT
[13469.593117] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed widget list set up for pcm 5 dir 0
[13469.593118] sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_hw_params on 0000:00:1f.3: -19
[13469.593119]  HDMI3: ASoC: __soc_pcm_hw_params() failed (-19)
[13469.593128]  HDMI3: ASoC: dpcm_fe_dai_hw_params failed (-19)
[13469.593199] sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to setup widget PIPELINE.9.HDA6.OUT
[13469.593200] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed widget list set up for pcm 5 dir 0
[13469.593201] sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_hw_params on 0000:00:1f.3: -19
[13469.593202]  HDMI3: ASoC: __soc_pcm_hw_params() failed (-19)
[13469.593207]  HDMI3: ASoC: dpcm_fe_dai_hw_params failed (-19)
[13469.593271] sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to setup widget PIPELINE.9.HDA6.OUT
[13469.593272] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed widget list set up for pcm 5 dir 0
[13469.593273] sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_hw_params on 0000:00:1f.3: -19
[13469.593274]  HDMI3: ASoC: __soc_pcm_hw_params() failed (-19)
[13469.593279]  HDMI3: ASoC: dpcm_fe_dai_hw_params failed (-19)
[13469.593350] sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to setup widget PIPELINE.9.HDA6.OUT
[13469.593351] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed widget list set up for pcm 5 dir 0
[13469.593351] sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_hw_params on 0000:00:1f.3: -19
[13469.593352]  HDMI3: ASoC: __soc_pcm_hw_params() failed (-19)
[13469.593359]  HDMI3: ASoC: dpcm_fe_dai_hw_params failed (-19)
[13469.593421] sof-audio-pci-intel-tgl 0000:00:1f.3: Failed to setup widget PIPELINE.9.HDA6.OUT
[13469.593422] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed widget list set up for pcm 5 dir 0
[13469.593423] sof-audio-pci-intel-tgl 0000:00:1f.3: ASoC: error at snd_soc_pcm_component_hw_params on 0000:00:1f.3: -19
[13469.593424]  HDMI3: ASoC: __soc_pcm_hw_params() failed (-19)
[13469.593429]  HDMI3: ASoC: dpcm_fe_dai_hw_params failed (-19)

Offline

#6 2022-06-20 19:37:44

skrat
Member
Registered: 2013-05-10
Posts: 38

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

I reported this to the bug tracker

https://bugs.archlinux.org/task/75122

Offline

#7 2022-06-21 12:59:49

Kabir
Member
From: India
Registered: 2016-12-06
Posts: 59

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

skrat wrote:

I reported this to the bug tracker

https://bugs.archlinux.org/task/75122

Thanks! Hope it gets looked at.

Offline

#8 2022-06-21 13:03:23

skrat
Member
Registered: 2013-05-10
Posts: 38

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

Kabir wrote:
skrat wrote:

I reported this to the bug tracker

https://bugs.archlinux.org/task/75122

Thanks! Hope it gets looked at.

Feel free to add votes in there

Offline

#9 2022-06-21 13:11:21

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,728

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

Technical the project you added the bug report to is wrong, you'd want to file it against the linux package rather than Arch Linux as a project, I'm also not entirely sure how useful it will be to report this on a downstream tracker when it's likely an upstream kernel issue.

Offline

#10 2022-06-23 22:39:29

jasoneliu
Member
Registered: 2022-02-05
Posts: 1

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

Same issue, I get this after waking from hibernation:

Jun 23 18:31:44 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump start ]------------
Jun 23 18:31:44 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware boot failure due to timeout
Jun 23 18:31:44 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: fw_state: SOF_FW_BOOT_IN_PROGRESS (2)
Jun 23 18:31:44 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: invalid header size 0xffffffff. FW oops is bogus
Jun 23 18:31:44 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: unexpected fault 0x00000000 trace 0x00000000
Jun 23 18:31:44 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: ------------[ DSP dump end ]------------
Jun 23 18:31:44 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to boot DSP firmware after resume -5
Jun 23 18:31:44 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: PM: dpm_run_callback(): pci_pm_restore+0x0/0xe0 returns -5
Jun 23 18:31:44 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: PM: failed to restore async: error -5

It also prevents me from hibernating again:

Jun 23 18:33:09 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: error: PM_GATE ipc error -19
Jun 23 18:33:09 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: failed to set requested target DSP state 0 substate 1
Jun 23 18:33:09 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: error: setting dsp state 0 substate 1
Jun 23 18:33:09 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to power down DSP during suspend -19
Jun 23 18:33:09 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: PM: pci_pm_freeze(): snd_sof_suspend+0x0/0x20 [snd_sof] returns -19
Jun 23 18:33:09 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: PM: dpm_run_callback(): pci_pm_freeze+0x0/0xc0 returns -19
Jun 23 18:33:09 hp-spectre-x360-14 kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: PM: failed to freeze async: error -19
Jun 23 18:33:09 hp-spectre-x360-14 kernel: hub 3-0:1.0: hub_ext_port_status failed (err = -113)
Jun 23 18:33:09 hp-spectre-x360-14 kernel: usb usb3-port9: cannot disable (err = -113)
Jun 23 18:33:09 hp-spectre-x360-14 kernel: usb 3-9: PM: dpm_run_callback(): usb_dev_restore+0x0/0x20 returns -113
Jun 23 18:33:09 hp-spectre-x360-14 kernel: usb 3-9: PM: failed to restore async: error -113
Jun 23 18:33:09 hp-spectre-x360-14 systemd-sleep[8123]: Failed to put system to sleep. System resumed again: No such device
Jun 23 18:33:09 hp-spectre-x360-14 systemd[1]: Failed to start Hibernate.

Offline

#11 2022-06-24 01:53:38

alovii
Member
Registered: 2022-06-24
Posts: 1

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

The workaround for me was to disable the sound card and reconnect, by running this script when waking up from sleep

device_id=$(lspci -D | grep Audio | awk '{print $1}')
echo 1 > /sys/bus/pci/devices/${device_id}/remove
sleep 1
echo 1 > /sys/bus/pci/rescan

Offline

#12 2022-06-24 11:20:57

Kabir
Member
From: India
Registered: 2016-12-06
Posts: 59

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

alovii wrote:

The workaround for me was to disable the sound card and reconnect, by running this script when waking up from sleep

device_id=$(lspci -D | grep Audio | awk '{print $1}')
echo 1 > /sys/bus/pci/devices/${device_id}/remove
sleep 1
echo 1 > /sys/bus/pci/rescan

Thanks this does work as a workaround until the problem is fixed. Although I did need to change your script from this link because I was getting a few errors.

./sound.sh: line 4: device_id: command not found
./sound.sh: line 4: /sys/bus/pci/devices//remove: Permission denied
./sound.sh: line 6: /sys/bus/pci/rescan: Permission denied

Offline

#13 2022-06-24 16:20:11

logothete
Member
Registered: 2022-01-06
Posts: 43

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

Edited comment, since I answered my question myself.
The version of the script that will work is below:

#!/bin/bash
[[ $UID = 0]] || exec sudo "$0"
echo 1 > /sys/bus/pci/devices/0000:00:1f.3/remove
sleep 1
echo 1> /sys/bus/pci/rescan

Where I have had to call sudo from within the script, and used the device ID directly instead of getting it as a variable.
It's a little baffling, though; I cannot call /sys/bus/pci/rescan on its own, even as root.

a nearly perfect workaround, I think. If only it could work without root privileges, we could automate this and forget.

Last edited by logothete (2022-06-24 16:34:01)

Offline

#14 2022-06-25 15:35:14

mad526
Member
Registered: 2009-01-22
Posts: 10

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

adding

options snd_sof sof_debug=128 

to /etc/modprobe.d/sof.conf fixed it for me. see https://github.com/thesofproject/sof/is … 1162990442

Offline

#15 2022-06-25 17:55:02

Kabir
Member
From: India
Registered: 2016-12-06
Posts: 59

Re: [SOLVED] Sound fails after waking from hibernation on 5.18 kernel

mad526 wrote:

adding

options snd_sof sof_debug=128 

to /etc/modprobe.d/sof.conf fixed it for me. see https://github.com/thesofproject/sof/is … 1162990442

Thanks so much, adding that line fixes it.

Offline

Board footer

Powered by FluxBB