You are not logged in.

#1 2022-06-24 15:02:23

0BADC0DE
Member
From: Regnum Utriusque Siciliae
Registered: 2018-02-21
Posts: 245

[SOLVED] Virtualbox not starting VMs

I have installed virtuabox (6.1.34-4) and virtualbox-host-dkms (6.1.34-4).
I am trying to install a Windows XP VM from ISO and as soon as I start it I get a never-seen-before dialog window that never completes:

https://i.ibb.co/qBhvR2z/32a8a0a05e7d.png

In the past I usually got to the emulated screen BIOS and then to the boot.
But now it is stuck that way and there is no way to close the application.
What shall I do?

moderator edit -- replaced oversized image with link.
Pasting pictures and code

UPDATE: Solved. Read below.

Last edited by 0BADC0DE (2022-07-14 08:57:39)


Maybe Computers Will Never Become As Intelligent
As Humans. Surely They Won't Ever Become So Stupid.

Offline

#2 2022-06-24 18:30:01

gca
Member
Registered: 2021-06-08
Posts: 59

Re: [SOLVED] Virtualbox not starting VMs

Try to change vm's user interface. Leave only top bar active and view if start.

Offline

#3 2022-06-25 07:56:02

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,557

Re: [SOLVED] Virtualbox not starting VMs

I have installed virtuabox (6.1.34-4) and virtualbox-host-dkms (6.1.34-4).

Which kernel are you currently running on? Have you installed the appropriate headers for your kernel?

Offline

#4 2022-06-26 05:56:38

0BADC0DE
Member
From: Regnum Utriusque Siciliae
Registered: 2018-02-21
Posts: 245

Re: [SOLVED] Virtualbox not starting VMs

d_fajardo wrote:

I have installed virtuabox (6.1.34-4) and virtualbox-host-dkms (6.1.34-4).

Which kernel are you currently running on? Have you installed the appropriate headers for your kernel?

> I have installed virtuabox (6.1.34-4) and virtualbox-host-dkms (6.1.34-4)

I would say so.
I have  installed:
extra/linux-zen 5.18.6.zen1-1
extra/linux-zen-headers 5.18.6.zen1-1

I am on KDE/Plasma/Wayland, BTW. And also have installed extra/xorg-xwayland 22.1.2-1 , but virtualbox doesn't appear in the list by xlsclients.

VirtualBox has always been part of my setup even though I don't use it very often.
I had to kill all VBox-related the processes as they are not responsive.
The logs are here.


Maybe Computers Will Never Become As Intelligent
As Humans. Surely They Won't Ever Become So Stupid.

Offline

#5 2022-06-26 07:47:50

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,557

Re: [SOLVED] Virtualbox not starting VMs

It might help installing the extension pack. It says in the logs you haven't got any.
https://aur.archlinux.org/packages/virt … ext-oracle
That could solve your keyboard and X issues though not really certain.

EDIT: Just curious which keyboard layout are you using?

Last edited by d_fajardo (2022-06-26 07:53:02)

Offline

#6 2022-06-26 14:30:50

someUser
Member
Registered: 2021-01-03
Posts: 13

Re: [SOLVED] Virtualbox not starting VMs

Have you tried adding ibt=off as a kernel parameter.

https://wiki.archlinux.org/title/Virtua … _Intel_CPU

Offline

#7 2022-06-27 07:14:28

0BADC0DE
Member
From: Regnum Utriusque Siciliae
Registered: 2018-02-21
Posts: 245

Re: [SOLVED] Virtualbox not starting VMs

d_fajardo wrote:

It might help installing the extension pack. It says in the logs you haven't got any.
https://aur.archlinux.org/packages/virt … ext-oracle
That could solve your keyboard and X issues though not really certain.

Nope, it didn't help. I don't get the BIOS but just that "Starting virtual machine" nevereding dialog.
I would usually get the BIOS almost immediately.

d_fajardo wrote:

EDIT: Just curious which keyboard layout are you using?

English (US, alt. intl.)

Last edited by 0BADC0DE (2022-06-27 07:14:50)


Maybe Computers Will Never Become As Intelligent
As Humans. Surely They Won't Ever Become So Stupid.

Offline

#8 2022-06-27 07:51:18

0BADC0DE
Member
From: Regnum Utriusque Siciliae
Registered: 2018-02-21
Posts: 245

Re: [SOLVED] Virtualbox not starting VMs

someUser wrote:

Have you tried adding ibt=off as a kernel parameter.

https://wiki.archlinux.org/title/Virtua … _Intel_CPU

My VM is not freezing. It is not starting at all, not even the BIOS!
And it has worked in the past on the very same system and cpu.


Maybe Computers Will Never Become As Intelligent
As Humans. Surely They Won't Ever Become So Stupid.

Offline

#9 2022-06-27 08:46:36

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,557

Re: [SOLVED] Virtualbox not starting VMs

From your previous log, it seems virtualbox is having  issues with your keyboard settings. It's probably good to investigate why this is first. It seems like X is not communicating with VBox.
Can you post the output of:

setxkbmap -print -verbose 10

And maybe a new VM log trying to start a guest machine.
Have you also tried other guest machines?

Offline

#10 2022-06-27 09:22:47

0BADC0DE
Member
From: Regnum Utriusque Siciliae
Registered: 2018-02-21
Posts: 245

Re: [SOLVED] Virtualbox not starting VMs

d_fajardo wrote:

From your previous log, it seems virtualbox is having  issues with your keyboard settings. It's probably good to investigate why this is first. It seems like X is not communicating with VBox.
Can you post the output of:

setxkbmap -print -verbose 10

And maybe a new VM log trying to start a guest machine.
Have you also tried other guest machines?

My setxkbmap output is here.
My VBox.log is here


Maybe Computers Will Never Become As Intelligent
As Humans. Surely They Won't Ever Become So Stupid.

Offline

#11 2022-06-27 11:13:11

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,557

Re: [SOLVED] Virtualbox not starting VMs

00:01:24.023452 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={755e6bdf-1640-41f9-bd74-3ef5fd653250} aComponent={KeyboardWrap} aText={The console is not powered up (putScancodes)}, preserve=false aResultDetail=0
00:01:24.367959 GUI: Machine-window #0 deactivated
00:01:24.367999 GUI: Releasing mouse on focus out
00:01:24.368221 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={755e6bdf-1640-41f9-bd74-3ef5fd653250} aComponent={KeyboardWrap} aText={The console is not powered up (putScancodes)}, preserve=false aResultDetail=0
00:01:24.368291 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={755e6bdf-1640-41f9-bd74-3ef5fd653250} aComponent={KeyboardWrap} aText={The console is not powered up (putScancodes)}, preserve=false aResultDetail=0
00:01:24.371044 GUI: Machine-view #0 unfocused, reason=3

From your logs, your machine is not reading the XKB keycode. It should read something like 'Using XKB for keycode to scan code conversion' Also not sure why you are getting these access denied errors.
Do you have any custom keys you have programmed for your keyboard?
Also can you post the output of lsmod just to see which VBox modules are loaded.

Offline

#12 2022-06-27 13:30:37

0BADC0DE
Member
From: Regnum Utriusque Siciliae
Registered: 2018-02-21
Posts: 245

Re: [SOLVED] Virtualbox not starting VMs

d_fajardo wrote:
00:01:24.023452 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={755e6bdf-1640-41f9-bd74-3ef5fd653250} aComponent={KeyboardWrap} aText={The console is not powered up (putScancodes)}, preserve=false aResultDetail=0
00:01:24.367959 GUI: Machine-window #0 deactivated
00:01:24.367999 GUI: Releasing mouse on focus out
00:01:24.368221 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={755e6bdf-1640-41f9-bd74-3ef5fd653250} aComponent={KeyboardWrap} aText={The console is not powered up (putScancodes)}, preserve=false aResultDetail=0
00:01:24.368291 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={755e6bdf-1640-41f9-bd74-3ef5fd653250} aComponent={KeyboardWrap} aText={The console is not powered up (putScancodes)}, preserve=false aResultDetail=0
00:01:24.371044 GUI: Machine-view #0 unfocused, reason=3

From your logs, your machine is not reading the XKB keycode. It should read something like 'Using XKB for keycode to scan code conversion' Also not sure why you are getting these access denied errors.
Do you have any custom keys you have programmed for your keyboard?
Also can you post the output of lsmod just to see which VBox modules are loaded.

I haven't got any special key mapping, just "English (US, alt. intl.)" from KDE settings.

I have no idea what's going on. It simply worked until a few weeks ago!


Maybe Computers Will Never Become As Intelligent
As Humans. Surely They Won't Ever Become So Stupid.

Offline

#13 2022-06-27 14:09:37

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,557

Re: [SOLVED] Virtualbox not starting VMs

Check your config files in ~/.config/VirtualBox if you can find any lead in any of the files there, like VirtualBox.xml, etc.
Then only thing I can suggest is to delete that directory (make a backup) and create a clean instance of VB,

Offline

#14 2022-06-27 14:13:34

0BADC0DE
Member
From: Regnum Utriusque Siciliae
Registered: 2018-02-21
Posts: 245

Re: [SOLVED] Virtualbox not starting VMs

Can VB work with Wayland/x Wayland,. AFAYCT?


Maybe Computers Will Never Become As Intelligent
As Humans. Surely They Won't Ever Become So Stupid.

Offline

#15 2022-06-27 14:19:45

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,358

Re: [SOLVED] Virtualbox not starting VMs

0BADC0DE wrote:
someUser wrote:

Have you tried adding ibt=off as a kernel parameter.

https://wiki.archlinux.org/title/Virtua … _Intel_CPU

My VM is not freezing. It is not starting at all, not even the BIOS!
And it has worked in the past on the very same system and cpu.

That doesn't answer the question.

That it worked previously doesn't matter when indirect branch tracking was just added with kernel 5.18. If anything, that supports someUser's idea.

Last edited by Scimmia (2022-06-27 14:22:10)

Offline

#16 2022-06-27 14:24:22

0BADC0DE
Member
From: Regnum Utriusque Siciliae
Registered: 2018-02-21
Posts: 245

Re: [SOLVED] Virtualbox not starting VMs

Scimmia wrote:
0BADC0DE wrote:
someUser wrote:

Have you tried adding ibt=off as a kernel parameter.

https://wiki.archlinux.org/title/Virtua … _Intel_CPU

My VM is not freezing. It is not starting at all, not even the BIOS!
And it has worked in the past on the very same system and cpu.

That doesn't answer the question.

That it worked previously doesn't matter when indirect branch tracking was just added with kernel 5.18. If anything, that supports someUser's idea.

Will test your suggestion later and report back here. Thanks.

Last edited by 0BADC0DE (2022-06-27 14:24:53)


Maybe Computers Will Never Become As Intelligent
As Humans. Surely They Won't Ever Become So Stupid.

Offline

#17 2022-07-14 08:45:10

0BADC0DE
Member
From: Regnum Utriusque Siciliae
Registered: 2018-02-21
Posts: 245

Re: [SOLVED] Virtualbox not starting VMs

someUser wrote:

Have you tried adding ibt=off as a kernel parameter.

https://wiki.archlinux.org/title/Virtua … _Intel_CPU

This one seems to fix the issue.
I added it to my /etc/default/grub like this:

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet ibt=off"

then run:

sudo grub-mkconfig -o /boot/grub/grub.cfg

and finally rebooted. Now the VMs start up regularly.


Maybe Computers Will Never Become As Intelligent
As Humans. Surely They Won't Ever Become So Stupid.

Offline

#18 2023-02-01 12:38:35

michimussato
Member
Registered: 2023-01-26
Posts: 3

Re: [SOLVED] Virtualbox not starting VMs

After upgrading from kernel

linux515

to any newer kernel, none of my VM's started anymore.

Currently running: 6.1.7-1-MANJARO (linux61)
The following kernels are installed in your system:
   * linux515
   * linux519
   * linux60
   * linux61

Exactly the same situation as outlined by 0BADC0DE:

0BADC0DE wrote:

I don't get the BIOS but just that "Starting virtual machine" nevereding dialog.

Adding

ibt=off

to

GRUB_CMDLINE_LINUX_DEFAULT

solved the issue.

It seems that the info outlined in https://wiki.archlinux.org/title/Virtua … _Intel_CPU should be integrated into https://wiki.archlinux.org/title/VirtualBox to make it more obvious (it took me quite a while till I found this highly appreciated thread). There was absolutely no hint in the VM log:

00:00:00.736779 VirtualBox VM 7.0.6 r155176 linux.amd64 (Jan 17 2023 21:23:05) release log
00:00:00.736783 Log opened 2023-02-01T12:09:56.500881000Z
00:00:00.736783 Build Type: release
00:00:00.736785 OS Product: Linux
00:00:00.736786 OS Release: 6.1.7-1-MANJARO
00:00:00.736786 OS Version: #1 SMP PREEMPT_DYNAMIC Wed Jan 18 22:33:03 UTC 2023
00:00:00.736824 DMI Product Name: G1621-02
00:00:00.736830 DMI Product Version: Default string
00:00:00.736836 Firmware type: UEFI
00:00:00.737224 Secure Boot: Disabled
00:00:00.737268 Host RAM: 15777MB (15.4GB) total, 14150MB (13.8GB) available
00:00:00.737272 Executable: /usr/lib/virtualbox/VirtualBoxVM
00:00:00.737272 Process ID: 3435
00:00:00.737273 Package type: LINUX_64BITS_GENERIC (OSE)
00:00:00.738499 Installed Extension Packs:
00:00:00.738507   Oracle VM VirtualBox Extension Pack (Version: 7.0.6 r155176; VRDE Module: VBoxVRDP; Crypto Module: VBoxPuelCrypto)
00:00:00.739102 Console: Machine state changed to 'Starting'
00:00:00.739215 Qt version: 5.15.8
00:00:00.739223 X11 Window Manager code: 5
00:00:00.747060 SUP: seg #0: R   0x00000000 LB 0x00061000
00:00:00.747079 SUP: seg #1: R X 0x00061000 LB 0x001a1000
00:00:00.747081 SUP: seg #2: R   0x00202000 LB 0x0006e000
00:00:00.747083 SUP: seg #3: RW  0x00270000 LB 0x0002eae8
00:00:00.767491 GUI: UIMediumEnumerator: Medium-enumeration finished!
00:00:00.767986 X Server details: vendor: The X.Org Foundation, release: 12101006, protocol version: 11.0, display string: :0
00:00:00.767995 Using XKB for keycode to scan code conversion
00:00:00.769391 GUI: UIDesktopWidgetWatchdog::sltHandleHostScreenAvailableGeometryCalculated: Screen 0 work area is actually resized to: 0x28 x 2532x1052
00:00:00.775093 GUI: UIDesktopWidgetWatchdog::sltHandleHostScreenAvailableGeometryCalculated: Screen 1 work area is actually resized to: 0x1080 x 1920x1200
00:00:02.482856 GUI: UIMediumEnumerator: Medium-enumeration finished!
[michael@pocket3 ~] $ lscpu
Architecture:            x86_64
  CPU op-mode(s):        32-bit, 64-bit
  Address sizes:         39 bits physical, 48 bits virtual
  Byte Order:            Little Endian
CPU(s):                  8
  On-line CPU(s) list:   0-7
Vendor ID:               GenuineIntel
  Model name:            11th Gen Intel(R) Core(TM) i7-1195G7 @ 2.90GHz
    CPU family:          6
    Model:               140
    Thread(s) per core:  2
    Core(s) per socket:  4
    Socket(s):           1
    Stepping:            2
    CPU(s) scaling MHz:  73%
    CPU max MHz:         5000.0000
    CPU min MHz:         400.0000
    BogoMIPS:            5839.00
    Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mc
                         a cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss 
                         ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art
                          arch_perfmon pebs bts rep_good nopl xtopology nonstop_
                         tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes6
                         4 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr p
                         dcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline
                         _timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefe
                         tch cpuid_fault epb cat_l2 invpcid_single cdp_l2 ssbd i
                         brs ibpb stibp ibrs_enhanced tpr_shadow vnmi flexpriori
                         ty ept vpid ept_ad fsgsbase tsc_adjust bmi1 avx2 smep b
                         mi2 erms invpcid rdt_a avx512f avx512dq rdseed adx smap
                          avx512ifma clflushopt clwb intel_pt avx512cd sha_ni av
                         x512bw avx512vl xsaveopt xsavec xgetbv1 xsaves split_lo
                         ck_detect dtherm ida arat pln pts hwp hwp_notify hwp_ac
                         t_window hwp_epp hwp_pkg_req avx512vbmi umip pku ospke 
                         avx512_vbmi2 gfni vaes vpclmulqdq avx512_vnni avx512_bi
                         talg avx512_vpopcntdq rdpid movdiri movdir64b fsrm avx5
                         12_vp2intersect md_clear flush_l1d arch_capabilities
Virtualization features: 
  Virtualization:        VT-x
Caches (sum of all):     
  L1d:                   192 KiB (4 instances)
  L1i:                   128 KiB (4 instances)
  L2:                    5 MiB (4 instances)
  L3:                    12 MiB (1 instance)
NUMA:                    
  NUMA node(s):          1
  NUMA node0 CPU(s):     0-7
Vulnerabilities:         
  Itlb multihit:         Not affected
  L1tf:                  Not affected
  Mds:                   Not affected
  Meltdown:              Not affected
  Mmio stale data:       Not affected
  Retbleed:              Not affected
  Spec store bypass:     Mitigation; Speculative Store Bypass disabled via prctl
  Spectre v1:            Mitigation; usercopy/swapgs barriers and __user pointer
                          sanitization
  Spectre v2:            Mitigation; Enhanced IBRS, IBPB conditional, RSB fillin
                         g, PBRSB-eIBRS SW sequence
  Srbds:                 Not affected
  Tsx async abort:       Not affected

Last edited by michimussato (2023-02-01 12:48:51)

Offline

#19 2023-02-01 12:48:14

0BADC0DE
Member
From: Regnum Utriusque Siciliae
Registered: 2018-02-21
Posts: 245

Re: [SOLVED] Virtualbox not starting VMs

Thanks.


Maybe Computers Will Never Become As Intelligent
As Humans. Surely They Won't Ever Become So Stupid.

Offline

Board footer

Powered by FluxBB