You are not logged in.

#1 2022-06-24 16:17:23

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,477

[Solved]Tweaked vim PKGBUILD in IgnoreGroup not completely honored

I have this PKGBUILD to build and install vim.
The package is a split package that provides: 'xxd' 'vim-minimal' 'vim-plugin-minimal'
The package is in group 'asp-mod' & added to pacman.conf 'IgnoreGroup'
This all is build and installed and works fine.

There is however a little snake in the grass, it doesn't bite...
If 'pacman -Qm' is executed it shows 'vim-debug 8.2.5046-2'
It seems incorrect because of the ignored group, however I may as well be wrong...

Like I said I have no problems with it but if the aurhelper(just a script) is used vim-debug comes along too and is skipped right away.
As you can imagine I guess, I don't want to see 'vim-debug' at all during this process, I bet I'm missing something...?

Not sure where exactly this belongs so I put in 'Creating & Modifying Packages'

Last edited by qinohe (2022-06-24 16:42:57)

Offline

#2 2022-06-24 16:32:26

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,437

Re: [Solved]Tweaked vim PKGBUILD in IgnoreGroup not completely honored

-debug packages don't inherit all of the attributes of the actual package. They don't even get put into the repos. Are you trying to get backtraces from vim? If not, why did you install it?

Offline

#3 2022-06-24 16:42:38

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,477

Re: [Solved]Tweaked vim PKGBUILD in IgnoreGroup not completely honored

Thanks for the swift answer Scimmia.

Scimmia wrote:

-debug packages don't inherit all of the attributes of the actual package. They don't even get put into the repos.

That makes sense...

Are you trying to get backtraces from vim? If not, why did you install it?

No actually, it's just an ASP PKGBUILD that is adjusted, but, I never thought of removing debug option - I will now and build it when I need it, again Thanks;)

Offline

#4 2022-06-24 18:02:45

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,061
Website

Re: [Solved]Tweaked vim PKGBUILD in IgnoreGroup not completely honored

qinohe wrote:

It seems incorrect because of the ignored group, however I may as well be wrong...

IgnorePkg and IgnoreGroup will not prevent packages from being listed in query (-Qm) output.  As the man page says, pacman will just ignore upgrades to these packages for --sysupgrade / -u.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#5 2022-06-24 18:35:08

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,477

Re: [Solved]Tweaked vim PKGBUILD in IgnoreGroup not completely honored

Trilby wrote:

IgnorePkg and IgnoreGroup will not prevent packages from being listed in query (-Qm) output.  As the man page says, pacman will just ignore upgrades to these packages for --sysupgrade / -u.

I did expect 'vim' & 'vim-runtime' to show-up in that same 'Qm' output too ... of course;) that's not the case only 'vim-debug' was shown by 'Qm'
This was a little odd to me! Not that vim or vim-runtime should show up because they(split) are tweaked 'original' packages that would be overwritten if not in IgnoreGroup by a regular update.
I have now disabled ! debug option everything is as I expect it to be, when I need it I build it...

Because debug packages don't inherit all attributes of the original package - like Scimmia said - it automatically shows up in 'Qm' as it's seen as 'foreign' package, at least not it any of the 'default' Arch repos...

Offline

#6 2022-06-24 19:34:42

progandy
Member
Registered: 2012-05-17
Posts: 5,006

Re: [Solved]Tweaked vim PKGBUILD in IgnoreGroup not completely honored

Because debug packages don't inherit all attributes of the original package

That doesn't really matter for the -Qm output. As you noticed, debug packages show up in -Qm since these packages are not available in the package repository. vim and vim-runtime are not listed in -Qm since a package with the same name is in the repository database. Pacman does not care how you installed a package, only if a package with that name is in the repositories or not.

Last edited by progandy (2022-06-24 19:36:15)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#7 2022-06-24 19:58:40

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,477

Re: [Solved]Tweaked vim PKGBUILD in IgnoreGroup not completely honored

progandy wrote:

Because debug packages don't inherit all attributes of the original package

That doesn't really matter for the -Qm output. As you noticed, debug packages show up in -Qm since these packages are not available in the package repository. vim and vim-runtime are not listed in -Qm since a package with the same name is in the repository database. Pacman does not care how you installed a package, only if a package with that name is in the repositories or not.

Thanks, I thought I said just that...;)
You forgot:

qinohe-said wrote:

...Not that vim or vim-runtime should show up because they(split) are tweaked 'original' packages that would be overwritten if not in IgnoreGroup by a regular update.
...it automatically shows up in 'Qm' as it's seen as 'foreign' package, at least not it any of the 'default' Arch repos...

Offline

#8 2022-06-24 20:08:32

progandy
Member
Registered: 2012-05-17
Posts: 5,006

Re: [Solved]Tweaked vim PKGBUILD in IgnoreGroup not completely honored

qinohe wrote:

Thanks, I thought I said just that...;)

I thought you said it as well, but was not completely sure I read it correctly, so take it as a summary for future readers of the thread smile


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#9 2022-06-24 20:14:44

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,477

Re: [Solved]Tweaked vim PKGBUILD in IgnoreGroup not completely honored

Oh you're welcome progandy and everyone else that contributed to this thread is;)! I just started doubting myself.
Maybe I should spend some time bettering my grammatical English I have noticed more confusion in the past roll

Offline

Board footer

Powered by FluxBB