You are not logged in.

#1 2022-06-30 07:54:48

Grossi_Claps
Member
Registered: 2017-03-28
Posts: 5

[SOLVED] PKGBUILD Review Request: omniorb425

Hello!
I've made a package for omniorb 4.2.5, since the 4.3.x branch is not backward compatible.

I've checked that it compiles on x86_64 and armv7h.

reviews welcome!
Thanks,
Antonio

# Maintainer: Antonio Bartalesi <antonio.bartalesi@gmail.com>
pkgname=omniorb425
pkgver=4.2.5
pkgrel=1
pkgdesc="A CORBA object request broker for C++ and Python."
arch=('x86_64' 'armv7h')
url="http://omniorb.sourceforge.net/"
license=('GPL2' 'LGPL2.1')
depends=('python')
makedepends=('pkgconfig')
provides=('omniorb=4.2.5')
conflicts=('omniorb' 'omniorb416' 'omniorb417')
source=(http://downloads.sourceforge.net/omniorb/omniORB-${pkgver}.tar.bz2)
sha256sums=('f05cf999fb2f4c24c1173b3c44ad97215591d0d1a48d49ac0843c464efe073bb')

build() {
  cd "${srcdir}/omniORB-${pkgver}"
  ./configure \
         --prefix=/usr \
         --with-omniORB-config=/etc/omniorb/omniORB.cfg \
         --with-omniNames-logdir=/var/log/omniORB \
         --with-openssl=/usr
  make
}

package() {
  cd "${srcdir}/omniORB-${pkgver}"
  make DESTDIR="${pkgdir}" install
  for i in man/man1/*.1; do
    install -D -m 644 $i "${pkgdir}/usr/share/${i}"
  done
}

Last edited by Grossi_Claps (2022-07-15 09:23:15)

Offline

#2 2022-06-30 11:10:37

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,256

Re: [SOLVED] PKGBUILD Review Request: omniorb425

Archlinux uses pkgconf nowadays, but you don't have to add it as makedep .

See the first purple box under https://wiki.archlinux.org/title/Arch_U … requisites

conflicts=('omniorb' 'omniorb416' 'omniorb417')

Please remove omniorb416 & 417 from conflicts.
All variants should provide & conflict omniorb and  let pacman deal with other varaints.the rest.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2022-07-15 09:22:49

Grossi_Claps
Member
Registered: 2017-03-28
Posts: 5

Re: [SOLVED] PKGBUILD Review Request: omniorb425

Thanks!
I removed

makedepends=('pkgconfig')

and changed conflicts to

conflicts=('omniorb')

Offline

Board footer

Powered by FluxBB