You are not logged in.

#1 2022-07-15 05:58:50

r0ber
Member
Registered: 2022-07-12
Posts: 9

[SOLVED] I can't install xbindkeys package > Invalid PGP or Corrupted.

Hi everyone.. im new in archlinux, but im solving all my newbie problems. I really love arch big_smile
But.. im having problems when i want to install xbindkeys package

My problem:

sudo pacman -S xbindkeys
resolving dependencies...
looking for conflicting packages...

Packages (1) xbindkeys-1.8.7-2

Total Download Size:   0.02 MiB
Total Installed Size:  0.05 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 xbindkeys-1.8.7-2...    23.4 KiB  37.1 KiB/s 00:01 [###########################] 100%
(1/1) checking keys in keyring                      [###########################] 100%
(1/1) checking package integrity                    [###########################] 100%
error: xbindkeys: signature from "Konstantin Gizdov <arch@kge.pw>" is marginal trust
:: File /var/cache/pacman/pkg/xbindkeys-1.8.7-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y

Some info about that keys and Konstantin Gizdov:

pub   rsa4096 2015-02-26 [SCEA]
      4BE61D684CB4E31741614E7089AA27231C530226
uid           [marginal] Konstantin Gizdov <arch@kge.pw>
uid           [marginal] Konstantin Gizdov <kgizdov@gmail.com>
uid           [marginal] keybase.io/kgizdov <kgizdov@keybase.io>
sub   rsa2048 2015-02-26 [SE] [expires: 2023-02-24]
sub   rsa2048 2015-02-26 [S] [expires: 2023-02-24]

I read some posts, i tried to delete the key and re-populate or similars ways.
Can you help me? big_smile

Thank you in advance.


UPDATE: A new version for community/xbindkeys 1.8.7-3 works fine.

Last edited by r0ber (2022-07-18 02:05:01)

Offline

#2 2022-07-15 06:26:39

Adriik
Member
From: Argentina
Registered: 2022-03-10
Posts: 82

Re: [SOLVED] I can't install xbindkeys package > Invalid PGP or Corrupted.

Did you read this or this?


I'm just someone. Please use [code] [/code] tags.

Command cheatsheet

Offline

#3 2022-07-15 07:21:05

r0ber
Member
Registered: 2022-07-12
Posts: 9

Re: [SOLVED] I can't install xbindkeys package > Invalid PGP or Corrupted.

Adriik wrote:

Did you read this or this?

Hi Adri,
Yes, i tried updating archlinux-keyring, and finding .part package, but no results.
I can't to install xbindkeys, same error.

Thanks.-

Offline

#4 2022-07-15 07:44:49

seth
Member
Registered: 2012-09-03
Posts: 33,485

Re: [SOLVED] I can't install xbindkeys package > Invalid PGP or Corrupted.

pacman -Qi archlinux-keyring
pacman-key --list-keys 'arch@kge.pw'

Online

#5 2022-07-15 08:24:06

r0ber
Member
Registered: 2022-07-12
Posts: 9

Re: [SOLVED] I can't install xbindkeys package > Invalid PGP or Corrupted.

seth wrote:
pacman -Qi archlinux-keyring
pacman-key --list-keys 'arch@kge.pw'

It shows this:

 pacman -Qi archlinux-keyring             
Name            : archlinux-keyring
Version         : 20220713-1
Description     : Arch Linux PGP keyring
Architecture    : any
URL             : https://gitlab.archlinux.org/archlinux/archlinux-keyring/
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : None
Optional Deps   : None
Required By     : pacman
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 1561.82 KiB
Packager        : Christian Hesse <eworm@archlinux.org>
Build Date      : Wed 13 Jul 2022 05:57:11 AM -03
Install Date    : Fri 15 Jul 2022 04:18:18 AM -03
Install Reason  : Installed as a dependency for another package
Install Script  : Yes
Validated By    : Signature

--

pacman-key --list-keys 'arch@kge.pw' 
gpg: Note: trustdb not writable
pub   rsa4096 2015-02-26 [SCEA]
      4BE61D684CB4E31741614E7089AA27231C530226
uid           [marginal] Konstantin Gizdov <arch@kge.pw>
uid           [marginal] Konstantin Gizdov <kgizdov@gmail.com>
uid           [marginal] keybase.io/kgizdov <kgizdov@keybase.io>
sub   rsa2048 2015-02-26 [SE] [expires: 2023-02-24]
sub   rsa2048 2015-02-26 [S] [expires: 2023-02-24]

pub   ed25519 2019-04-12 [C] [expires: 2024-04-10]
      0A9DDABB64B993D82AD45E4F32EAB0A976938292
uid           [  full  ] Konstantin Gizdov (Arch Linux) <kgizdov@archlinux.org>
uid           [ unknown] Konstantin Gizdov <arch@kge.pw>
uid           [ unknown] Konstantin Gizdov <kgizdov@gmail.com>
uid           [ unknown] keybase.io/kgizdov (Keybase) <kgizdov@keybase.io>
sub   rsa4096 2021-04-15 [E] [expires: 2026-04-14]
sub   ed25519 2019-04-12 [A] [expires: 2024-04-10]
sub   ed25519 2019-04-12 [S] [expires: 2024-04-10]
sub   cv25519 2019-04-12 [E] [expires: 2024-04-10]

Offline

#6 2022-07-15 12:08:02

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,816

Re: [SOLVED] I can't install xbindkeys package > Invalid PGP or Corrupted.

This is a bug, the package needs rebuilt with the maintainer's current key.

Offline

#7 2022-07-15 16:27:45

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,557
Website

Re: [SOLVED] I can't install xbindkeys package > Invalid PGP or Corrupted.

You may also adjust the maintainer's key's trust level manually and sign it using pacman-key.


Солідарність з Україною

Offline

#8 2022-07-17 20:04:41

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,494

Re: [SOLVED] I can't install xbindkeys package > Invalid PGP or Corrupted.

You can rebuild the package yourself too.
It will be updated if you use the original package.
https://github.com/archlinux/svntogit-c … k/PKGBUILD

edit: xbindkeys 1.8.7-3 just landed in [Community]..

Last edited by qinohe (2022-07-17 22:05:54)

Offline

#9 2022-07-18 01:52:54

r0ber
Member
Registered: 2022-07-12
Posts: 9

Re: [SOLVED] I can't install xbindkeys package > Invalid PGP or Corrupted.

Thanks you for your time to answer me.
I will check everything and i will write my results.

UPDATE: Solved i installed the new community/xbindkeys 1.8.7-3

Thanks.

Last edited by r0ber (2022-07-18 02:03:18)

Offline

#10 2022-07-18 02:03:32

r0ber
Member
Registered: 2022-07-12
Posts: 9

Re: [SOLVED] I can't install xbindkeys package > Invalid PGP or Corrupted.

qinohe wrote:

You can rebuild the package yourself too.
It will be updated if you use the original package.
https://github.com/archlinux/svntogit-c … k/PKGBUILD

edit: xbindkeys 1.8.7-3 just landed in [Community]..

Thank you very much.

Offline

Board footer

Powered by FluxBB