You are not logged in.

#1 2022-07-24 13:05:37

Blackmine57
Member
Registered: 2019-08-29
Posts: 18

[SOLVED] [GOOGLE NEST] 11n_disable=1 needed

Hey !

About a week ago I added options iwlwifi 11n_disable=8 in /etc/modprobe.d/iwlwifi.conf and everything worked fine. But for some reason it does no longer work. Now I have to use 11n_disable = 1 which is way slower (20 mbps instead of 300)

With 11n_disable=8 : when I connect to my network I can make about 5-6 pings before my network "die". I mean no packet is sent or received. I cannot even ping my router (86.1)
Here are my iwlwifi logs (dmesg, there are almost the same in journalctl)  : https://pastebin.com/U43xSDSa

My network adapter is a Intel Corp Wireless 7265, I am using KDE (with NetworkManager ofc), I am using  archlinux 5.18.13-arch1-1 and it is almost a clean install. Please note I don't have to do anything in liveUSB, everything works fine

I'm really sorry but I don't know what to add. Do you guys have an idea ?

Please ask for additional information, I probably forgot something

Thank you !

PS : I believe it's a Kernel issue because it works fine on liveUSB and used to work fine a while ago.

Solution : if you have google nest wifi devices, please make a sudo iwlist scanning or nmcli -f SSID,BSSID,ACTIVE dev wifi list
Copy the BSSID with the best signal rating (or even all). Then go to network manager and specify the correct BSSID.
If you don't know which one is fine try all !
You can also just remove your current network and make a nmcli d wifi connect XX:XX:XX:XX:XX:XX

Last edited by Blackmine57 (2022-07-31 17:14:59)

Offline

#2 2022-07-24 14:25:17

seth
Member
Registered: 2012-09-03
Posts: 31,849

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

https://bbs.archlinux.org/viewtopic.php … 6#p2045326 ?
You can also try to "iwlwifi.disable_11ac=1" in case that'S the actual troublemaker and you're just randomly hitting it by disabling 11n.
Also random finds: "iwlwifi.power_save=0" and "iwlwifi.amsdu=3", https://bugs.gentoo.org/721064

Which kernel is on your install ISO?
Do you load the same firmware version there?

Online

#3 2022-07-24 15:14:51

Blackmine57
Member
Registered: 2019-08-29
Posts: 18

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

Hi

I tried  cfg80211 cfg80211_disable_40mhz_24ghz=Y     ;      iwlwifi.disable_11ac=1     ;   "iwlwifi.power_save=0" and "iwlwifi.amsdu=3"   and none worked. I still get disconnected after a few pings

My install ISO is using the kernel 5.18.7 and using the firmware 29.4063824552.0
My computer is also using the firmware=29.4063824552.0 (same firmware)

Offline

#4 2022-07-24 19:46:34

seth
Member
Registered: 2012-09-03
Posts: 31,849

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

I then guess the behavior is fine w/ the LST kernel?

Online

#5 2022-07-24 21:36:57

Blackmine57
Member
Registered: 2019-08-29
Posts: 18

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

If you mean LTS kernel I just tried and I do have the exact same issue. I cannot access internet without 11n_disable=1

Offline

#6 2022-07-25 06:31:16

seth
Member
Registered: 2012-09-03
Posts: 31,849

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

So it's neither the kernel nor the firmware.
Leaves the sw stack, w/ the obvious chance that you're using iwd on the iso and wpa_supplicant on the installed system.
Could also be triggered by NMs scanning habits.

=> Post a complete system journal and disable whatever network config tool you use, reboot (to reset¹ the chip) and try to connect w/ iwd only.
For NM it might be enough to disable https://wiki.archlinux.org/title/Networ … domization

[1] ceterum censeo: if there's a parallel windows, see the 3rd link below (the BIOS will likely understand that you're not waking up from a USB key and that might make the difference there)

Online

#7 2022-07-25 11:27:36

Blackmine57
Member
Registered: 2019-08-29
Posts: 18

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

Hi,

Thanks for your reply

I just tried with IWD and I do have the exact same issue. I cannot access to internet after few pings / requests without 11n_disable.
With 11n_disable :

Here is a dmesg using NetworkManager : https://pastebin.com/4ejy3UR0
And here is one with IWD : https://pastebin.com/JgN39n8t


Without 11n_disable :
NM : https://pastebin.com/gLpRPmrP
IWD : https://pastebin.com/w3GdRPSJ

I'm really not sure everything is needed, but whatever.

I also tried to disable MAC Address Randomization but it does not work neither without 11n.

I also had a windows install a week ago but I wiped it. But I remember I disabled fastboot

Offline

#8 2022-07-25 12:58:08

seth
Member
Registered: 2012-09-03
Posts: 31,849

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

"sudo journalctl -b", not dmesg (it doesn't log the userspace so the interaction of the userspace tools isn't recorded in those pastes - you can only see that at some point teh queue is stuck and the FW crashes)

Edit: "… -b -<n>" allows you to go back in time, so … "sudo journalctl -b -1" is the previous boot etc. - you don't have to re-create the setups.

Last edited by seth (2022-07-25 12:59:40)

Online

#9 2022-07-25 17:51:58

Blackmine57
Member
Registered: 2019-08-29
Posts: 18

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

Oh, I'm sorry !

-b -1 : http://0x0.st/ojfj.txt 
-b -2 : http://0x0.st/ojfe.txt
-b -3 : http://0x0.st/ojf2.txt
-b -4 : http://0x0.st/ojf_.txt

I did not put -b -0 because it'd almost be the same as another.
I'm really sorry but I do not know which one is with or without IWD. If you want I can make everything again. It might be easier for you. Feel free to ask !

Thank you again for helping me !

Offline

#10 2022-07-25 20:47:47

seth
Member
Registered: 2012-09-03
Posts: 31,849

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

The FW crashes in three of the boots after ca. 16, 23 and 36 seconds
In the short one, dnsmasq is started before. For the other ones inbetween the NIC activation and the FW crash.
=> Try to disable dnsmasq (and dnsmasq-dhcp) Make sure the related iptable rules aren't loaded.
See what happens.

Online

#11 2022-07-25 21:43:14

Blackmine57
Member
Registered: 2019-08-29
Posts: 18

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

Here are the latest logs without dnsmasq and I do have the same errors.
https://0x0.st/ojV-.txt
I'm quite sure that none of my firewall rules are about dnsmasq, but here there are https://0x0.st/ojVo.txt

Thank you

Offline

#12 2022-07-26 06:38:43

seth
Member
Registered: 2012-09-03
Posts: 31,849

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

Nothing sad
You get connected, poll dmesg and after ~1m the FW crashes.
To be absolutely sure:

I tried  cfg80211 cfg80211_disable_40mhz_24ghz=Y     ;      iwlwifi.disable_11ac=1     ;   "iwlwifi.power_save=0" and "iwlwifi.amsdu=3"   and none worked.

One of those is not like the others and there's no business for semicolons in this context - you did apply those settings successfully and went for "cfg80211.cfg80211_disable_40mhz_24ghz=Y" in case you used it as kernel parameter?
(I'm sorry to ask, but I'm running out of ideas and there're ppl. on this forum who'll try to enter kernel parameters into an interactive shell…)

Throwing more stuff at the wall:
https://bbs.archlinux.org/viewtopic.php … 7#p2022487 (but I don't see how this would cause a firmware crash)

I still get disconnected after a few pings

Is this actually a constant

ping -q _gateway

to keep a "lifeline" on the NIC?
I guess you've at some point seen https://bbs.archlinux.org/viewtopic.php … 3#p1918843 - did you try any/all of

options iwlwifi swcrypto=0
options iwlwifi bt_coex_active=0
options iwlwifi power_save=0
options iwlwifi uapsd_disable=1
options iwlmvm power_scheme=1

Online

#13 2022-07-26 10:52:26

Blackmine57
Member
Registered: 2019-08-29
Posts: 18

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

Rewrite :

seth wrote:

One of those is not like the others and there's no business for semicolons in this context - you did apply those settings successfully and went for "cfg80211.cfg80211_disable_40mhz_24ghz=Y" in case you used it as kernel parameter?
(I'm sorry to ask, but I'm running out of ideas and there're ppl. on this forum who'll try to enter kernel parameters into an interactive shell…)

I put ";" to make something like a list. I did not really put them. I also did not execute the command in a terminal. Only in /etc/modprobe.d/iwlwifi.conf
Here are my logs with all of these parameters : http://0x0.st/ojJS.txt
Here is my iwlwifi.conf : https://0x0.st/ojJM.txt. I did put everything possible, but I also tested all one by one.

seth wrote:

You did apply those settings successfully and went for "cfg80211.cfg80211_disable_40mhz_24ghz=Y" in case you used it as kernel parameter?

Yeah I did apply all those settings. However I was quite confused about "cfg80211.cfg80211_disable_40mhz_24ghz=Y" because I did never see anything like "ANY.ANY" in that file.
So, I used "options cfg80211 cfg80211_disable_40mhz_24ghz=Y". Is it correct ?

seth wrote:

Is this actually a constant
ping -q _gateway
to keep a "lifeline" on the NIC?

No it is not, I am quickly unable to ping the gateway. The disconnection is even faster if I do something like a CURL, WGET, speedtest etc... (works with 11n_disable=1)

seth wrote:

I guess you've at some point seen https://bbs.archlinux.org/viewtopic.php … 3#p1918843 - did you try any/all of

Yeah, I tried all one by one. It did not work for me. I always have the same issue : after few pings/curl/etc I get disconnected

seth wrote:

https://bbs.archlinux.org/viewtopic.php … 7#p2022487 (but I don't see how this would cause a firmware crash)

I'm going to try that !
Just tried, same issue

Last edited by Blackmine57 (2022-07-26 12:35:25)

Offline

#14 2022-07-26 15:47:25

seth
Member
Registered: 2012-09-03
Posts: 31,849

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

Yeah I did apply all those settings. However I was quite confused about "cfg80211.cfg80211_disable_40mhz_24ghz=Y" because I did never see anything like "ANY.ANY" in that file.

The syntax between /etc/modprobe.d/*.conf and the kernel commandline differs. You'd just add "iwlwifi.11n_disable=1" to the kernel commandline to apply that parameter.

juil. 26 13:41:38 archlinux kernel: iwlwifi: unknown parameter 'amsdu' ignored

Sorry, it's actually "amsdu_size" - and you'd most likely still have to use "options iwlwifi 11n_disable=8" next to any other parameter (notably disable_11ac=1)

Online

#15 2022-07-26 16:40:06

Blackmine57
Member
Registered: 2019-08-29
Posts: 18

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

Oh okay. I see what you mean. My bad !

I fixed amsdu_size and added 11n_disable=8 but I still have the same problem (and disabled=1)

That's really weird

Offline

#16 2022-07-28 07:24:47

seth
Member
Registered: 2012-09-03
Posts: 31,849

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

I just noticed that those referenced configs all say "options iwlwifi swcrypto=0" which is the default behavior anyway - you could give "options iwlwifi swcrypto=1" a shot to handle the encryption on the CPU.

Online

#17 2022-07-28 16:47:33

Blackmine57
Member
Registered: 2019-08-29
Posts: 18

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

I just tried but nope sad
http://ix.io/45Wq

Offline

#18 2022-07-31 17:09:28

Blackmine57
Member
Registered: 2019-08-29
Posts: 18

Re: [SOLVED] [GOOGLE NEST] 11n_disable=1 needed

SOLVED !
My computer was trying to connect to the wrong router (google nest). I had to manually specify the correct BSSID in NetworkManager.
No clue why I always had so much errors in journalctl but anyway.
Thank you for trying to help me and I'm really sorry if I wasted your time. If I can help in anyway please say smile

Offline

Board footer

Powered by FluxBB