You are not logged in.

#1 2022-07-26 12:23:49

frmar440
Member
Registered: 2022-07-26
Posts: 1

PipeWire - No output devices

Hi, I am new to Linux and currently trying to set up my sound system. My sound server is PipeWire, my session manager is WirePlumber, and I use PulseAudio clients. Everything seems to be up and running:

$ pactl info
Server String: /run/user/1000/pulse/native                                                                                               
Library Protocol Version: 35                                                                                                             
Server Protocol Version: 35                                                                                                             
Is Local: yes                                                                                                                           
Client Index: 102                                                                                                                       
Tile Size: 65472                                                                                                                         
User Name: fredericmarcotte                                                                                                             
Host Name: ThinkPadX1FM                                                                                                                 
Server Name: PulseAudio (on PipeWire 0.3.56)                                                                                             
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: auto_null
Default Source: auto_null.monitor
Cookie: bcfe:f1e2

$ systemctl --user status pipewire pipewire-pulse wireplumber
● pipewire.service - PipeWire Multimedia Service                                                                                         
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; preset: enabled)                                                   
     Active: active (running) since Tue 2022-07-26 07:53:40 EDT; 19min ago                                                               
TriggeredBy: ● pipewire.socket                                                                                                           
   Main PID: 863 (pipewire)                                                                                                             
      Tasks: 6 (limit: 18847)
     Memory: 13.0M
        CPU: 151ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             ├─863 /usr/bin/pipewire
             └─879 /usr/bin/wireplumber

Jul 26 07:53:40 ThinkPadX1FM systemd[856]: Started PipeWire Multimedia Service.
Jul 26 07:53:40 ThinkPadX1FM wireplumber[879]: Failed to set scheduler settings: Operation not permitted
Jul 26 07:53:40 ThinkPadX1FM wireplumber[879]: SPA handle 'api.libcamera.enum.manager' could not be loaded; is it installed?
Jul 26 07:53:40 ThinkPadX1FM wireplumber[879]: PipeWire's libcamera SPA missing or broken. libcamera not supported.
Jul 26 07:53:40 ThinkPadX1FM wireplumber[879]: reserve-device plugin is not connected to D-Bus, disabling device reservation
Jul 26 07:56:31 ThinkPadX1FM wireplumber[879]: <WpSiStandardLink:0x561d0f865e10> 2 of 2 PipeWire links failed to activate

● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; enabled; preset: enabled)
     Active: active (running) since Tue 2022-07-26 07:53:40 EDT; 19min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 865 (pipewire-pulse)
      Tasks: 2 (limit: 18847)
     Memory: 3.1M
        CPU: 76ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─865 /usr/bin/pipewire-pulse

Jul 26 07:53:40 ThinkPadX1FM systemd[856]: Started PipeWire PulseAudio.

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; preset: enabled)
     Active: active (running) since Tue 2022-07-26 07:53:40 EDT; 19min ago
   Main PID: 864 (wireplumber)
      Tasks: 4 (limit: 18847)
     Memory: 4.1M
        CPU: 79ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─864 /usr/bin/wireplumber

Jul 26 07:53:40 ThinkPadX1FM systemd[856]: Started Multimedia Service Session Manager.
Jul 26 07:53:40 ThinkPadX1FM wireplumber[864]: Failed to set scheduler settings: Operation not permitted
Jul 26 07:53:40 ThinkPadX1FM wireplumber[864]: SPA handle 'api.libcamera.enum.manager' could not be loaded; is it installed?
Jul 26 07:53:40 ThinkPadX1FM wireplumber[864]: PipeWire's libcamera SPA missing or broken. libcamera not supported.
Jul 26 07:53:40 ThinkPadX1FM wireplumber[864]: reserve-device plugin is not connected to D-Bus, disabling device reservation
Jul 26 08:08:05 ThinkPadX1FM wireplumber[864]: <WpSiStandardLink:0x563164a32540> 2 of 2 PipeWire links failed to activate

However, as you can see from `pactl info` output, the default sink is auto_null. Also `pactl list sinks` doesn't list my headphones plugged in the audio jack port. With pavucontrol, only dummy output appears in the output devices.

I have read several topics, but can't seem to find an answer to my issue.

Best,

Frederic

Offline

#2 2022-07-26 12:33:32

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 4,636

Re: PipeWire - No output devices

Please edit your post and use [ code ] tags (not quote tags) when posting output. This makes the output easier to read and provides a scroll box for long output.

https://wiki.archlinux.org/title/Genera … s_and_code
https://bbs.archlinux.org/help.php#bbcode


How to post. A sincere effort to use modest and proper language and grammar is a sign of respect toward the community.

Offline

#3 2022-07-26 13:30:05

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,037

Re: PipeWire - No output devices

What actual devices are even detected in the first place?

aplay -lL
pactl list cards

Offline

#4 2023-03-06 10:44:52

m32w
Member
Registered: 2023-03-06
Posts: 1

Re: PipeWire - No output devices

[core-ssh ~]$ aplay -lL
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default
    Default ALSA Output (Home Assistant PulseAudio Sound Server)
aplay: device_list:275: no soundcards found...
[core-ssh ~]$ pactl list cards
Card #1
        Name: bluez_card.B1_29_34_2B_62_53
        Driver: module-bluez5-device.c
        Owner Module: 16
        Properties:
                device.description = "TEST"
                device.string = "B1:29:34:2B:62:53"
                device.api = "bluez"
                device.class = "sound"
                device.bus = "bluetooth"
                device.form_factor = "headset"
                bluez.path = "/org/bluez/hci0/dev_B1_29_34_2B_62_53"
                bluez.class = "0x340404"
                bluez.alias = "TEST"
                device.icon_name = "audio-headset-bluetooth"
                device.intended_roles = "phone"
        Profiles:
                a2dp_sink: High Fidelity Playback (A2DP Sink) (sinks: 1, sources: 0, priority: 40, available: yes)
                off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
        Active Profile: a2dp_sink
        Ports:
                headset-output: Headset (type: Headset, priority: 0, latency offset: 0 usec, available)
                        Part of profile(s): a2dp_sink
                headset-input: Headset (type: Headset, priority: 0, latency offset: 0 usec, not available)

Offline

#5 2023-03-06 15:53:43

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 19,678

Re: PipeWire - No output devices

m32w:  Welcome to the Arch Linux forums.   The original poster in this thread has only ever made a single post and has not responded to the tread for more than half a year.
I am going to assume your problem is not the same as the original poster's give the time frame.

I am going to close this old thread as having been abandoned, and invite you to start a new thread that you will own.  If you feel this thread is relevant, go ahead and link back to this this thread in your new thread.

Thanks.

frmar440:  Should you return and wish this thread reopened, please use the report link to drop a note to the moderators with your request.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB