You are not logged in.

#1 2022-08-01 17:06:49

zong
Member
Registered: 2022-08-01
Posts: 4

service issue before login to user (nginx, samba)

Hi,

I am running Nginx and Samba on my personal computer. I found a very wired issue recently.
The service Nginx and samba do not work if I do not log in to my personal account.

I check the  following things:
1. startup computer
2. login to root. (not personal user)
3. check network status using (ping) (work)
4. check nginx, smb, nmb service(systemctl status). (work)
5. visit the server using another computer. (does not work) (samba and website)
6. login to personal user. (just login from tty, nothing else)
7. visit the server using another computer. (work) (samba and website)
8. 4. check nginx, smb, nmb service(systemctl status). (same as 4)

I read the wiki and tried to find the reason and solve the problem but failed.

Thanks for any help and discussion.

Offline

#2 2022-08-01 17:19:34

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,053
Website

Re: service issue before login to user (nginx, samba)

Step 5 needs elabortation... what does "not working" look like?  What errors do you get on the visiting client?  Have you tried pinging or nmap'ing the server?  What errors or changes in the log / status / journal do you get after a failed connection attempt (e.g., repeat the check in #4 after #5 fails).


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2022-08-01 17:30:40

zong
Member
Registered: 2022-08-01
Posts: 4

Re: service issue before login to user (nginx, samba)

Trilby wrote:

Step 5 needs elabortation... what does "not working" look like?  What errors do you get on the visiting client?  Have you tried pinging or nmap'ing the server?  What errors or changes in the log / status / journal do you get after a failed connection attempt (e.g., repeat the check in #4 after #5 fails).

Thanks for your reply.
I did check #4 after #5 fails

I try following things.

ping from mac --> archlinux server(login root). (request timeout)
ping from archlinux (login root only) --> mac (work)
ping from archlinux (login personal user) --> mac (work)
ping from mac --> archlinux server(login personal user). (work)

nmap scan server port (login root) nothing found.
nmap scan server port (login person user) 4 ports found.

nmap scan localhost(login as root)  get 4 ports .

Last edited by zong (2022-08-01 17:37:36)

Offline

#4 2022-08-01 17:46:18

zong
Member
Registered: 2022-08-01
Posts: 4

Re: service issue before login to user (nginx, samba)

I found out what causes the issue. I installed another video card recently and set up Xorg multi-seat.
After I remove the seat1. Everything works fine.

This may be a bug related to Xorg.

Offline

#5 2022-08-01 21:02:09

seth
Member
Registered: 2012-09-03
Posts: 30,881

Re: service issue before login to user (nginx, samba)

This may be a bug related to Xorg.

No. This is a problem with how and when you configure what network device.

You should™ not have to login at all to be able to ping the system, let alone start a display server and if there're wired and wifi NICs obtaining different IPs in parallel, you might be able to get an outbound route over the wired NIC but are trying to ping the wifi NIC.
Or, if the relevant NIC is a usb dongle, you might have assigned it to a systemd seat - but there's no way that "a bug related to Xorg" broke your network ("ping from mac --> archlinux server(login root). (request timeout)")

Online

#6 2022-08-06 19:19:25

zong
Member
Registered: 2022-08-01
Posts: 4

Re: service issue before login to user (nginx, samba)

seth wrote:

This may be a bug related to Xorg.

No. This is a problem with how and when you configure what network device.

You should™ not have to login at all to be able to ping the system, let alone start a display server and if there're wired and wifi NICs obtaining different IPs in parallel, you might be able to get an outbound route over the wired NIC but are trying to ping the wifi NIC.
Or, if the relevant NIC is a usb dongle, you might have assigned it to a systemd seat - but there's no way that "a bug related to Xorg" broke your network ("ping from mac --> archlinux server(login root). (request timeout)")

I am not sure what happened, but only thing I did is using "loginctl" to attach a graphic card to seat1. That's all. I did not do anything related to the network device.

Last edited by zong (2022-08-06 19:20:55)

Offline

#7 2022-08-06 19:50:21

seth
Member
Registered: 2012-09-03
Posts: 30,881

Re: service issue before login to user (nginx, samba)

Neither are we, but I guess your system journal knows…

Online

Board footer

Powered by FluxBB