You are not logged in.

#1 2022-08-04 02:50:16

Kritiqual
Member
Registered: 2021-09-10
Posts: 16

[Solved] How to disable beep noise when booting Archlinux iso?

When I boot the iso from USB, on the countdown screen, there is large beep noise when the menu first show up and when the timer is counting. Also I see something like "ACPI BIOS error" before menu show up if it related. How can I disable large beep noise? And what does that error means, is it come from my hardware or from the iso?

Last edited by Kritiqual (2022-08-06 13:15:25)

Offline

#2 2022-08-04 02:55:08

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,135
Website

Re: [Solved] How to disable beep noise when booting Archlinux iso?


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2022-08-04 05:56:09

nl6720
Wiki Admin
Registered: 2016-07-02
Posts: 372

Re: [Solved] How to disable beep noise when booting Archlinux iso?

The beep is made by GRUB, so from jasonwryan's linked options, only "physically" would work. Or if it's an emulated PC speaker, like laptops have, then maybe it can be disabled in firmware settings.

Offline

#4 2022-08-06 13:15:44

Kritiqual
Member
Registered: 2021-09-10
Posts: 16

Re: [Solved] How to disable beep noise when booting Archlinux iso?

Thanks, only disable it in firmware setting worked

Offline

#5 2022-08-08 07:01:57

mass_t
Member
Registered: 2015-04-21
Posts: 44

Re: [Solved] How to disable beep noise when booting Archlinux iso?

echo "blacklist pcspkr" | sudo tee /etc/modprobe.d/nobeep.conf && sudo rmmod pcspkr

Offline

#6 2022-08-08 09:57:22

Kritiqual
Member
Registered: 2021-09-10
Posts: 16

Re: [Solved] How to disable beep noise when booting Archlinux iso?

mass_t wrote:

echo "blacklist pcspkr" | sudo tee /etc/modprobe.d/nobeep.conf && sudo rmmod pcspkr

Sorry, but that's not work on iso

Offline

#7 Yesterday 23:21:13

eduhoribe
Member
Registered: Yesterday
Posts: 1

Re: [Solved] How to disable beep noise when booting Archlinux iso?

You can edit the .../EFI/BOOT/grub.cfg file on the flash drive and remove or comment the line with the playcommand. Mine was around the line 29.

...
# GRUB init tune for accessibility
# play 600 988 1 1319 4
...

Last edited by eduhoribe (Yesterday 23:52:15)

Offline

Board footer

Powered by FluxBB