You are not logged in.

#1 2022-08-17 14:47:58

matafan
Member
Registered: 2013-11-29
Posts: 7

KDE Wallet has become very slow to start

After yesterday's update, KDE Wallet's startup has become very slow.

I'm not sure exactly how KDE Wallet is architectured, but what I mean is that the dialog asking you for your password is now displayed almost a minute after KDE has started, as opposed to being displayed immediately like it used to be. This is very annoying as launching Chromium before KDE Wallet's password has been provided results in all state data (cookies, local storage, etc) being lost.

I'm using GPG for my main (kdewallet) wallet. Anyone else experiencing this?

Offline

#2 2022-08-18 02:44:13

SelfAdjointOperator
Member
From: UK
Registered: 2021-04-29
Posts: 7
Website

Re: KDE Wallet has become very slow to start

Hi, I'm having the same issue. KDE Wallet slow to launch (to show the little unlock dialog), and also I keep losing Chromium cookies. Quite annoying yeah lol.

Offline

#3 2022-08-18 22:02:27

chmurli
Member
Registered: 2008-12-23
Posts: 51

Re: KDE Wallet has become very slow to start

Same problem here. I cannot start Chromium or Spotify in a reasonable time.
Downgrading kwallet to 5.96.0-1 fixes the problem.

Last edited by chmurli (2022-08-18 22:02:45)

Offline

#4 2022-08-19 01:35:36

SelfAdjointOperator
Member
From: UK
Registered: 2021-04-29
Posts: 7
Website

Re: KDE Wallet has become very slow to start

chmurli wrote:

Downgrading kwallet to 5.96.0-1 fixes the problem.

Yeah that works for me too as a temporary workaround, thanks

Offline

#5 2022-08-19 02:04:28

SelfAdjointOperator
Member
From: UK
Registered: 2021-04-29
Posts: 7
Website

Re: KDE Wallet has become very slow to start

Opened a bug report here

Offline

#6 2022-08-19 06:15:54

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,097

Re: KDE Wallet has become very slow to start

Please report it upstream

Offline

#7 2022-08-20 07:04:46

matafan
Member
Registered: 2013-11-29
Posts: 7

Re: KDE Wallet has become very slow to start

Thanks you everyone. I've reported the bug upstream: https://bugs.kde.org/show_bug.cgi?id=458085

Offline

#8 2022-08-26 08:53:02

matafan
Member
Registered: 2013-11-29
Posts: 7

Re: KDE Wallet has become very slow to start

Seems to have been fixed by the latest update. Looks like it was an Arch issue after all. I've self-closed KDE bug 458085.

Offline

#9 2022-08-26 09:38:54

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,097

Re: KDE Wallet has become very slow to start

Being fixed by the latest update doesn't mean it's an Arch issue. Quite the opposite: the latest update adds an upstream patch which is still pending review.

Offline

#10 2022-08-26 17:46:58

SelfAdjointOperator
Member
From: UK
Registered: 2021-04-29
Posts: 7
Website

Re: KDE Wallet has become very slow to start

I've just tested version 5.97.0-3 (latest as of posting) and the issue is still present: slow startup and cookies missing. Still staying on 5.96.0-1 for now.

Offline

#11 2022-08-28 07:58:42

matafan
Member
Registered: 2013-11-29
Posts: 7

Re: KDE Wallet has become very slow to start

To fix the issue you need to do two things: update to kwallet 5.97.0-3, and disable "Secret Service DBus API" in KDE's System Settings.

From what I understand the fix in kwallet 5.97.0-3 is just a quick workaround, not the final solution to this issue which appears to be a deadlock between kwallet and gpg

Offline

#12 2022-08-30 11:34:34

SelfAdjointOperator
Member
From: UK
Registered: 2021-04-29
Posts: 7
Website

Re: KDE Wallet has become very slow to start

I've tested version 5.97.0-4 and the bug still persists. Where is the "Secret Service DBus API" located in Settings, I can't find it?

Offline

#13 2022-08-30 15:10:33

matafan
Member
Registered: 2013-11-29
Posts: 7

Re: KDE Wallet has become very slow to start

The option is in Settings -> KDE Wallet -> Enable Secret Service DBus API (uncheck the option)

However there seem to be a better workaround: you can leave the option checked, but add "no-allow-external-cache" to your ~/.gnupg/gpg-agent.conf file.

Offline

#14 2022-09-01 07:33:23

stuartn60
Member
Registered: 2022-09-01
Posts: 3

Re: KDE Wallet has become very slow to start

This has been a very annoying issue ... I'm an opensuse tumbleweed user with a fully up-to-date system ... I've tried all the workarounds that I'm able to without success and only been able to solve this by using Kleopatra to reset my kdewallet password to empty ... temporary solution until all this is resolved ... hope this helps others until there is a fix ... cheers

Offline

#15 2022-09-01 17:10:59

DRFK
Member
Registered: 2020-12-17
Posts: 10

Re: KDE Wallet has become very slow to start

stuartn60 wrote:

This has been a very annoying issue ... I'm an opensuse tumbleweed user with a fully up-to-date system ... I've tried all the workarounds that I'm able to without success and only been able to solve this by using Kleopatra to reset my kdewallet password to empty ... temporary solution until all this is resolved ... hope this helps others until there is a fix ... cheers

I am afraid there won't be a fix. In fact, according to https://bugs.kde.org/show_bug.cgi?id=458085#c36 the recommended solution is the above-mentioned one, i.e., add "no-allow-external-cache" to ~/.gnupg/gpg-agent.conf while keeping Secret Service API support enabled. Works fine here for current openSUSE Tumbleweed (sorry for hijacking this thread).

Offline

#16 2022-09-01 20:37:16

DRFK
Member
Registered: 2020-12-17
Posts: 10

Re: KDE Wallet has become very slow to start

Offline

#17 2022-09-02 00:55:26

stuartn60
Member
Registered: 2022-09-01
Posts: 3

Re: KDE Wallet has become very slow to start

DRFK wrote:

I am afraid there won't be a fix. In fact, according to https://bugs.kde.org/show_bug.cgi?id=458085#c36 the recommended solution is the above-mentioned one, i.e., add "no-allow-external-cache" to ~/.gnupg/gpg-agent.conf while keeping Secret Service API support enabled. Works fine here for current openSUSE Tumbleweed (sorry for hijacking this thread).

I've again tried "no-allow-external-cache" with a passphrase ... unfortunately there is still a 50-sec wait for kdewallet to start ... not sure why this is different to your experience smile

Offline

#18 2022-09-02 17:19:32

DRFK
Member
Registered: 2020-12-17
Posts: 10

Re: KDE Wallet has become very slow to start

stuartn60 wrote:
DRFK wrote:

I am afraid there won't be a fix. In fact, according to https://bugs.kde.org/show_bug.cgi?id=458085#c36 the recommended solution is the above-mentioned one, i.e., add "no-allow-external-cache" to ~/.gnupg/gpg-agent.conf while keeping Secret Service API support enabled. Works fine here for current openSUSE Tumbleweed (sorry for hijacking this thread).

I've again tried "no-allow-external-cache" with a passphrase ... unfortunately there is still a 50-sec wait for kdewallet to start ... not sure why this is different to your experience smile

Could you please leave a comment at https://bugs.kde.org/show_bug.cgi?id=458085? Thx.

Offline

#19 2022-09-03 07:01:52

stuartn60
Member
Registered: 2022-09-01
Posts: 3

Re: KDE Wallet has become very slow to start

Today's massive update in Tumbleweed to KDE Plasma 5.24.4 KDE Framework 5.97.0 & QT 5.15.5 seems to have remedied the issue ... I have both the secret-bus and "no-allow-external-cache" in gpg-agent.conf ... many thanks for your interest

Offline

#20 2022-09-03 08:18:30

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 2,097

Re: KDE Wallet has become very slow to start

Can we please stop the opensuse hijack.

Offline

#21 2022-11-13 19:22:29

SelfAdjointOperator
Member
From: UK
Registered: 2021-04-29
Posts: 7
Website

Re: KDE Wallet has become very slow to start

matafan wrote:

The option is in Settings -> KDE Wallet -> Enable Secret Service DBus API (uncheck the option)

However there seem to be a better workaround: you can leave the option checked, but add "no-allow-external-cache" to your ~/.gnupg/gpg-agent.conf file.

Hi, sorry for the very late reply.
I was using kwallet 5.96.0-1 for the longest time (until today) because of the bug, using --ignore kwallet whenever -Syu-ing.
I've -Syu-ed today, including kwallet, now on version 5.99.0-1. Disabling Secret Service DBus API in KDE's settings works for me, no need to edit gpg-agent.conf.
For the record I tested 5.99.0-1 with the SS DBus API enabled and the deadlock still persists / Chromium loses its cookies (I made backups of .{config,cache}/chromium though, all good).
Thanks

Offline

Board footer

Powered by FluxBB