You are not logged in.

#1 2022-08-27 23:23:58

MarlonCendron
Member
Registered: 2020-01-14
Posts: 6

Error on python-dephell-setuptools when trying to update AUR packages

Running

yay -Syyu

I get the following error:

[sudo] password for marlon: 
:: Synchronizing package databases...
 core                                                                       158.3 KiB   490 KiB/s 00:00 [##############################################################] 100%
 extra                                                                     1826.8 KiB  1293 KiB/s 00:01 [##############################################################] 100%
 community                                                                    6.8 MiB  1099 KiB/s 00:06 [##############################################################] 100%
 multilib                                                                   176.4 KiB  1400 KiB/s 00:00 [##############################################################] 100%
:: Starting full system upgrade...
 there is nothing to do
:: Searching databases for updates...
:: Searching AUR for updates...
 -> Orphaned AUR Packages:  python-dephell-archive  python-dephell-argparse  python-dephell-changelogs  python-dephell-discover  python-dephell-licenses  python-dephell-links  python-dephell-markers  python-dephell-pythons  python-dephell-setuptools  python-dephell-shells  python-dephell-specifier  python-dephell-venvs  python-dephell-versioning
 -> Flagged Out Of Date AUR Packages:  qt5-styleplugins  tableplus
:: 6 Packages to upgrade.
6  aur/python-dephell-setuptools  0.2.4-4           -> 0.2.5-1
5  aur/python-grpcio-tools        1.46.1-1          -> 1.47.0-1
4  aur/qt5-styleplugins           5.0.0.20170311-28 -> 5.0.0.20170311-29
3  aur/spotify                    1:1.1.84.716-1    -> 1:1.1.84.716-2
2  aur/visual-studio-code-bin     1.69.2-1          -> 1.70.2-1
1  aur/yay                        11.1.2-1          -> 11.3.0-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
==> 

:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur:6]  python-dephell-setuptools-0.2.5-1  python-grpcio-tools-1.47.0-1  qt5-styleplugins-5.0.0.20170311-29  spotify-1:1.1.84.716-2  visual-studio-code-bin-1.70.2-1  yay-11.3.0-1

  6 python-dephell-setuptools                (Installed) (Build Files Exist)
  5 python-grpcio-tools                      (Installed) (Build Files Exist)
  4 qt5-styleplugins                         (Installed) (Build Files Exist)
  3 spotify                                  (Installed) (Build Files Exist)
  2 visual-studio-code-bin                   (Installed) (Build Files Exist)
  1 yay                                      (Installed) (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> :: PKGBUILD up to date, Skipping (6/0): python-grpcio-tools, qt5-styleplugins, spotify, visual-studio-code-bin, yay, python-dephell-setuptools
  6 python-dephell-setuptools                (Installed) (Build Files Exist)
  5 python-grpcio-tools                      (Installed) (Build Files Exist)
  4 qt5-styleplugins                         (Installed) (Build Files Exist)
  3 spotify                                  (Installed) (Build Files Exist)
  2 visual-studio-code-bin                   (Installed) (Build Files Exist)
  1 yay                                      (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: (1/6) Parsing SRCINFO: python-dephell-setuptools
:: (2/6) Parsing SRCINFO: python-grpcio-tools
:: (3/6) Parsing SRCINFO: qt5-styleplugins
:: (4/6) Parsing SRCINFO: spotify
:: (5/6) Parsing SRCINFO: visual-studio-code-bin
:: (6/6) Parsing SRCINFO: yay
==> Making package: python-dephell-setuptools 0.2.5-1 (Sat 27 Aug 2022 08:20:47 PM -03)
==> Retrieving sources...
  -> Found python-dephell-setuptools-0.2.5.tar.gz
==> Validating source files with sha256sums...
    python-dephell-setuptools-0.2.5.tar.gz ... Passed
==> Making package: spotify 1:1.1.84.716-2 (Sat 27 Aug 2022 08:20:48 PM -03)
==> Retrieving sources...
  -> Found spotify.protocol
  -> Found LICENSE
  -> Found spotify-1.1.84.716-x86_64.deb
  -> Found spotify-1.1.84.716-2-Release
  -> Found spotify-1.1.84.716-2-Release.sig
  -> Found spotify-1.1.84.716-2-x86_64-Packages
==> Validating source files with sha512sums...
    spotify.protocol ... Passed
    LICENSE ... Passed
    spotify-1.1.84.716-x86_64.deb ... Passed
    spotify-1.1.84.716-2-Release ... Skipped
    spotify-1.1.84.716-2-Release.sig ... Skipped
    spotify-1.1.84.716-2-x86_64-Packages ... Skipped
==> Verifying source file signatures with gpg...
    spotify-1.1.84.716-2-Release ... Passed
==> Making package: qt5-styleplugins 5.0.0.20170311-29 (Sat 27 Aug 2022 08:20:48 PM -03)
==> Retrieving sources...
  -> Found qt5-styleplugins-335dbece103e2cbf6c7cf819ab6672c2956b17b3.tar.gz
  -> Found 0001-fix-build-against-Qt-5.15.patch
  -> Found 0002-fix-gtk2-background.patch
  -> Found qt5-styleplugins.hook
==> Validating source files with sha512sums...
    qt5-styleplugins-335dbece103e2cbf6c7cf819ab6672c2956b17b3.tar.gz ... Passed
    0001-fix-build-against-Qt-5.15.patch ... Passed
    0002-fix-gtk2-background.patch ... Passed
    qt5-styleplugins.hook ... Passed
==> Making package: python-grpcio-tools 1.47.0-1 (Sat 27 Aug 2022 08:20:49 PM -03)
==> Retrieving sources...
  -> Found grpcio-tools-1.47.0.tar.gz
==> Validating source files with sha512sums...
    grpcio-tools-1.47.0.tar.gz ... Passed
==> Making package: visual-studio-code-bin 1.70.2-1 (Sat 27 Aug 2022 08:20:50 PM -03)
==> Retrieving sources...
  -> Found visual-studio-code.desktop
  -> Found visual-studio-code-url-handler.desktop
  -> Found visual-studio-code-workspace.xml
  -> Found visual-studio-code-bin.sh
  -> Found code_x64_1.70.2.tar.gz
==> Validating source files with sha256sums...
    visual-studio-code.desktop ... Passed
    visual-studio-code-url-handler.desktop ... Passed
    visual-studio-code-workspace.xml ... Passed
    visual-studio-code-bin.sh ... Passed
==> Validating source_x86_64 files with sha256sums...
    code_x64_1.70.2.tar.gz ... Passed
==> Making package: yay 11.3.0-1 (Sat 27 Aug 2022 08:20:52 PM -03)
==> Retrieving sources...
  -> Found yay-11.3.0.tar.gz
==> Validating source files with sha256sums...
    yay-11.3.0.tar.gz ... Passed
==> Making package: python-dephell-setuptools 0.2.5-1 (Sat 27 Aug 2022 08:20:52 PM -03)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found python-dephell-setuptools-0.2.5.tar.gz
==> Validating source files with sha256sums...
    python-dephell-setuptools-0.2.5.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting python-dephell-setuptools-0.2.5.tar.gz with bsdtar
==> Starting prepare()...
==> Sources are ready.
==> Making package: python-dephell-setuptools 0.2.5-1 (Sat 27 Aug 2022 08:20:54 PM -03)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Removing existing $pkgdir/ directory...
==> Starting build()...
* Getting dependencies for wheel...
/usr/lib/python3.10/site-packages/setuptools/dist.py:772: UserWarning: Usage of dash-separated 'description-file' will not be supported in future versions. Please use the underscore name 'description_file' instead
  warnings.warn(
/usr/lib/python3.10/site-packages/setuptools/config/setupcfg.py:459: SetuptoolsDeprecationWarning: The license_file parameter is deprecated, use license_files instead.
  warnings.warn(msg, warning_class)
running egg_info
creating dephell_setuptools.egg-info
writing dephell_setuptools.egg-info/PKG-INFO
writing dependency_links to dephell_setuptools.egg-info/dependency_links.txt
writing top-level names to dephell_setuptools.egg-info/top_level.txt
writing manifest file 'dephell_setuptools.egg-info/SOURCES.txt'
reading manifest file 'dephell_setuptools.egg-info/SOURCES.txt'
adding license file 'LICENSE'
writing manifest file 'dephell_setuptools.egg-info/SOURCES.txt'
* Building wheel...
/usr/lib/python3.10/site-packages/setuptools/dist.py:772: UserWarning: Usage of dash-separated 'description-file' will not be supported in future versions. Please use the underscore name 'description_file' instead
  warnings.warn(
/usr/lib/python3.10/site-packages/setuptools/config/setupcfg.py:459: SetuptoolsDeprecationWarning: The license_file parameter is deprecated, use license_files instead.
  warnings.warn(msg, warning_class)
running bdist_wheel
running build
running build_py
creating build
creating build/lib
creating build/lib/dephell_setuptools
copying dephell_setuptools/_cmd.py -> build/lib/dephell_setuptools
copying dephell_setuptools/__init__.py -> build/lib/dephell_setuptools
copying dephell_setuptools/_cli.py -> build/lib/dephell_setuptools
copying dephell_setuptools/_cfg.py -> build/lib/dephell_setuptools
copying dephell_setuptools/_pkginfo.py -> build/lib/dephell_setuptools
copying dephell_setuptools/_manager.py -> build/lib/dephell_setuptools
copying dephell_setuptools/_static.py -> build/lib/dephell_setuptools
copying dephell_setuptools/__main__.py -> build/lib/dephell_setuptools
copying dephell_setuptools/_cached_property.py -> build/lib/dephell_setuptools
copying dephell_setuptools/distutils_cmd.py -> build/lib/dephell_setuptools
copying dephell_setuptools/_constants.py -> build/lib/dephell_setuptools
copying dephell_setuptools/_base.py -> build/lib/dephell_setuptools
installing to build/bdist.linux-x86_64/wheel
running install
running install_lib
creating build/bdist.linux-x86_64
creating build/bdist.linux-x86_64/wheel
creating build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/_cmd.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/__init__.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/_cli.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/_cfg.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/_pkginfo.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/_manager.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/_static.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/__main__.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/_cached_property.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/distutils_cmd.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/_constants.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
copying build/lib/dephell_setuptools/_base.py -> build/bdist.linux-x86_64/wheel/dephell_setuptools
running install_egg_info
running egg_info
writing dephell_setuptools.egg-info/PKG-INFO
writing dependency_links to dephell_setuptools.egg-info/dependency_links.txt
writing top-level names to dephell_setuptools.egg-info/top_level.txt
reading manifest file 'dephell_setuptools.egg-info/SOURCES.txt'
adding license file 'LICENSE'
writing manifest file 'dephell_setuptools.egg-info/SOURCES.txt'
Copying dephell_setuptools.egg-info to build/bdist.linux-x86_64/wheel/dephell_setuptools-0.0.0-py3.10.egg-info
running install_scripts
creating build/bdist.linux-x86_64/wheel/dephell_setuptools-0.0.0.dist-info/WHEEL
creating '/home/marlon/.cache/yay/python-dephell-setuptools/src/dephell_setuptools-v.0.2.5/dist/tmpvzsq1mg7/dephell_setuptools-0.0.0-py3-none-any.whl' and adding 'build/bdist.linux-x86_64/wheel' to it
adding 'dephell_setuptools/__init__.py'
adding 'dephell_setuptools/__main__.py'
adding 'dephell_setuptools/_base.py'
adding 'dephell_setuptools/_cached_property.py'
adding 'dephell_setuptools/_cfg.py'
adding 'dephell_setuptools/_cli.py'
adding 'dephell_setuptools/_cmd.py'
adding 'dephell_setuptools/_constants.py'
adding 'dephell_setuptools/_manager.py'
adding 'dephell_setuptools/_pkginfo.py'
adding 'dephell_setuptools/_static.py'
adding 'dephell_setuptools/distutils_cmd.py'
adding 'dephell_setuptools-0.0.0.dist-info/LICENSE'
adding 'dephell_setuptools-0.0.0.dist-info/METADATA'
adding 'dephell_setuptools-0.0.0.dist-info/WHEEL'
adding 'dephell_setuptools-0.0.0.dist-info/top_level.txt'
adding 'dephell_setuptools-0.0.0.dist-info/RECORD'
removing build/bdist.linux-x86_64/wheel
Successfully built dephell_setuptools-0.0.0-py3-none-any.whl
==> Starting check()...
============================================================================ test session starts ============================================================================
platform linux -- Python 3.10.6, pytest-7.1.2, pluggy-1.0.0
rootdir: /home/marlon/.cache/yay/python-dephell-setuptools/src/dephell_setuptools-v.0.2.5
collected 5 items                                                                                                                                                           

tests/test_cfg.py F                                                                                                                                                   [ 20%]
tests/test_cmd.py .                                                                                                                                                   [ 40%]
tests/test_static.py ...                                                                                                                                              [100%]

================================================================================= FAILURES ==================================================================================
_________________________________________________________________________________ test_cfg __________________________________________________________________________________

    def test_cfg():
        path = Path(__file__).parent / 'setups' / 'setup.cfg'
>       actual = CfgReader(path).content

tests/test_cfg.py:10: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
dephell_setuptools/_cached_property.py:17: in __get__
    value = obj.__dict__[self.func.__name__] = self.func(obj)
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

self = <dephell_setuptools._cfg.CfgReader object at 0x7f99a5fd5f90>

    @cached_property
    def content(self) -> Dict[str, Any]:
        path = self.path
        if path.name == 'setup.py':
            path = path.parent / 'setup.cfg'
            if not path.exists():
                raise FileNotFoundError(str(path))
    
        parser = ConfigParser()
        parser.read(str(path))
    
        options = deepcopy(parser._sections)  # type: ignore
        for section, content in options.items():
            for k, v in content.items():
                options[section][k] = ('', v)
    
        container = type('container', (), dict.fromkeys(FIELDS))()
>       ConfigOptionsHandler(container, options).parse()
E       TypeError: ConfigOptionsHandler.__init__() missing 2 required positional arguments: 'ignore_option_errors' and 'ensure_discovered'

dephell_setuptools/_cfg.py:42: TypeError
========================================================================== short test summary info ==========================================================================
FAILED tests/test_cfg.py::test_cfg - TypeError: ConfigOptionsHandler.__init__() missing 2 required positional arguments: 'ignore_option_errors' and 'ensure_discovered'
======================================================================== 1 failed, 4 passed in 1.15s ========================================================================
==> ERROR: A failure occurred in check().
    Aborting...
 -> error making: python-dephell-setuptools

Offline

#2 2022-08-28 15:21:14

philo
Member
Registered: 2015-01-26
Posts: 188

Re: Error on python-dephell-setuptools when trying to update AUR packages

This is an AUR package and now orphan.

Offline

#3 2022-08-28 15:32:47

MarlonCendron
Member
Registered: 2020-01-14
Posts: 6

Re: Error on python-dephell-setuptools when trying to update AUR packages

But what do I do to fix it??

Offline

#4 2022-08-28 15:44:13

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,288
Website

Re: Error on python-dephell-setuptools when trying to update AUR packages

Why do you have it installed.  It is only kinda' an AUR package.  It was dropped to the AUR from the main repos.  I suspect you initially installed it from the main repos, but it wouldn't have been dropped if any other package relied on it.  So most likely, you should just remove it and the associated packages unless you use them directly / explicitly.

Any "fix" would be to the upstream code, and upstream appears to have abandonned the project (or at least has not posted any commits in years).

Also please read AUR comments - this issue is already being discussed there.

Aside: please don't needlessly use -Syyu.  That is not the proper way to update your system.

Last edited by Trilby (2022-08-28 15:47:58)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#5 2022-08-28 16:59:05

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,894
Website

Re: Error on python-dephell-setuptools when trying to update AUR packages

Mod note: moving to AUR Issues


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB