You are not logged in.

#1 2022-09-16 17:49:16

jonas-w
Member
Registered: 2022-04-15
Posts: 2

XClip or wl-clipboard as dependency

If a package that is on the AUR requires a clipboard integration like xclip/xsel/wl-clipboard.

What is the best way to handle this?
My solution was to put them as optdepends.
But this isn't really pretty because if someone installs it without looking at the optdepends they won't have clipboard support.
Is there a better solution which maybe let's you choose what clipboard utility you want to install?

Thanks

Offline

#2 2022-09-16 17:53:23

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,288
Website

Re: XClip or wl-clipboard as dependency

jonas-w wrote:

My solution was to put them as optdepends.

Assuming the package in question doesn't specifically require one of them, then this is the right approach.

jonas-w wrote:

... if someone installs it without looking at the optdepends they won't have clipboard support.

That's on them.  There's no amount of code that can eliminate user abuse.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

Board footer

Powered by FluxBB