You are not logged in.

#1 2022-09-19 19:34:53

1nv0k32
Member
Registered: 2022-09-19
Posts: 4

[SOLVED] Microphone problem on Dell XPS 13 plus (9320)

Hi everyone.

I have a weird issue with Microphone in Archlinux and dell XPS 13 plus Developer Edition. To reproduce it follow this:

0. Mic works fine in Arch with sof-firmware.
1. Disable and enable microphone from BIOS (changing and saving anything in BIOS causes this problem)
2. Boot to Arch, The mic records only white noise.
3. Boot to Ubuntu, The mic works there perfectly.
4. Boot to Arch again, Mic works fine as well.

I'm totally confused as it holds the state just before booting to Ubuntu.
Thanks in advance for your time and answers.

Best Regards.

Last edited by 1nv0k32 (2022-09-20 08:35:03)

Offline

#2 2022-09-20 00:53:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,032

Re: [SOLVED] Microphone problem on Dell XPS 13 plus (9320)

Sounds like a BIOS firmware bug that might be fixed by an update there. Is the reboot to Ubuntu strictly necessary or does a reboot/full power cycle back to Arch without the Ubuntu roundtrip work as well?

Offline

#3 2022-09-20 06:40:02

1nv0k32
Member
Registered: 2022-09-19
Posts: 4

Re: [SOLVED] Microphone problem on Dell XPS 13 plus (9320)

@V1del Thanks for the reply.

BIOS bug might be the case. My BIOS is the latest version (1.7.1)
I've also seen this bug happening to other people in the Archwiki discussion.

I've tested different scenarios to see what is going on. This is the result:
- Mic is NOT working in Arch, Boot to Ubuntu, Reboot to Arch, Mic is working in Arch
- Mic is working in Arch, Reboot to Arch, Mic is working in Arch
- Mic is working in Arch, Power off, Power on, Boot to Arch, Mic is NOT working
- Mic is working in Arch, reboot to BIOS, Boot to Arch, Mic is NOT working.

It seems that Archlinux can't initialize something related to the sound device (DSP or something like that) correctly.
I'm using the latest version of every package without any customized configuration.

Last edited by 1nv0k32 (2022-09-20 06:42:20)

Offline

#4 2022-09-20 06:56:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,032

Re: [SOLVED] Microphone problem on Dell XPS 13 plus (9320)

In the not working case, can you restore it  by running

sudo alsactl init

/prevent it from breaking in the first place by running

sudo alsactl store

while it is not broken?

Last edited by V1del (2022-09-20 06:57:07)

Offline

#5 2022-09-20 07:11:40

1nv0k32
Member
Registered: 2022-09-19
Posts: 4

Re: [SOLVED] Microphone problem on Dell XPS 13 plus (9320)

Thanks. This fixed the issue.

Offline

#6 2022-09-20 07:29:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,032

Re: [SOLVED] Microphone problem on Dell XPS 13 plus (9320)

Yeah then it needs an explicit init to a defined state which Ubuntu probably configures by default and Arch will logically set up a service once you ran alsactl store.

In any case, please mark as [SOLVED] by prepending that to the title in your first post.

Offline

Board footer

Powered by FluxBB