You are not logged in.

#1 2022-09-22 06:34:40

ignis.flamme
Member
Registered: 2021-07-12
Posts: 3

[SOLVED] systemd-boot not booting to default despite being told to

I am currently using systemd-boot as my bootloader and have the following as my config in

/boot/loader/loader.conf
timeout menu-hidden
console-mode max
default arch-lts.conf
editor no

According to

https://www.freedesktop.org/software/systemd/man/loader.conf.html

If set to "menu-hidden" or "0" (the default) no menu is shown and the default entry will be booted immediately. The menu can be shown by pressing and holding a key before systemd-boot is launched. Setting this to "menu-force" disables the timeout while always showing the menu.

As you can see, I set

 timeout menu-hidden 

and it doesn't work properly. Nor does

 timeout 0 

seem to work and immediately boot like the manual says it should.
So, I'm kinda stumped on what to do.

Last edited by ignis.flamme (2022-09-22 14:25:41)

Offline

#2 2022-09-22 07:58:07

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,032

Re: [SOLVED] systemd-boot not booting to default despite being told to

Why are you stumped? Just use 0? FWIW as for the actual issue, how up to date is your actual systemd-boot payload on the ESP? What's your output of

bootctl status

I'm assuming passing a string to that option is a newer development.

Offline

#3 2022-09-22 08:43:39

ignis.flamme
Member
Registered: 2021-07-12
Posts: 3

Re: [SOLVED] systemd-boot not booting to default despite being told to

The options

menu-hidden

and

0

are equivalent. I have tried both options, and neither of them do what they should (they don't immediately skip the bootloader selection and use the default).

Output of bootctl status

System:
     Firmware: UEFI 2.60 (American Megatrends 5.13)
  Secure Boot: disabled (disabled)
 TPM2 Support: yes
 Boot into FW: supported

Current Boot Loader:
      Product: systemd-boot 251.4-1-arch
     Features: + Boot counting
               + Menu timeout control
               + One-shot menu timeout control
               + Default entry control
               + One-shot entry control
               + Support for XBOOTLDR partition
               + Support for passing random seed to OS
               + Load drop-in drivers
               + Boot loader sets ESP information
          ESP: /dev/disk/by-partuuid/cdbec894-6c6f-4898-9d57-58ad7cd00b31
         File: `-/EFI/SYSTEMD/SYSTEMD-BOOTX64.EFI

Random Seed:
 Passed to OS: yes
 System Token: set
       Exists: yes

Available Boot Loaders on ESP:
          ESP: /boot (/dev/disk/by-partuuid/cdbec894-6c6f-4898-9d57-58ad7cd00b31)
         File: `-/EFI/systemd/systemd-bootx64.efi (systemd-boot 251.4-1-arch)
         File: `-/EFI/BOOT/BOOTX64.EFI (systemd-boot 251.4-1-arch)

Boot Loaders Listed in EFI Variables:
        Title: Linux Boot Manager
           ID: 0x0001
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/cdbec894-6c6f-4898-9d57-58ad7cd00b31
         File: `-/EFI/SYSTEMD/SYSTEMD-BOOTX64.EFI

        Title: UEFI OS
           ID: 0x0005
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/cdbec894-6c6f-4898-9d57-58ad7cd00b31
         File: `-/EFI/BOOT/BOOTX64.EFI

        Title: Windows Boot Manager
           ID: 0x0006
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/cdbec894-6c6f-4898-9d57-58ad7cd00b31
         File: `-/EFI/MICROSOFT/BOOT/BOOTMGFW.EFI

        Title: Windows Boot Manager
           ID: 0x0004
       Status: inactive, boot-order
    Partition: /dev/disk/by-partuuid/105e39ab-541c-11eb-ad76-914d98896433
         File: `-/EFI/MICROSOFT/BOOT/BOOTMGFW.EFI

Boot Loader Entries:
        $BOOT: /boot (/dev/disk/by-partuuid/cdbec894-6c6f-4898-9d57-58ad7cd00b31)

Default Boot Loader Entry:
         type: Boot Loader Specification Type #1 (.conf)
        title: Arch Linux LTS
           id: arch-lts.conf
       source: /boot/loader/entries/arch-lts.conf
        linux: /vmlinuz-linux-lts
       initrd: /intel-ucode.img
               /initramfs-linux-lts.img
      options: fbcon=nodefer msr.allow_writes=on mitigations=off rootflags=subvol=@ resume=PARTLABEL=swap root=PARTLABEL=root

Last edited by ignis.flamme (2022-09-22 08:44:37)

Offline

#4 2022-09-22 09:15:55

Raynman
Member
Registered: 2011-10-22
Posts: 1,443

Re: [SOLVED] systemd-boot not booting to default despite being told to

EFI variables? Check the "Tip" block in https://wiki.archlinux.org/title/System … figuration

Offline

#5 2022-09-22 09:21:27

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,032

Re: [SOLVED] systemd-boot not booting to default despite being told to

Ah, I've read that as 0 worked and the hidden-menu option didn't, but you did use nor. What is the behaviour? Do you see the menu anyway? A lot of these things might be configured in EFI variables which will take precedence over the loader.conf however the bootctl command should list that if that was the case afaik. What do you get from

efivar --list | grep -i Timeout

? If that lists a Timeout entry you'll either need to change the timeout in the menu directly with t or I suppose

bootctl set-timeout 0

would work as well.

Edit: Ah shit, didn't know this would be mentioned that plainly in the article.

Last edited by V1del (2022-09-22 09:22:27)

Offline

#6 2022-09-22 14:23:50

ignis.flamme
Member
Registered: 2021-07-12
Posts: 3

Re: [SOLVED] systemd-boot not booting to default despite being told to

Thanks Raynman and V1del, both your solutions worked for me.
I used

bootctl set-timeout 0

and its working properly now.
Strange, in my previous arch install, adjusting the timeout to 0 in the loader.conf would work flawlessly.

Offline

#7 2022-09-22 14:35:04

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,032

Re: [SOLVED] systemd-boot not booting to default despite being told to

As mentioned if the EFI variables are actually present then they take precedence over the loader.conf. So if you used set-timeout with an empty string to clear the variables, you should once again see loader.conf take an effect.

Offline

Board footer

Powered by FluxBB