You are not logged in.

#1 2022-09-23 10:06:32

fakemishraji
Member
Registered: 2022-07-14
Posts: 8

[Solved] Difficulty installing Steam

I have installed it easily in the past on the same system. But for some reason, this is not working out now.

sri@ArchLinux ~]$ sudo pacman -S steam
[sudo] password for sri:
resolving dependencies...
warning: cannot resolve "expat=2.4.9", a dependency of "lib32-expat"
warning: cannot resolve "lib32-expat", a dependency of "lib32-wayland"
warning: cannot resolve "lib32-wayland", a dependency of "lib32-mesa"
warning: cannot resolve "lib32-mesa", a dependency of "lib32-libglvnd"
:: There are 3 providers available for lib32-opengl-driver:
:: Repository multilib
   1) lib32-mesa  2) lib32-mesa-amber  3) lib32-nvidia-utils

Enter a number (default=1):
warning: cannot resolve "expat=2.4.9", a dependency of "lib32-expat"
warning: cannot resolve "lib32-expat", a dependency of "lib32-wayland"
warning: cannot resolve "lib32-wayland", a dependency of "lib32-mesa"
warning: cannot resolve "lib32-opengl-driver", a dependency of "lib32-libglvnd"
warning: cannot resolve "lib32-libgl", a dependency of "steam"
:: There are 4 providers available for lib32-vulkan-driver:
:: Repository multilib
   1) lib32-amdvlk  2) lib32-nvidia-utils  3) lib32-vulkan-intel  4) lib32-vulkan-radeon

Enter a number (default=1):
:: The following package cannot be upgraded due to unresolvable dependencies:
      steam

:: Do you want to skip the above package for this upgrade? [y/N] y
looking for conflicting packages...
there is nothing to do

Last edited by fakemishraji (2022-09-23 10:18:20)

Offline

#2 2022-09-23 10:10:44

stanczew
Member
Registered: 2021-03-02
Posts: 41

Re: [Solved] Difficulty installing Steam

expat 2.4.9 is in Testing. You probably enabled Multilib-Testing without enabling other Testing repositories.
Either enable all Testing repos, or disable Multilib-Testing. In both cases update your system with pacman -Syuu to update all packages to their correct testing or normal versions.

Last edited by stanczew (2022-09-23 10:12:51)

Offline

#3 2022-09-23 10:11:14

kermit63
Member
Registered: 2018-07-04
Posts: 111

Re: [Solved] Difficulty installing Steam

do you have the multilib repository enabled?

Offline

#4 2022-09-23 10:16:02

fakemishraji
Member
Registered: 2022-07-14
Posts: 8

Re: [Solved] Difficulty installing Steam

kermit63 wrote:

do you have the multilib repository enabled?

Yes, but as I found out it was the testing branch smile Thank you for the prompt response

Offline

#5 2022-09-23 10:16:40

fakemishraji
Member
Registered: 2022-07-14
Posts: 8

Re: [Solved] Difficulty installing Steam

stanczew wrote:

expat 2.4.9 is in Testing. You probably enabled Multilib-Testing without enabling other Testing repositories.
Either enable all Testing repos, or disable Multilib-Testing. In both cases update your system with pacman -Syuu to update all packages to their correct testing or normal versions.

Outstanding diagnosis smile Yes, it turns out that I had enabled the testing branch. All sorted now smile

Offline

Board footer

Powered by FluxBB