You are not logged in.

#1 2022-10-12 06:06:15

anarionzuo
Member
Registered: 2022-10-12
Posts: 1

Cannot install anything AUR with bsdtar broken

Hi. I could not install anything from AUR with yay because bsdtar always reports:

```
bsdtar: Option --no-read-sparse is not supported
Usage:
  List:    bsdtar -tf <archive-filename>
  Extract: bsdtar -xf <archive-filename>
  Create:  bsdtar -cf <archive-filename> [filenames...]
  Help:    bsdtar --help
```

Perhaps it is because of the new version of libarchive:

```
> yay -Q libarchive
libarchive 3.6.1-2
```

Any ideas?

Offline

#2 2022-10-12 06:35:50

seth
Member
Registered: 2012-09-03
Posts: 34,954

Re: Cannot install anything AUR with bsdtar broken

Perhaps it is because of the new version of libarchive:

No. The option is used illegally.
https://man.archlinux.org/man/core/liba … ead-sparse

1. BBS predates markdown, https://bbs.archlinux.org/help.php#bbcode
2.

Jason wrote:

pacman is you package manager

3. Which AUR package specifically (not "all I tried", name a specific one)

Offline

#3 2022-10-12 09:15:40

cphyc
Member
Registered: 2015-01-06
Posts: 19

Re: Cannot install anything AUR with bsdtar broken

It appears I have the same issue as the OP. All the packages I tried building using makepkg fail with the same error message:

# Example building cura-bin
$ makepkg -f
==> Making package: cura-bin 5.1.1-1 (Wed 12 Oct 2022 11:09:31 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found Ultimaker-Cura-5.1.1-linux-modern.AppImage
  -> Found cura.desktop
  -> Found cura.png
==> Validating source files with sha512sums...
    Ultimaker-Cura-5.1.1-linux-modern.AppImage ... Passed
    cura.desktop ... Passed
    cura.png ... Passed
==> Extracting sources...
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "cura-bin"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
bsdtar: Option --no-read-sparse is not supported
Usage:
  List:    bsdtar -tf <archive-filename>
  Extract: bsdtar -xf <archive-filename>
  Create:  bsdtar -cf <archive-filename> [filenames...]
  Help:    bsdtar --help
==> ERROR: Failed to create package file
Things I tried

I get the same error message at the same step when trying to install the otf-stix AUR package instead, or any other I tried.

I am using the manjaro version of /etc/makepkg.conf. I can also confirm that the manual of bsdtar does not mention the option --no-read-sparse.

I tried building with

PKGEXT=".pkg.tar" makepkg

but got the same issue.

Downgrading libarchive to 3.6.1-1 or to 3.5.3-2 didn't help. Downgrading tar to 1.33 didn't help either.

System info

I have the same version of libarchive as the OP:

$ yay -Q libarchive
libarchive 3.6.1-2
$ yay -Q tar
tar 1.34-1

Last edited by cphyc (2022-10-12 09:25:12)

Offline

#4 2022-10-12 09:29:44

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 18,187

Re: Cannot install anything AUR with bsdtar broken

are both of you using Manjaro and did Manjaro do a Manjaro and break something standard again?

Offline

#5 2022-10-12 09:31:44

cphyc
Member
Registered: 2015-01-06
Posts: 19

Re: Cannot install anything AUR with bsdtar broken

I am using Manjaro indeed, and after digging a bit more it seems manjaro doesn't ship with the same version of pacman as arch (6.0.2-2 for arch, 6.0.2-1 for Manjaro).

Offline

#6 2022-10-12 09:32:31

seth
Member
Registered: 2012-09-03
Posts: 34,954

Re: Cannot install anything AUR with bsdtar broken

I am using the manjaro version of /etc/makepkg.conf. I can also confirm that the manual of bsdtar does not mention the option --no-read-sparse.

type tar
type bsdtar
pacman -Qi tar libarchive
pacman -Qo bsdtar
man bsdtar | grep sparse

Edit: yeah, quelle surprise…

Last edited by seth (2022-10-12 09:33:09)

Offline

#7 2022-10-12 09:36:22

cphyc
Member
Registered: 2015-01-06
Posts: 19

Re: Cannot install anything AUR with bsdtar broken

Thanks seth, your prompt actually led me to the solution: I was working in a virtual environment that was shadowing my version of bsdtar. The solution is then simply to get out of the environment.
For reference, here is the output of the five commands above

$ type bsdtar
$ pacman -Qi tar libarchive
$ pacman -Qo bsdtar
$ man bsdtar | grep sparse
tar is /usr/bin/tar
bsdtar is /home/cphyc/miniconda3/bin/bsdtar
Name            : tar
Version         : 1.34-1
Description     : Utility used to store, backup, and transport files
Architecture    : x86_64
URL             : https://www.gnu.org/software/tar/
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : glibc  acl  attr
Optional Deps   : None
Required By     : base  lib32-libltdl  libtool
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 2.88 MiB
Packager        : Sébastien Luttringer <seblu@seblu.net>
Build Date      : Sat 13 Feb 2021 14:17:10 CET
Install Date    : Wed 12 Oct 2022 11:24:44 CEST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Name            : libarchive
Version         : 3.6.1-2
Description     : Multi-format archive and compression library
Architecture    : x86_64
URL             : https://libarchive.org/
Licenses        : BSD
Groups          : None
Provides        : libarchive.so=13-64
Depends On      : acl  libacl.so=1-64  bzip2  expat  lz4  openssl  xz  zlib  zstd
Optional Deps   : None
Required By     : cmake  debuginfod  evince  file-roller  flatpak  fwupd  gnome-autoar
                  gnome-boxes  gvfs  libgxps  mkinitcpio  mpv  ostree  pacman  pkgfile  smbclient
                  tesseract  totem-pl-parser  vlc
Optional For    : vtk
Conflicts With  : None
Replaces        : None
Installed Size  : 1129.74 KiB
Packager        : Christian Hesse <eworm@archlinux.org>
Build Date      : Mon 01 Aug 2022 23:34:30 CEST
Install Date    : Wed 12 Oct 2022 11:22:46 CEST
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

error: No package owns /home/cphyc/miniconda3/bin/bsdtar
     -S      (x mode only) Extract files as sparse files.  For every block on disk, check first
             the conv=sparse option of dd.

Offline

#8 2022-10-12 09:37:08

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 18,187

Re: Cannot install anything AUR with bsdtar broken

This hopefully illustrates unmistakenly to everyone why our rules are the way they are: https://bbs.archlinux.org/misc.php?action=rules

Closing.

Reopening on the chance the OP is actually using Arch but has their binary similarly shadowed.

Last edited by V1del (2022-10-12 09:40:55)

Offline

#9 2022-10-12 12:16:01

a82singh
Member
Registered: 2022-10-12
Posts: 2

Re: Cannot install anything AUR with bsdtar broken

Even i am facing this issue for all the packages i am trying to install using makepkg. Any help how to resolve this will be appreciated.

  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
bsdtar: Option --no-read-sparse is not supported
Usage:
  List:    bsdtar -tf <archive-filename>
  Extract: bsdtar -xf <archive-filename>
  Create:  bsdtar -cf <archive-filename> [filenames...]
  Help:    bsdtar --help

Offline

#10 2022-10-12 12:17:31

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 18,187

Re: Cannot install anything AUR with bsdtar broken

Read/post the outputs of commands in post #6 and the mentioned resolution in comment #7

Generally do not run system manipulating operations in a conda virtual environment, explicitly exit out of them, fix your shell init scripts to not unconditionally enter you inta a conda/virtual environment that might shadow system binaries.

Last edited by V1del (2022-10-12 12:20:25)

Offline

#11 2022-10-12 12:20:40

Scimmia
Fellow
Registered: 2012-09-01
Posts: 10,014

Re: Cannot install anything AUR with bsdtar broken

With what version of pacman?

Offline

#12 2022-10-13 01:25:56

astrea_apn
Member
Registered: 2022-10-13
Posts: 2

Re: Cannot install anything AUR with bsdtar broken

the problem is due to anaconda base environment. In my case...
i made this.
1-. $conda deactivate
2-. $yay -Syu
3-. $source [PATH TO CONDA]/bin/activate (in my case, source $HOME/anaconda3/bin/activate)
4-. $conda init

Offline

#13 2022-10-13 02:54:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 18,187

Re: Cannot install anything AUR with bsdtar broken

Don't make conda the base environment of your entire shell that's guaranteed to run you into weird issues with more than just this case here. Run conda explicitly in a terminal you dedicate to "conda" stuff, when you are actually doing conda stuff.

Offline

#14 2022-10-13 06:15:10

a82singh
Member
Registered: 2022-10-12
Posts: 2

Re: Cannot install anything AUR with bsdtar broken

I deactivated conda base and it works now.

Offline

Board footer

Powered by FluxBB