You are not logged in.

#1 2022-11-07 03:09:12

Hacksign
Member
Registered: 2012-07-30
Posts: 98

[SOLVED][wpa_supplicant bug]openssl3 upgrade breaks wpa_suplicant auth

Full upgrade (I dont think this is a partial upgrade problem), upgrade by command `yay -Syyu`.
The wpa_supplicant can not establish PEAP authentication connection, error log:

11月 07 10:25:56 XSignLaptop wpa_supplicant[472]: enp0s31f6: CTRL-EVENT-EAP-PEER-ALT depth=0 DNS:xxxxxx
11月 07 10:25:56 XSignLaptop wpa_supplicant[472]: SSL: SSL3 alert: write (local SSL3 detected an error):fatal:internal error
11月 07 10:25:56 XSignLaptop wpa_supplicant[472]: OpenSSL: openssl_handshake - SSL_connect error:0A0C0103:SSL routines::internal error
11月 07 10:25:56 XSignLaptop wpa_supplicant[472]: enp0s31f6: CTRL-EVENT-EAP-FAILURE EAP authentication failed
11月 07 10:26:19 XSignLaptop wpa_supplicant[472]: enp0s31f6: CTRL-EVENT-DISCONNECTED bssid=xxxxxx reason=3 locally_generated=1
11月 07 10:26:19 XSignLaptop wpa_supplicant[472]: enp0s31f6: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="" auth_failures=1 duration=10 reason=AUTH_FAILED

And I can not establish a connection by ipsec VPN. It seems all things with tls handshake will not work properly.
Down grade: openssl-1.1.1 sudo systemd systemd-libs systemd-sysvcompact linux-5.0.6 wpa_supplicant strongswan to previous version solved the problem....

Last edited by Hacksign (2022-11-07 03:16:55)

Offline

#2 2022-11-07 03:10:20

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: [SOLVED][wpa_supplicant bug]openssl3 upgrade breaks wpa_suplicant auth

Online

#3 2022-11-07 15:50:39

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,899

Re: [SOLVED][wpa_supplicant bug]openssl3 upgrade breaks wpa_suplicant auth

Can you please explain why you use yy in your pacman switches?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#4 2022-11-09 01:52:37

Hacksign
Member
Registered: 2012-07-30
Posts: 98

Re: [SOLVED][wpa_supplicant bug]openssl3 upgrade breaks wpa_suplicant auth

ewaller wrote:

Can you please explain why you use yy in your pacman switches?

I've synced once that day, so I just need a force sync in case there is something updated while I report this problem ~

Offline

#5 2022-11-09 02:14:14

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,577
Website

Re: [SOLVED][wpa_supplicant bug]openssl3 upgrade breaks wpa_suplicant auth

No, you do not need a forced sync for that as that's precisely what a normal sync is for.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#6 2022-11-09 03:16:33

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,899

Re: [SOLVED][wpa_supplicant bug]openssl3 upgrade breaks wpa_suplicant auth

As Trilby points out, that is what a normal sync is for.  The yy option says to ignore what is already downloaded, and download it all again.  It is generally a waste of your time and our resources.  A single y will grab anything that has changed since the last time you used y, even if it was moments ago.  The only reason for yy is if there is a possibility that things are corrupted.

Someone, someplace recommended yy, and it has been an exercise in cargo cult maintenance ever since.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB