You are not logged in.

#1 2022-11-12 07:08:01

Zodigram
Member
Registered: 2022-05-16
Posts: 15

SOLVED: Systemd-boot not loading on new install on Macbook Air (2017)

I've been using systemd-boot for a while, but decided to reinstall arch recently on my 2017 Macbook Air. However, I can't seem to get it to work at all. On my previous install, there would be a weird loading circle in the middle of the screen but an otherwise fully functional set of systemd-boot entries underneath it, but now I just get the circle which freezes at some point, with no systemd-boot menu on screen at all.

I'm really at a loss. I have my esp mounted to /boot, I ran bootctl install, I created the same exact entries I was using before with the exception of updated UUIDs, and i have initramfs-linux.img, initramfs-linux-fallback.img, intel-ucode.img, and vmlinuz-linux all in /boot. I'm not sure if this is a problem with systemd-boot, my Mac's UEFI implementation being nonstandard, or something I've overlooked myself.

Last edited by Zodigram (2022-11-22 05:47:06)

Offline

#2 2022-11-13 18:33:19

defragmenteur
Member
Registered: 2022-04-23
Posts: 4

Re: SOLVED: Systemd-boot not loading on new install on Macbook Air (2017)

I have the same problem on my mac since systemd was upgrade to 252.1-1.

systemd-boot 252 fails to boot on MacBookAir4,2/Mac

Offline

#3 2022-11-13 22:13:03

Zodigram
Member
Registered: 2022-05-16
Posts: 15

Re: SOLVED: Systemd-boot not loading on new install on Macbook Air (2017)

Thanks for letting me know I'm not alone, so at least I know the source of the error isn't me. I'll be keeping an eye on that GitHub issue.

Should I mark this as solved?

Offline

Board footer

Powered by FluxBB