You are not logged in.

#1 2022-11-22 13:59:55

Registered: 2022-08-15
Posts: 6

Wayland: Chromium/electron app image don't refresh on workspace change


I've migrated to Wayland quite recently. I run Gnome with an Nvidia rtx3070 and closed-source drivers. I've had a few issues and solved most of them except this one that I've especially noticed in the past 2 weeks.

I run a few applications based on electron (+chromium) and noticed this issue with most of them but it's especially annoying with Discord because I assume wrongly that I did not receive any message.

The symptoms: So let's say that I work on a workspace and move back to the workspace where the electron application is displayed, the image is always exactly as it was when I left the workspace previously. If I move my mouse, the hover animation can get some things refreshed and I get a patchwork of the old and new states. If I resize the window it gets completely refreshed.

Any idea what's going on? How I could fix this?

Edit: extra precisions: I start the applications in wayland mode.

Last edited by o1ivier (2022-11-22 15:35:51)


Board footer

Powered by FluxBB