You are not logged in.

#1 2022-11-22 14:24:25

Cerbkraft
Member
From: United Kingom
Registered: 2022-11-22
Posts: 8

[SOLVED] MEDIATEK onboard Wifi no longer detected

Hello everyone, I have been having issues with MEDIATEK built in WIFI if anyone could help me figure out what on earth I have done I would be grateful.

PC specs:

AMD Ryzen 5600x
ASUS TUF X570-gaming pro Wifi II
AMD Radeon RX 6650 XT

The other day I decided to give my PC a dusting as it was due for a clean, I unplugged my computer completely and started cleaning and just having a general organize inside the case.

I then put it back together and powered up to find that my Wifi was no longer being detected, I checked the antenna that connects to the back of the motherboard and that was fine and still nothing. (The Ethernet still works luckily as a fallback but the Wifi was very convenient to have and was working the day before perfectly fine before i cleaned the inside of the PC)

Hunting around online for any kind of starting point for trouble shooting because I had no clue what to do to fix this.

(Side note the MEDIATEK bluetooth controller works fine)

$ lspci -nnk | grep -iA3 net
08:00.0 Network controller [0280]: MEDIATEK Corp. MT7921K (RZ608) Wi-Fi 6E 80MHz [14c3:0608]
 Subsystem: MEDIATEK Corp. MT7921K (RZ608) Wi-Fi 6E 80MHz [14c3:0608]
 Kernel modules: mt7921e
09:00.0 Ethernet controller [0200]: Intel Corporation Ethernet Controller I225-V [8086:15f3] (rev 03)
 Subsystem: ASUSTeK Computer Inc. Device [1043:87d2]
 Kernel driver in use: igc
 Kernel modules: igc
$ lsmod | grep mt
btmtk                  16384  1 btusb
mt7921e                32768  0
bluetooth             942080  44 btrtl,btmtk,btintel,btbcm,bnep,btusb,rfcomm
mt7921_common          94208  1 mt7921e
mt76_connac_lib        69632  2 mt7921e,mt7921_common
mt76                  102400  3 mt7921e,mt7921_common,mt76_connac_lib
mac80211             1298432  3 mt76,mt7921_common,mt76_connac_lib
cfg80211             1118208  4 mt76,mac80211,mt7921_common,mt76_connac_lib
$ sudo dmesg | grep mt
[    0.001054] Found optimal setting for mtrr clean up
[    3.283744] mt7921e: probe of 0000:08:00.0 failed with error -22

Now I am genuinely lost about what the heck has gone wrong with this as it worked fine until I powered everything down and unplugged to clean. NGL it has frustrated me to no end.

I have also tried the modprobe and the rmod commands and rebooted, but no joy.

If anyone can help me I would much appreciate it smile If I have missed any relevant information that is needed please let me know and I will try to update as best as I can for you smile

Last edited by Cerbkraft (2022-12-01 12:33:07)

Offline

#2 2022-11-22 15:02:20

seth
Member
Registered: 2012-09-03
Posts: 35,092

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

The chip is there, but the probe fails w/ EINVAL
Post the complete system journal (sudo journalctl -b) and if there's a parallel windows installation, see the 3rd link below.

Offline

#3 2022-11-22 15:09:49

Cerbkraft
Member
From: United Kingom
Registered: 2022-11-22
Posts: 8

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

seth wrote:

The chip is there, but the probe fails w/ EINVAL
Post the complete system journal (sudo journalctl -b) and if there's a parallel windows installation, see the 3rd link below.

Sorry I forgot to mention that I am not dual booting and fast boot is not enabled on this machine

Offline

#4 2022-11-22 15:28:35

Cerbkraft
Member
From: United Kingom
Registered: 2022-11-22
Posts: 8

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

https://pastebin.com/V6JPj7hX

this is the complete Journalctl -b log for you hopefully this is ok it is quite a big one xD

Offline

#5 2022-11-22 15:44:06

seth
Member
Registered: 2012-09-03
Posts: 35,092

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

This is all references of the device

Nov 22 13:21:39 archlinux kernel: acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI EDR HPX-Type3]
Nov 22 13:21:39 archlinux kernel: acpi PNP0A08:00: _OSC: platform does not support [PCIeHotplug SHPCHotplug PME LTR DPC]
Nov 22 13:21:39 archlinux kernel: acpi PNP0A08:00: _OSC: OS now controls [AER PCIeCapability]
Nov 22 13:21:39 archlinux kernel: acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-7f] only partially covers this bridge
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: [14c3:0608] type 00 class 0x028000
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: reg 0x10: [mem 0x7fffe00000-0x7fffefffff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: reg 0x18: [mem 0x7ffff00000-0x7ffff03fff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: reg 0x20: [mem 0x7ffff04000-0x7ffff04fff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: enabling Extended Tags
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: supports D1 D2
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: PME# supported from D0 D1 D2 D3hot D3cold

And here's the problem:

Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: can't claim BAR 0 [mem 0x7fffe00000-0x7fffefffff 64bit pref]: no compatible bridge window
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: can't claim BAR 2 [mem 0x7ffff00000-0x7ffff03fff 64bit pref]: no compatible bridge window
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: can't claim BAR 4 [mem 0x7ffff04000-0x7ffff04fff 64bit pref]: no compatible bridge window
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 0: no space for [mem size 0x00100000 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 0: failed to assign [mem 0x7fffe00000-0x7fffefffff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 2: no space for [mem size 0x00004000 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 2: failed to assign [mem 0x7ffff00000-0x7ffff03fff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 4: no space for [mem size 0x00001000 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 4: failed to assign [mem 0x7ffff04000-0x7ffff04fff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: Adding to iommu group 27
Nov 22 13:21:41 archlinux kernel: mt7921e: probe of 0000:08:00.0 failed with error -22

Try adding "pci=nocrs" to the kernel parameters and also the LTS kernel.

Then there's

Nov 22 13:21:39 archlinux kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
Nov 22 13:21:39 archlinux kernel: ccp 0000:0e:00.1: ccp: unable to access the device: you might be running a broken BIOS.

Try to convince the HW that you're running windows: https://bbs.archlinux.org/viewtopic.php … 5#p2066945

Offline

#6 2022-11-22 15:53:17

Cerbkraft
Member
From: United Kingom
Registered: 2022-11-22
Posts: 8

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

seth wrote:

This is all references of the device

Nov 22 13:21:39 archlinux kernel: acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI EDR HPX-Type3]
Nov 22 13:21:39 archlinux kernel: acpi PNP0A08:00: _OSC: platform does not support [PCIeHotplug SHPCHotplug PME LTR DPC]
Nov 22 13:21:39 archlinux kernel: acpi PNP0A08:00: _OSC: OS now controls [AER PCIeCapability]
Nov 22 13:21:39 archlinux kernel: acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-7f] only partially covers this bridge
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: [14c3:0608] type 00 class 0x028000
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: reg 0x10: [mem 0x7fffe00000-0x7fffefffff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: reg 0x18: [mem 0x7ffff00000-0x7ffff03fff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: reg 0x20: [mem 0x7ffff04000-0x7ffff04fff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: enabling Extended Tags
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: supports D1 D2
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: PME# supported from D0 D1 D2 D3hot D3cold

And here's the problem:

Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: can't claim BAR 0 [mem 0x7fffe00000-0x7fffefffff 64bit pref]: no compatible bridge window
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: can't claim BAR 2 [mem 0x7ffff00000-0x7ffff03fff 64bit pref]: no compatible bridge window
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: can't claim BAR 4 [mem 0x7ffff04000-0x7ffff04fff 64bit pref]: no compatible bridge window
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 0: no space for [mem size 0x00100000 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 0: failed to assign [mem 0x7fffe00000-0x7fffefffff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 2: no space for [mem size 0x00004000 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 2: failed to assign [mem 0x7ffff00000-0x7ffff03fff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 4: no space for [mem size 0x00001000 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: BAR 4: failed to assign [mem 0x7ffff04000-0x7ffff04fff 64bit pref]
Nov 22 13:21:39 archlinux kernel: pci 0000:08:00.0: Adding to iommu group 27
Nov 22 13:21:41 archlinux kernel: mt7921e: probe of 0000:08:00.0 failed with error -22

Try adding "pci=nocrs" to the kernel parameters and also the LTS kernel.

Then there's

Nov 22 13:21:39 archlinux kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
Nov 22 13:21:39 archlinux kernel: ccp 0000:0e:00.1: ccp: unable to access the device: you might be running a broken BIOS.

Try to convince the HW that you're running windows: https://bbs.archlinux.org/viewtopic.php … 5#p2066945

Hang on I am very new to this and this is genuinely terrifying me xD

And please forgive my naivety but I genuinely don't know what any of this means. If you could put it into layman's terms for an idiot like me xD I am more scared of touching something I have know knowledge in and breaking it xD

Last edited by Cerbkraft (2022-11-22 15:54:14)

Offline

#7 2022-11-22 15:59:02

d.ALT
Member
Registered: 2019-05-10
Posts: 543

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

<EDIT>
But still... I still can't figure it out how seth managed to know what's the solution tongue
</EDIT>

nocrs           [X86] Ignore PCI host bridge windows from ACPI.
                                If you need to use this, please report a bug.

(https://www.kernel.org/doc/html/v4.14/a … eters.html)

And here you're faking your hardware to let false beliefs to the devices.

Last edited by d.ALT (2022-11-22 16:02:21)


<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.

Offline

#8 2022-11-22 16:10:19

seth
Member
Registered: 2012-09-03
Posts: 35,092

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

The kernel actually suggests that - and we don't know whether nocrs helps in his case.
acpi_osi is more "cheating" the HW than "faking" it.

this is genuinely terrifying me

There's nothing to be terrified about.
The sugegsted changes are all trnasient and if you've specific question on how to proceed: ask.

Offline

#9 2022-11-22 16:24:44

Cerbkraft
Member
From: United Kingom
Registered: 2022-11-22
Posts: 8

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

seth wrote:

The kernel actually suggests that - and we don't know whether nocrs helps in his case.
acpi_osi is more "cheating" the HW than "faking" it.

this is genuinely terrifying me

There's nothing to be terrified about.
The sugegsted changes are all trnasient and if you've specific question on how to proceed: ask.

How do I get to/edit the kernel parameters  to add "pci=nocrs"?

this is is all new grounds for me, so I want to be sure before I start and make mistakes.

Offline

#10 2022-11-22 16:25:53

d.ALT
Member
Registered: 2019-05-10
Posts: 543

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

seth wrote:

The kernel actually suggests that - and we don't know whether nocrs helps in his case.

yeah seth, but you're poiting into a (maybe right) direction, at least! wink Me, personally, I'm still missing the "glue" to relate that error to its (possible) solution...

Although I understand the meaning of that nocrs, I could not immediately associate it with the problem!


<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.

Offline

#11 2022-11-22 16:28:25

seth
Member
Registered: 2012-09-03
Posts: 35,092

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

https://wiki.archlinux.org/title/Kernel_parameters
Ideally, use the interactive commandline editor of your bootloader (any change there will be gone w/ a reboot)

Offline

#12 2022-11-22 16:39:09

Cerbkraft
Member
From: United Kingom
Registered: 2022-11-22
Posts: 8

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

I shall give this a try and let you know of the outcome when I have completed it smile thank you for your information and help and if I do get stuck I shall ask smile

Offline

#13 2022-11-22 16:51:36

d.ALT
Member
Registered: 2019-05-10
Posts: 543

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

Cerbkraft wrote:

I shall give this a try and let you know of the outcome when I have completed it smile thank you for your information and help and if I do get stuck I shall ask smile

To be sure the parameter will be actually active, after you'll boot into system, check this:

# cat /proc/cmdline | grep nocrs

or, alternatively

# dmesg | grep nocrs

<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.

Offline

#14 2022-11-22 17:47:31

seth
Member
Registered: 2012-09-03
Posts: 35,092

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

d.ALT wrote:
# cat /proc/cmdline | grep nocrs

Ahemm: https://porkmail.org/era/unix/award#cat

Also

grep --color=auto nocrs /proc/cmdline

will highlight the match.

Offline

#15 2022-12-01 12:31:12

Cerbkraft
Member
From: United Kingom
Registered: 2022-11-22
Posts: 8

Re: [SOLVED] MEDIATEK onboard Wifi no longer detected

Sorry about delayed response to this post just an update, I tried what you suggested but this froze my boot up and left me stuck, (I can only assume I had done something incorrect), however I appreciate all the help you have given me and the pointers, but apparently it is now fixed and I haven't touch anything at all so something has been updated and fixed down the line. So the mystery of the missing Wifi shall remain but will mark the post as solved smile

Offline

Board footer

Powered by FluxBB