You are not logged in.

#1 2022-11-22 15:21:38

vf
Member
Registered: 2020-04-07
Posts: 69

[RESOLVED] Mounting '/dev/disk/by-label' to '/run/archiso/bootmnt'

`ERROR: '/dev/disk/by-label' device did not show up after 30 seconds...`

I guess that arch doesn't need to mount that to boot. It seems to be something that lasted from the ISO installation. How to get rid of that "hook", for the OS to boot successfully?

Last edited by vf (2022-11-24 09:55:06)

Offline

#2 2022-11-23 00:31:29

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,840

Re: [RESOLVED] Mounting '/dev/disk/by-label' to '/run/archiso/bootmnt'

It sounds as if you haven't specified some partition correctly. Which boot loader are you using and how is it configured? What is in fstab?

Last edited by cfr (2022-11-23 00:31:46)


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#3 2022-11-23 10:31:13

nl6720
The Evil Wiki Admin
Registered: 2016-07-02
Posts: 402

Re: [RESOLVED] Mounting '/dev/disk/by-label' to '/run/archiso/bootmnt'

vf wrote:
Mounting '/dev/disk/by-label' to '/run/archiso/bootmnt'

That line should come from the "archiso" mkinitcpio hook. Check your /etc/mkinitcpio.conf.

vf wrote:

It seems to be something that lasted from the ISO installation.

Nothing from the live environment should last in the installed system unless you installed the system using the unsupported method of extracting the root file system image (airootfs.sfs in the ISO).

Offline

#4 2022-11-24 09:46:49

vf
Member
Registered: 2020-04-07
Posts: 69

Re: [RESOLVED] Mounting '/dev/disk/by-label' to '/run/archiso/bootmnt'

I tried that and it booted right up

```sh
mv /usr/lib/initcpio/hooks/archiso /usr/lib/initcpio/oldHooks/
```

Feel free to ask questions if you want to know how I founded or if there is analogous case

`It sounds as if you haven't specified some partition correctly.`

I did it manually on `/etc/fstab`, and after applying an idea, it worked as is

`Which boot loader are you using and how is it configured?`

EFISTUB if I'm not wrong. I mean I create an entry in the UEFI to boot to VmLinuz and I give him some arguments to start

`What is in fstab?`

```fstab
        UUID=$a /           ext4     rw              0       1
        UUID=$b /boot   vfat     rw              0       2
```

`Check your /etc/mkinitcpio.conf.`

I didn't quite understood this part. If I'm right, `pacstrap` create a good one (conf and hooks) from ISO instructions if there isn't one already. But if there is, it does not touch it (or just append to it) and create with that? Because I effectively had a hook from the ISO, but not the hook it is supposed to create for an installation, but the very hook that make the ISO work

`you installed the system using the *unsupported method* of extracting the root file system image (airootfs.sfs in the ISO).`

I didn't even bother extracting it (if I remember right), I just copied the root structure. It baffled me that an Arch ISO (quite heavy for a non graphical one) didn't have, like, the actual OS to install. That it needs internet to get it. I hadn't an internet access and needed to install it. I hoped that with the ISO I would be fine, because the iPXE doesn't have the necessary obviously. So I tried the only offline method that I had, because the ISO, despite being so huge, didn't had installation instructions offline. It's like a pudding of nothing weighting that much, no instructions, no OS, at the picture of actual society. Anyway I used the local resource to install the actual OS, removed the hook, and now it works fine. The system just seems a bit here and here not configured for a standalone, but I will find through the way. But I would like for the future very much an actual offline ISO of Arch. I know that it's a very connected OS by it's essential and bleeding-edge nature, but we have step in life where internet is not always available and Arch stills the OS of heart and all our workflow is configured on it or is even only available on it. And the arch-based doesn't always have whats needed and isn't supported by the Arch community (which is bigger than the other)

Thanks for the help anyway

Last edited by vf (2022-11-24 09:51:21)

Offline

#5 2022-11-24 10:50:33

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,636

Re: [RESOLVED] Mounting '/dev/disk/by-label' to '/run/archiso/bootmnt'


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

Board footer

Powered by FluxBB