You are not logged in.

#1 2022-11-23 12:22:18

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

[SOLVED]Error with makepkg

Hello again guys i'm having some errors while compiling packages from the aur with makepkg.
I installed the linux-lts kernel and need two modules for my broadcom wifi controller and nvidia driver. In particular i would like to install theese two:
https://aur.archlinux.org/packages/broadcom-wl-lts
https://aur.archlinux.org/packages/nvid … x-lts-dkms
I followed the general guide to manually install aur packages but when i run makepkg -si i got different errors. In particular, i got this from making broadcom-wl:

[1m[32m==>[m[1m Creazione del pacchetto: broadcom-wl-lts 6.30.223.271-2 (mer 23 nov 2022, 12:59:08)[m
[1m[32m==>[m[1m Controllo delle dipendenze durante l'avvio in corso...[m
[1m[32m==>[m[1m Controllo delle dipendenze durante la compilazione in corso...[m
[1m[32m==>[m[1m Download dei sorgenti in corso...[m
[1m[34m  ->[m[1m È stato trovato modprobe.d[m
[1m[34m  ->[m[1m È stato trovato license.patch[m
[1m[34m  ->[m[1m È stato trovato wl_linux.c.patch[m
[1m[34m  ->[m[1m È stato trovato hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz[m
[1m[32m==>[m[1m Validazione di source file con sha256sums...[m
[1m[32m==>[m[1m Validazione di source_x86_64 file con sha256sums...[m
[1m[32m==>[m[1m Estrazione dei sorgenti in corso...[m
[1m[34m  ->[m[1m Estrazione di hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz usando bsdtar in corso...[m
[1m[32m==>[m[1m Avvio di prepare() in corso...[m
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 207 (offset 2 lines).
patching file src/wl/sys/wl_linux.c
[1m[32m==>[m[1m Rimozione dell'esistente directory $pkgdir/ in corso...[m
[1m[32m==>[m[1m Avvio di build() in corso...[m
make: *** /usr/lib/modules//build: File o directory non esistente.  Arresto.
[1m[31m==> ERRORE:[m[1m Si è verificato un errore in build().[m
[1m    L'operazione sta per essere interrotta...[m

Unfortunately is in italian and it doesn't show messages properly but the problem is that it says me:

 /home/bob/broadcom-wl-lts/PKGBUILD: line 34: /usr/lib/modules/extramodules-5.15-lts/version: no such file or directory

Then it compile and in the end:

starting build()
make: *** /usr/lib/modules//build: no such file or directory, abortion.
ERROR: an error occoured in build()

I think that's fine for now, i'll post the error for the nvidia driver later (or if you think it's better to do it asap, i'll post them immediately)

Last edited by cervyesterday (2022-11-24 11:48:49)

Offline

#2 2022-11-23 13:44:19

d.ALT
Member
Registered: 2019-05-10
Posts: 327

Re: [SOLVED]Error with makepkg

cervyesterday wrote:

Unfortunately is in italian

$ LC_ALL=C blah

<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.

Offline

#3 2022-11-23 13:57:16

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,799

Re: [SOLVED]Error with makepkg

Read up on how DKMS works. You don't want broadcom-wl-lts when broadcom-wl-dkms is already in the repos. You don't want nvidia-340xx-lts-dkms when nvidia-340xx-dkms exists.

Offline

#4 2022-11-23 14:07:50

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

This is the output in English

[1m[32m==>[m[1m Making package: broadcom-wl-lts 6.30.223.271-2 (Wed Nov 23 15:05:46 2022)[m
[1m[32m==>[m[1m Checking runtime dependencies...[m
[1m[32m==>[m[1m Checking buildtime dependencies...[m
[1m[32m==>[m[1m Retrieving sources...[m
[1m[34m  ->[m[1m Found modprobe.d[m
[1m[34m  ->[m[1m Found license.patch[m
[1m[34m  ->[m[1m Found wl_linux.c.patch[m
[1m[34m  ->[m[1m Found hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz[m
[1m[32m==>[m[1m Validating source files with sha256sums...[m
[1m[32m==>[m[1m Validating source_x86_64 files with sha256sums...[m
[1m[32m==>[m[1m Extracting sources...[m
[1m[34m  ->[m[1m Extracting hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz with bsdtar[m
[1m[32m==>[m[1m Starting prepare()...[m
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 207 (offset 2 lines).
patching file src/wl/sys/wl_linux.c
[1m[32m==>[m[1m Removing existing $pkgdir/ directory...[m
[1m[32m==>[m[1m Starting build()...[m
make: *** /usr/lib/modules//build: No such file or directory.  Stop.
[1m[31m==> ERROR:[m[1m A failure occurred in build().[m
[1m    Aborting...[m

Offline

#5 2022-11-23 14:09:28

d.ALT
Member
Registered: 2019-05-10
Posts: 327

Re: [SOLVED]Error with makepkg

Please have a look at what Scimmia suggested you

Scimmia wrote:

Read up on how DKMS works. You don't want broadcom-wl-lts when broadcom-wl-dkms is already in the repos. You don't want nvidia-340xx-lts-dkms when nvidia-340xx-dkms exists.


<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.

Offline

#6 2022-11-23 14:11:36

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

Scimmia wrote:

Read up on how DKMS works. You don't want broadcom-wl-lts when broadcom-wl-dkms is already in the repos. You don't want nvidia-340xx-lts-dkms when nvidia-340xx-dkms exists.

But what do you mean with "is already in the repos"? It's a fresh arch install and i can't install broadcom-wl because i installed the lts kernel version. If i try to run

 pacman -S broadcom-wl-dkms 

it says that i need linux and not linux-lts

Offline

#7 2022-11-23 14:16:04

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,799

Re: [SOLVED]Error with makepkg

Oh? What distro are you on, then? In Arch, it doesn't require any specific kernel, as that's not how DKMS works.

Offline

#8 2022-11-23 14:22:40

d.ALT
Member
Registered: 2019-05-10
Posts: 327

Re: [SOLVED]Error with makepkg

cervyesterday wrote:
 pacman -S broadcom-wl-dkms 

it says that i need linux and not linux-lts

Click here and tell us what do you read under Dependencies.


<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.

Offline

#9 2022-11-23 14:26:14

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

Scimmia wrote:

Oh? What distro are you on, then? In Arch, it doesn't require any specific kernel, as that's not how DKMS works.

So i don't need to download the lts version, but just the dkms one?

Offline

#10 2022-11-23 14:27:34

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,799

Re: [SOLVED]Error with makepkg

Still haven't read up on DKMS, I see.

Offline

#11 2022-11-23 14:28:22

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

d.ALT wrote:
cervyesterday wrote:
 pacman -S broadcom-wl-dkms 

it says that i need linux and not linux-lts

Click here and tell us what do you read under Dependencies.

Just dkms

Offline

#12 2022-11-23 14:29:53

d.ALT
Member
Registered: 2019-05-10
Posts: 327

Re: [SOLVED]Error with makepkg

cervyesterday wrote:
d.ALT wrote:
cervyesterday wrote:
 pacman -S broadcom-wl-dkms 

it says that i need linux and not linux-lts

Click here and tell us what do you read under Dependencies.

Just dkms

cervyesterday wrote:
 pacman -S broadcom-wl-dkms 

it says that i need linux and not linux-lts

Last edited by d.ALT (2022-11-23 14:30:42)


<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.

Offline

#13 2022-11-23 14:30:29

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

I tried to run

 pacman -S broadcom-wl-dkms

But it says

ERROR: missing 6.0.9-arch1-1 kernel modules tree for module broadcom-wl/6.30.223.271

Offline

#14 2022-11-23 14:32:23

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

d.ALT wrote:
cervyesterday wrote:
d.ALT wrote:

Click here and tell us what do you read under Dependencies.

Just dkms

cervyesterday wrote:
 pacman -S broadcom-wl-dkms 

it says that i need linux and not linux-lts

You're right, i did it wrong because i tried to install broadcom-wl and not the dkms version hmm

Last edited by cervyesterday (2022-11-23 14:32:47)

Offline

#15 2022-11-23 14:32:37

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,799

Re: [SOLVED]Error with makepkg

That means you installed the headers for that kernel, but not the kernel itself.

Offline

#16 2022-11-23 14:33:21

d.ALT
Member
Registered: 2019-05-10
Posts: 327

Re: [SOLVED]Error with makepkg

cervyesterday wrote:
ERROR: missing 6.0.9-arch1-1 kernel modules tree for module broadcom-wl/6.30.223.271

Scimmia was inviting you to into making you think (and learn); read here:  https://wiki.archlinux.org/title/Dynami … le_Support


<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.

Offline

#17 2022-11-23 14:34:16

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

Scimmia wrote:

That means you installed the headers for that kernel, but not the kernel itself.

I followed the installation guide and simply replace linux with linux-lts, what did i forget?

Offline

#18 2022-11-23 14:51:44

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

Ok guys sorry, i found out i installed linux-headers for the non-lts kernel (idk how), so i removed it and now broadcom-wl-dkms is installed.
Now i'll try to install nvidia-340xx-dkms and see what happens

Offline

#19 2022-11-23 15:53:52

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

d.ALT wrote:
cervyesterday wrote:
ERROR: missing 6.0.9-arch1-1 kernel modules tree for module broadcom-wl/6.30.223.271

Scimmia was inviting you to into making you think (and learn); read here:  https://wiki.archlinux.org/title/Dynami … le_Support

Ok, i don't understand couple of things.
If i've installed the linux-lts kernel i can install dkms packages and not the lts version, can't i?
If so, why there are dkms packages and dkmes-lts packages?
Second, nvidia-340xx-dkms has linux (not linux-lts) as a dependency, so do i need to install nvidia-340xx-lts-dkms?
If i try to install it i get this error:

ERROR: Kernel configuration is invalid.
Inclue/generated/autoconf.h or include/config/auto.conf are missing
Run 'make oldconfig && make prepare' on kernel src to fix it
[...]
ERROR: a failure occoured in build() aborting...

Is it normal that the kernel configuration is invalid? I've simply installed the linux-lts kernel so idk why there's such an error
And how can i run those commands on kernel src to fix it? I mean, in wich folder do i have to run those commands?
I've installed linux-lts for more stability, do you think i'd better install non-lts kernel?

Excuse me for the lack of competence but I am installing arch on an old macbook, when I had installed it on a lenovo pc I didn't have all these problems hmm

Last edited by cervyesterday (2022-11-23 15:55:05)

Offline

#20 2022-11-23 17:52:01

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,515
Website

Re: [SOLVED]Error with makepkg

cervyesterday wrote:

If so, why there are dkms packages and dkmes-lts packages?

There aren't.  There's no such thing as a dkms-lts package - certainly not in the arch linux repos.*

cervyesterday wrote:

Second, nvidia-340xx-dkms has linux (not linux-lts) as a dependency

No, it doesn't.  Where are you getting this information?

* edit: I see there is a nvidia-340xx-lts-dkms package in the AUR.  I don't use nvidia, so I could be missing something, but that seems awefully fishy to me - but it is the AUR, anyone can put any nonsense there.

EDIT 2: now I'm confusing myself.  On the aur web interface, there are nvidia-340xx dkms packages that list specific kernels as dependencies, but somehow when I just git cloned the nvidia-340xx-dkms from the AUR I got a different PKGBUILD which does not list the kernel as a dependency.  I deleted it and cloned it again, and I'm still getting a completely different PKGBUILD than the one on the AUR web interface.  And they have completely different git log histories ... WTF?  EDIT: Ooops! the current package is a split package which shows on the AUR, but cloning the split package name gets a much older removed version of the package.

Last edited by Trilby (2022-11-23 18:09:25)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#21 2022-11-23 18:09:30

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,799

Re: [SOLVED]Error with makepkg

Trilby, check the pkgbase. These are poorly done split packages.

Offline

#22 2022-11-23 18:10:41

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,515
Website

Re: [SOLVED]Error with makepkg

Thanks - I just discovered that.  I had cloned the actual package name, and apparently there is a stale / deleted git repo with that name still.  Is that an issue with how this new package was submitted, or is there really a loophole in the aur functionality here?


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#23 2022-11-23 18:27:15

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,799

Re: [SOLVED]Error with makepkg

It's by design. When cloning, you're always cloning the pkgbase, and deleting a package just removes it from the web interface, so the underlying git repo is still there.

cervyesterday, given the state of these packages, I'm not sure what to tell you to do. nvidia-340xx-lts-dkms is probably your best option, but it also builds nvidia-340xx-lts, which you don't want. You'd have to edit the PKGBUILD to make it right, or just deal with the longer build and ignore the extra package. Just make sure you're actually building the nvidia-340xx-lts pkgbase.

Last edited by Scimmia (2022-11-23 18:27:54)

Offline

#24 2022-11-23 18:55:59

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

Scimmia wrote:

It's by design. When cloning, you're always cloning the pkgbase, and deleting a package just removes it from the web interface, so the underlying git repo is still there.

cervyesterday, given the state of these packages, I'm not sure what to tell you to do. nvidia-340xx-lts-dkms is probably your best option, but it also builds nvidia-340xx-lts, which you don't want. You'd have to edit the PKGBUILD to make it right, or just deal with the longer build and ignore the extra package. Just make sure you're actually building the nvidia-340xx-lts pkgbase.

Ok, so the error reported that says the kernel configuration is invalid is because it compiles both dkms and non-dkms versions?
In any case, I don't know how to properly edit the PKGBUILD file.
Furthermore, why both dkms and non-dkms packages have the same git url?

EDIT:
In the PKGBUILD it's written that an italian is one of the contributors, with his email address, do you think i could write to him?

Otherwise, Do you think i'd better switch to the non-lts kernel?

Last edited by cervyesterday (2022-11-23 19:03:38)

Offline

#25 2022-11-23 19:06:03

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,799

Re: [SOLVED]Error with makepkg

I don't know for sure what the error is from. I don't even know for sure what you're building. What are you doing, exactly?

Offline

Board footer

Powered by FluxBB