You are not logged in.

#26 2022-11-23 19:30:25

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

I've git cloned this package
https://aur.archlinux.org/packages/nvid … x-lts-dkms (which, for instance, is the same as the non-dkms git url)
Then i've ran makepkg -si in the package directory
And got that error

Offline

#27 2022-11-23 21:59:19

seth
Member
Registered: 2012-09-03
Posts: 33,622

Re: [SOLVED]Error with makepkg

The concept of dkms is antithetical to "linux version"
The easiest way out (w/o changing the PKGBUILDs) would be to install linux and linux-lts (and their corresponding header packages) - you can have as many unused kernels installed as you want.
Otherwise edit the dependency list of the dkms PKGBUILD(s) in question and make them depend on the kernel/headers you've installed.

Whatever you do: do NOT only install the header packages for any kernel, but not the kernel.

As for "broadcom-wl-lts" in particular:

Last Updated:    2016-12-16 08:04 (UTC)
Flagged out-of-date (2017-03-04)

You don't want to use that at all and under no circumstances and you don't have to: The concept of dkms is antithetical to "linux version".

Online

#28 2022-11-23 23:55:21

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,827

Re: [SOLVED]Error with makepkg

I just built that package in a clean chroot with no problem, so the issue is on your end. Post the entire log, maybe?

Offline

#29 2022-11-24 00:05:30

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

seth wrote:

The concept of dkms is antithetical to "linux version"
The easiest way out (w/o changing the PKGBUILDs) would be to install linux and linux-lts (and their corresponding header packages) - you can have as many unused kernels installed as you want.
Otherwise edit the dependency list of the dkms PKGBUILD(s) in question and make them depend on the kernel/headers you've installed.

Whatever you do: do NOT only install the header packages for any kernel, but not the kernel.

As for "broadcom-wl-lts" in particular:

Last Updated:    2016-12-16 08:04 (UTC)
Flagged out-of-date (2017-03-04)

You don't want to use that at all and under no circumstances and you don't have to: The concept of dkms is antithetical to "linux version".

Ok, i've reinstalled the whole system and both linux and linux-lts with their respective headers. Then i boot via grub in the linux entry (non-lts) and now i've successfully installed the nvidia-340xx-dkms driver(non lts). I've reinstalled plasma xorg and everything useful but now I have the same issue that I had last week with this topic
https://bbs.archlinux.org/viewtopic.php?id=281246
But this time boot is stuck at "finished load/save random seed" if I boot with the lts kernel and at "started Hostname service" if I boot with the non-lts kernel
Here's the journal of the last boot
https://0x0.st/oUmm.txt

Last edited by cervyesterday (2022-11-24 00:17:38)

Offline

#30 2022-11-24 07:11:59

seth
Member
Registered: 2012-09-03
Posts: 33,622

Re: [SOLVED]Error with makepkg

The boot isn't "stuck"

Nov 24 01:07:02 MacBookboB systemd[1]: Started Getty on tty2.
Nov 24 01:07:02 MacBookboB audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=getty@tty2 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 24 01:07:02 MacBookboB kernel: audit: type=1130 audit(1669248422.291:43): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=getty@tty2 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 24 01:07:04 MacBookboB dbus-daemon[274]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.11' (uid=0 pid=355 comm="/bin/login -p --    ")
Nov 24 01:07:04 MacBookboB dbus-daemon[274]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
Nov 24 01:07:04 MacBookboB login[355]: pam_systemd_home(login:auth): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Nov 24 01:07:06 MacBookboB audit[355]: USER_AUTH pid=355 uid=0 auid=4294967295 ses=4294967295 msg='op=PAM:authentication grantors=pam_securetty,pam_shells,pam_faillock,pam_permit,pam_faillock acct="bob" exe="/usr/bin/login" hostname=MacBookboB addr=? terminal=/dev/tty2 res=success'
…
Nov 24 01:07:06 MacBookboB login[355]: pam_unix(login:session): session opened for user bob(uid=1000) by LOGIN(uid=0)
Nov 24 01:07:06 MacBookboB kernel: audit: type=1100 audit(1669248426.031:44): pid=355 uid=0 auid=4294967295 ses=4294967295 msg='op=PAM:authentication grantors=pam_securetty,pam_shells,pam_faillock,pam_permit,pam_faillock acct="bob" exe="/usr/bin/login" hostname=MacBookboB addr=? terminal=/dev/tty2 res=success'
…
Nov 24 01:07:06 MacBookboB systemd-logind[275]: New session 1 of user bob.

However:

Nov 24 01:06:50 MacBookboB sddm[282]: Display server starting...
Nov 24 01:06:50 MacBookboB sddm[282]: Adding cookie to "/var/run/sddm/{5c55be39-4204-4224-91c6-a6d95a61e001}"
Nov 24 01:06:50 MacBookboB sddm[282]: Running: /usr/bin/X -nolisten tcp -background none -seat seat0 vt1 -auth /var/run/sddm/{5c55be39-4204-4224-91c6-a6d95a61e001} -noreset -displayfd 17
Nov 24 01:06:50 MacBookboB sddm[282]: Failed to read display number from pipe
Nov 24 01:06:50 MacBookboB sddm[282]: Display server stopping...
Nov 24 01:06:50 MacBookboB sddm[282]: Attempt 3 starting the Display server on vt 1 failed
Nov 24 01:06:50 MacBookboB sddm[282]: Could not start Display server on vt 1

This is probably subject for another thread, but post your xorg log.

Online

#31 2022-11-24 11:35:38

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

[    11.524] (--) Log file renamed from "/var/log/Xorg.pid-351.log" to "/var/log/Xorg.0.log"
[    11.526] 
X.Org X Server 1.21.1.4
X Protocol Version 11, Revision 0
[    11.526] Current Operating System: Linux MacBookboB 6.0.9-arch1-1 #1 SMP PREEMPT_DYNAMIC Wed, 16 Nov 2022 17:01:17 +0000 x86_64
[    11.526] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=810b5a05-c06d-4730-a663-aca674d9e2e1 rw loglevel=3
[    11.526]  
[    11.526] Current version of pixman: 0.42.2
[    11.526] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    11.527] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    11.527] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 24 12:22:27 2022
[    11.527] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    11.527] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    11.527] (==) ServerLayout "Layout0"
[    11.527] (**) |-->Screen "Screen0" (0)
[    11.527] (**) |   |-->Monitor "Monitor0"
[    11.527] (**) |   |-->Device "Device0"
[    11.527] (**) |-->Input Device "Keyboard0"
[    11.527] (**) |-->Input Device "Mouse0"
[    11.527] (==) Automatically adding devices
[    11.527] (==) Automatically enabling devices
[    11.527] (==) Automatically adding GPU devices
[    11.527] (==) Automatically binding GPU devices
[    11.527] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    11.527] (WW) The directory "/usr/share/fonts/misc" does not exist.
[    11.528] 	Entry deleted from font path.
[    11.528] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/TTF".
[    11.528] 	Entry deleted from font path.
[    11.528] 	(Run 'mkfontdir' on "/usr/share/fonts/TTF").
[    11.528] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    11.528] 	Entry deleted from font path.
[    11.528] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    11.528] 	Entry deleted from font path.
[    11.528] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    11.528] 	Entry deleted from font path.
[    11.528] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    11.528] 	Entry deleted from font path.
[    11.528] (==) FontPath set to:
	
[    11.528] (==) ModulePath set to "/usr/lib/xorg/modules"
[    11.528] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    11.528] (WW) Disabling Keyboard0
[    11.528] (WW) Disabling Mouse0
[    11.528] (II) Module ABI versions:
[    11.528] 	X.Org ANSI C Emulation: 0.4
[    11.528] 	X.Org Video Driver: 25.2
[    11.528] 	X.Org XInput driver : 24.4
[    11.528] 	X.Org Server Extension : 10.0
[    11.529] (++) using VT number 1

[    11.529] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    11.529] (II) xfree86: Adding drm device (/dev/dri/card0)
[    11.529] (II) Platform probe for /sys/devices/pci0000:00/0000:00:10.0/0000:02:00.0/drm/card0
[    11.532] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"
[    11.532] (**) OutputClass "nvidia" setting /dev/dri/card0 as PrimaryGPU
[    11.534] (--) PCI:*(2@0:0:0) 10de:0863:106b:00aa rev 177, Mem @ 0xd2000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00001000/128, BIOS @ 0x????????/131072
[    11.534] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    11.534] (II) LoadModule: "glx"
[    11.535] (II) Loading /usr/lib/nvidia/xorg/libglx.so
[    11.556] (II) Module glx: vendor="NVIDIA Corporation"
[    11.556] 	compiled for 4.0.2, module version = 1.0.0
[    11.556] 	Module class: X.Org Server Extension
[    11.556] (II) NVIDIA GLX Module  340.108  Wed Dec 11 14:26:50 PST 2019
[    11.556] (II) LoadModule: "nvidia"
[    11.556] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    11.557] (II) Module nvidia: vendor="NVIDIA Corporation"
[    11.557] 	compiled for 4.0.2, module version = 1.0.0
[    11.557] 	Module class: X.Org Video Driver
[    11.557] ================ WARNING WARNING WARNING WARNING ================
[    11.557] This server has a video driver ABI version of 25.2 that this
driver does not officially support.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[    11.557] =================================================================
[    11.557] (EE) NVIDIA: Use the -ignoreABI option to override this check.
[    11.557] (II) UnloadModule: "nvidia"
[    11.557] (II) Unloading nvidia
[    11.557] (EE) Failed to load module "nvidia" (unknown error, 0)
[    11.557] (EE) No drivers available.
[    11.557] (EE) 
Fatal server error:
[    11.557] (EE) no screens found(EE) 
[    11.557] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    11.557] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    11.557] (EE) 
[    11.557] (EE) Server terminated with error (1). Closing log file.

I remember that i saw something around with the "-ignoreABI" option, but i can't remember where i have to write it

Offline

#32 2022-11-24 11:48:03

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

Ok i found it, it's in nvidia config file, i add it and now it works.

Offline

#33 2022-11-24 11:53:13

seth
Member
Registered: 2012-09-03
Posts: 33,622

Re: [SOLVED]Error with makepkg

https://aur.archlinux.org/cgit/aur.git/ … idia-340xx

It rather looks like you added a static server config for no reason

[    11.527] (==) ServerLayout "Layout0"
[    11.527] (**) |-->Screen "Screen0" (0)
[    11.527] (**) |   |-->Monitor "Monitor0"
[    11.527] (**) |   |-->Device "Device0"
[    11.527] (**) |-->Input Device "Keyboard0"
[    11.527] (**) |-->Input Device "Mouse0"

You shoudl remove *that* file and let the 20-nvidia.conf that comes w/ the package handle the driver config.

Online

#34 2022-11-24 12:36:52

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

seth wrote:

https://aur.archlinux.org/cgit/aur.git/ … idia-340xx

It rather looks like you added a static server config for no reason

[    11.527] (==) ServerLayout "Layout0"
[    11.527] (**) |-->Screen "Screen0" (0)
[    11.527] (**) |   |-->Monitor "Monitor0"
[    11.527] (**) |   |-->Device "Device0"
[    11.527] (**) |-->Input Device "Keyboard0"
[    11.527] (**) |-->Input Device "Mouse0"

You shoudl remove *that* file and let the 20-nvidia.conf that comes w/ the package handle the driver config.

It seems like it's going well in any case, do you think i should do it anyway?

Offline

#35 2022-11-24 12:42:34

seth
Member
Registered: 2012-09-03
Posts: 33,622

Re: [SOLVED]Error with makepkg

Yes. Forcing a static server config is highly discouraged and only required for very specific setups - and nvidia-settings generates garbled cruft anyway.
(In this case breaking your setup)

Online

#36 2022-11-24 13:48:10

cervyesterday
Member
Registered: 2022-11-13
Posts: 39

Re: [SOLVED]Error with makepkg

seth wrote:

Yes. Forcing a static server config is highly discouraged and only required for very specific setups - and nvidia-settings generates garbled cruft anyway.
(In this case breaking your setup)

I did it, but now i can't get networks... how is it possible?

Edit:
Ok i reboot again and now no issues with networks

Last edited by cervyesterday (2022-11-24 13:51:11)

Offline

#37 2022-11-24 13:55:43

seth
Member
Registered: 2012-09-03
Posts: 33,622

Re: [SOLVED]Error with makepkg

Your network issues aren't related to your xor config.
If they flare up again, open a nwe thread and post a complete system journal and the output of

find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f

Online

Board footer

Powered by FluxBB