You are not logged in.

#1 2022-11-25 15:52:29

TheLastTeapot
Member
Registered: 2022-11-25
Posts: 2

[SOLVED]nvidia-open driver fails to work on Hyprland (wlroots)

my specs:
cpu: Amd Ryzen 7 3700x
Gpu: Nvidia GeForce 470 GT
Motherboard: MSI x570 MEG Unify
Drive: SK Hynix Gold 512GB ssd
RAM: 16GB Crucial ballistix 3600mHz

I know this is a very common issue, but I'm pretty sure my card will work.
I have followed the instructions here (https://wiki.hyprland.org/Nvidia/) and also added nvidia nvidia_modeset nvidia_uvm nvidia_drm and nvidia_drm.modeset=1 to my /etc/default/grub and regenerated the config. When launching Hyprland through the wrapper the first time after boot, I get: "

Seat opened with backend 'logind' 
Successfully loaded libseat session
Found 1 GPUs
Initializing DRM backend for /dev/dri/card0 (nvidia-drm)
Found 4 DRM CRTCs
Found 12 DRM planes
Supported EGL client extensions: EGL_EXT_platform_base EGL_EXT_device_base EGL_EXT_device_enumeration EGL_EXT_device_query EGL_KHR_client_get_all_proc_addresses EGL_EXT_client_extensions EGL_KHR_debug EGL_KHR(screen cuts off here). And then it doesn't open and the prompt appears again with [SIGABRT] in front of it.

After that, every time I run it I get: "fish: Job 1, './.local/(username)/wrapperh1' terminated by signal SIGABRT (Abort)01), message: "eglInitialize"o create screen"yDevicesEXT: failed to allocate device list.form_xcb EGL_MESA_platform_surfacelesslient_extensions EGL_KHR_debug EGL_KHR(screen cuts off here)".

Any help is very appreciated, this is my first time posting an issue, so if you need any information I have not supplied, please ask for it. I am aware there may be no solution to this problem and it might just not work.

Last edited by TheLastTeapot (2022-11-25 16:24:41)

Offline

#2 2022-11-25 15:59:06

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 18,171

Re: [SOLVED]nvidia-open driver fails to work on Hyprland (wlroots)

Your card and the driver you are required to use for it (... you'd need nvidia-390xx-{dkms,utils} from the AUR for that) are too old to support these developments. It should work if you opt for the open source nouveau though. You need to remove nvidia-{open,utils} regardless.

GBM support in the nvidia driver was only introduced with the 495 driver: https://wiki.archlinux.org/title/Wayland#Requirements

Last edited by V1del (2022-11-25 16:20:29)

Offline

#3 2022-11-25 16:24:00

TheLastTeapot
Member
Registered: 2022-11-25
Posts: 2

Re: [SOLVED]nvidia-open driver fails to work on Hyprland (wlroots)

Thank you for the clarification, A new card(AMD) is on my shopping list

Offline

Board footer

Powered by FluxBB