You are not logged in.

#1 2022-11-27 09:06:16

ez_hedge
Member
Registered: 2022-11-27
Posts: 7

XFCE4 cannot log-in (login loop), can log as root

Hello, I know this problem has already been answered several times but nothing I've read was helpful..

Since this morning, when I try to login as regular user, I'm stuck inside a loop but I can log as root.
I guess the problem is permission for my /home/user folder, but now that I did chown properly, I'm out of ideas about what's wrong..

I'd prefer understand the issue and fix it, rather nuking with snapper at each problem I'll encounter (without any guarantee that it'd fix anything, been days last reboot..)

Please I need your help..

EDIT : I can log as my regular user from tty..

Last edited by ez_hedge (2022-11-27 09:07:22)

Offline

#2 2022-11-27 09:24:37

seth
Member
Registered: 2012-09-03
Posts: 35,092

Re: XFCE4 cannot log-in (login loop), can log as root

Post a system journal after failing to login to xfce:

sudo journalctl -b | curl -F 'file=@-' 0x0.st

Offline

#3 2022-11-27 09:28:10

ez_hedge
Member
Registered: 2022-11-27
Posts: 7

Re: XFCE4 cannot log-in (login loop), can log as root

Here's the output : http://0x0.st/oU7S.txt

Offline

#4 2022-11-27 09:28:22

tucuxi
Member
From: Switzerland
Registered: 2020-03-08
Posts: 285

Re: XFCE4 cannot log-in (login loop), can log as root

What changes did you make during your last session before this morning?

Why did you suspect the problem was caused by wrong permissions? Instead of running chown, you should have verified your hypothesis first.

Post the journal when you could not log in.

Offline

#5 2022-11-27 09:36:22

ez_hedge
Member
Registered: 2022-11-27
Posts: 7

Re: XFCE4 cannot log-in (login loop), can log as root

I didn't reboot for many days, so it's hard to tell what I did which may have caused this.. but I did :

- rename user (probably main cause, debugging this morning running ls -l /home/user displayed permission for old username, then I did chown)
- pipewire manager
- install/unistall/install rust
- install yarn
- firejail & firecfg
- installed libvirt
- selenium browser automation

Offline

#6 2022-11-27 09:39:52

ez_hedge
Member
Registered: 2022-11-27
Posts: 7

Re: XFCE4 cannot log-in (login loop), can log as root

reading my logs, the 1st "lightdm" appears here :

Nov 27 09:51:06 arch audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lightdm comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 27 09:51:06 arch lightdm[1029]: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files

Last edited by ez_hedge (2022-11-27 10:41:12)

Offline

#7 2022-11-27 09:47:20

seth
Member
Registered: 2012-09-03
Posts: 35,092

Re: XFCE4 cannot log-in (login loop), can log as root

There isn't even an indication of an attempt to start the session, post the lightdm log (should be in /var/log)
But "rename user" is most likely the cause

grep -rE '(dev|1000)' /etc/passwd

(there're no passwords in that file, the name is historic)

Offline

#8 2022-11-27 09:48:37

ez_hedge
Member
Registered: 2022-11-27
Posts: 7

Re: XFCE4 cannot log-in (login loop), can log as root

dev:x:1000:1000::/home/dev:/bin/bash (I have a terminal open)

Last edited by ez_hedge (2022-11-27 10:40:56)

Offline

#9 2022-11-27 09:50:09

ez_hedge
Member
Registered: 2022-11-27
Posts: 7

Re: XFCE4 cannot log-in (login loop), can log as root

I made sure to include multiple tries for username 'dev' :

output of /var/log/lightdm/lightdm.log

[+3104.92s] DEBUG: Session pid=7408: Started with service 'lightdm', username 'dev'
[+3104.93s] DEBUG: Session pid=7408: Got 1 message(s) from PAM
[+3104.93s] DEBUG: Prompt greeter with 1 message(s)
[+3113.87s] DEBUG: Continue authentication
[+3113.88s] DEBUG: Session pid=7408: Authentication complete with return value 0: Success
[+3113.88s] DEBUG: Authenticate result for user dev: Success
[+3113.88s] DEBUG: User dev authorized
[+3113.89s] DEBUG: Greeter requests session xfce
[+3113.89s] DEBUG: Seat seat0: Stopping greeter; display server will be re-used for user session
[+3113.89s] DEBUG: Terminating login1 session c9
[+3113.89s] DEBUG: Session pid=7351: Sending SIGTERM
[+3113.89s] DEBUG: Greeter closed communication channel
[+3113.89s] DEBUG: Session pid=7351: Exited with return value 0
[+3113.89s] DEBUG: Seat seat0: Session stopped
[+3113.89s] DEBUG: Seat seat0: Greeter stopped, running session
[+3113.89s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session5
[+3113.89s] DEBUG: Session pid=7408: Running command /etc/lightdm/Xsession startxfce4
[+3113.89s] DEBUG: Creating shared data directory /var/lib/lightdm-data/dev
[+3113.89s] DEBUG: Session pid=7408: Logging to .xsession-errors
[+3114.08s] DEBUG: Activating VT 8
[+3114.08s] DEBUG: Activating login1 session 16
[+3114.08s] DEBUG: Seat seat0 changes active session to 
[+3114.08s] DEBUG: Seat seat0 changes active session to 16
[+3114.08s] DEBUG: Session 16 is already active
[+3114.11s] DEBUG: Session pid=7408: Exited with return value 127
[+3114.11s] DEBUG: Seat seat0: Session stopped
[+3114.11s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+3114.11s] DEBUG: Sending signal 15 to process 7341
[+3114.11s] DEBUG: Seat seat0 changes active session to 
[+3114.41s] DEBUG: Process 7341 exited with return value 0
[+3114.41s] DEBUG: XServer 1: X server stopped
[+3114.41s] DEBUG: Releasing VT 8
[+3114.41s] DEBUG: XServer 1: Removing X server authority /run/lightdm/root/:1
[+3114.41s] DEBUG: Seat seat0: Display server stopped
[+3114.41s] DEBUG: Seat seat0: Active display server stopped, starting greeter
[+3114.41s] DEBUG: Seat seat0: Creating greeter session
[+3114.41s] DEBUG: Seat seat0: Creating display server of type x
[+3114.41s] DEBUG: Using VT 8
[+3114.41s] DEBUG: Seat seat0: Starting local X display on VT 8
[+3114.41s] DEBUG: XServer 1: Logging to /var/log/lightdm/x-1.log
[+3114.41s] DEBUG: XServer 1: Writing X server authority to /run/lightdm/root/:1
[+3114.41s] DEBUG: XServer 1: Launching X Server
[+3114.41s] DEBUG: Launching process 7457: /usr/bin/X :1 -seat seat0 -auth /run/lightdm/root/:1 -nolisten tcp vt8 -novtswitch
[+3114.41s] DEBUG: XServer 1: Waiting for ready signal from X server :1
[+3115.10s] DEBUG: Got signal 10 from process 7457
[+3115.10s] DEBUG: XServer 1: Got signal from X server :1
[+3115.10s] DEBUG: XServer 1: Connecting to XServer :1
[+3115.10s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+3115.10s] DEBUG: Session pid=7467: Started with service 'lightdm-greeter', username 'lightdm'
[+3115.11s] DEBUG: Session pid=7467: Authentication complete with return value 0: Success
[+3115.11s] DEBUG: Seat seat0: Session authenticated, running command
[+3115.11s] DEBUG: Session pid=7467: Running command /usr/bin/lightdm-gtk-greeter
[+3115.11s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+3115.11s] DEBUG: Session pid=7467: Logging to /var/log/lightdm/seat0-greeter.log
[+3115.15s] DEBUG: Activating VT 8
[+3115.15s] DEBUG: Activating login1 session c10
[+3115.16s] DEBUG: Seat seat0 changes active session to c10
[+3115.16s] DEBUG: Session c10 is already active
[+3115.22s] DEBUG: Greeter connected version=1.32.0 api=1 resettable=false
[+3115.26s] DEBUG: Greeter start authentication for dev
[+3115.26s] DEBUG: Session pid=7488: Started with service 'lightdm', username 'dev'
[+3115.26s] DEBUG: Session pid=7488: Got 1 message(s) from PAM
[+3115.26s] DEBUG: Prompt greeter with 1 message(s)
[+3117.10s] DEBUG: Greeter start authentication
[+3117.10s] DEBUG: Session pid=7488: Sending SIGTERM
[+3117.10s] DEBUG: Session pid=7495: Started with service 'lightdm', username '(null)'
[+3117.10s] DEBUG: Session pid=7488: Terminated with signal 15
[+3117.10s] DEBUG: Session: Failed during authentication
[+3117.10s] DEBUG: Seat seat0: Session stopped
[+3117.11s] DEBUG: Session pid=7495: Got 1 message(s) from PAM
[+3117.11s] DEBUG: Prompt greeter with 1 message(s)
[+3118.73s] DEBUG: Greeter start authentication for root
[+3118.73s] DEBUG: Session pid=7495: Sending SIGTERM
[+3118.73s] DEBUG: Session pid=7496: Started with service 'lightdm', username 'root'
[+3118.73s] DEBUG: Session pid=7495: Terminated with signal 15
[+3118.73s] DEBUG: Session: Failed during authentication
[+3118.73s] DEBUG: Seat seat0: Session stopped
[+3118.73s] DEBUG: Session pid=7496: Got 1 message(s) from PAM
[+3118.73s] DEBUG: Prompt greeter with 1 message(s)
[+3125.82s] DEBUG: Continue authentication
[+3127.49s] DEBUG: Session pid=7496: Authentication complete with return value 7: Authentication failure
[+3127.49s] DEBUG: Authenticate result for user root: Authentication failure
[+3127.49s] DEBUG: Session pid=7496: Exited with return value 1
[+3127.49s] DEBUG: Seat seat0: Session stopped
[+3127.50s] DEBUG: Greeter start authentication for root
[+3127.50s] DEBUG: Session pid=7505: Started with service 'lightdm', username 'root'
[+3127.50s] DEBUG: Session pid=7505: Got 1 message(s) from PAM
[+3127.50s] DEBUG: Prompt greeter with 1 message(s)
[+3133.72s] DEBUG: Greeter start authentication for root
[+3133.72s] DEBUG: Session pid=7505: Sending SIGTERM
[+3133.72s] DEBUG: Session pid=7506: Started with service 'lightdm', username 'root'
[+3133.72s] DEBUG: Session pid=7505: Terminated with signal 15
[+3133.72s] DEBUG: Session: Failed during authentication
[+3133.72s] DEBUG: Seat seat0: Session stopped
[+3133.72s] DEBUG: Session pid=7506: Got 1 message(s) from PAM
[+3133.72s] DEBUG: Prompt greeter with 1 message(s)
[+3139.55s] DEBUG: Continue authentication
[+3139.56s] DEBUG: Session pid=7506: Authentication complete with return value 0: Success
[+3139.56s] DEBUG: Authenticate result for user root: Success
[+3139.56s] DEBUG: User root authorized
[+3139.57s] DEBUG: Greeter requests session xfce
[+3139.57s] DEBUG: Seat seat0: Returning to existing user session root
[+3139.57s] DEBUG: Unlocking login1 session 4
[+3139.57s] DEBUG: Activating VT 7
[+3139.80s] DEBUG: Seat seat0: Stopping greeter
[+3139.80s] DEBUG: Terminating login1 session c10
[+3139.80s] DEBUG: Session pid=7467: Sending SIGTERM
[+3139.80s] DEBUG: Activating login1 session 4
[+3139.81s] DEBUG: Session pid=7506: Exited with return value 0
[+3139.81s] DEBUG: Seat seat0: Session stopped
[+3139.81s] DEBUG: Seat seat0 changes active session to 4
[+3139.81s] DEBUG: Session 4 is already active
[+3139.82s] DEBUG: Greeter closed communication channel
[+3139.82s] DEBUG: Session pid=7467: Exited with return value 0
[+3139.82s] DEBUG: Seat seat0: Session stopped
[+3139.82s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+3139.82s] DEBUG: Sending signal 15 to process 7457
[+3139.83s] DEBUG: Process 7457 exited with return value 0
[+3139.83s] DEBUG: XServer 1: X server stopped
[+3139.83s] DEBUG: Releasing VT 8
[+3139.83s] DEBUG: XServer 1: Removing X server authority /run/lightdm/root/:1
[+3139.83s] DEBUG: Seat seat0: Display server stopped

Last edited by ez_hedge (2022-11-27 10:40:43)

Offline

#10 2022-11-27 10:09:57

seth
Member
Registered: 2012-09-03
Posts: 35,092

Re: XFCE4 cannot log-in (login loop), can log as root

Please edit your post and use code tags, https://bbs.archlinux.org/help.php#bbcode

[+3113.89s] DEBUG: Seat seat0: Greeter stopped, running session
[+3113.89s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session5
[+3113.89s] DEBUG: Session pid=7408: Running command /etc/lightdm/Xsession startxfce4
[+3113.89s] DEBUG: Creating shared data directory /var/lib/lightdm-data/dev
[+3113.89s] DEBUG: Session pid=7408: Logging to .xsession-errors
[+3114.08s] DEBUG: Activating VT 8
[+3114.08s] DEBUG: Activating login1 session 16
[+3114.08s] DEBUG: Seat seat0 changes active session to
[+3114.08s] DEBUG: Seat seat0 changes active session to 16
[+3114.08s] DEBUG: Session 16 is already active
[+3114.11s] DEBUG: Session pid=7408: Exited with return value 127
stat /home/dev /home/dev/.Xauthority

Offline

#11 2022-11-27 10:40:25

ez_hedge
Member
Registered: 2022-11-27
Posts: 7

Re: XFCE4 cannot log-in (login loop), can log as root

I think issue is much broader than I've thought : renaming user kept alive systemd services as long I didn't fully rebooted, I think I have configuration mismatches all over the place now..

I deleted ~/.Xauthority as suggested by some tutorials, ain't sure what to look at

  File: /home/dev
  Size: 754       	Blocks: 8          IO Block: 4096   directory
Device: 0,37	Inode: 257         Links: 1
Access: (0710/drwx--x---)  Uid: ( 1000/     dev)   Gid: ( 1000/     dev)
Access: 2022-11-22 08:57:22.233388201 +0100
Modify: 2022-11-27 10:53:16.380633245 +0100
Change: 2022-11-27 10:53:16.380633245 +0100
 Birth: 2022-11-22 08:57:22.233388201 +0100
  File: /home/dev/.Xauthority
  Size: 0         	Blocks: 0          IO Block: 4096   regular empty file
Device: 0,37	Inode: 860048      Links: 1
Access: (0600/-rw-------)  Uid: ( 1000/     dev)   Gid: ( 1000/     dev)
Access: 2022-11-27 10:19:34.822199895 +0100
Modify: 2022-11-27 10:43:00.370383748 +0100
Change: 2022-11-27 10:43:00.370383748 +0100
 Birth: 2022-11-27 10:19:34.822199895 +0100

Offline

#12 2022-11-27 14:34:12

seth
Member
Registered: 2012-09-03
Posts: 35,092

Re: XFCE4 cannot log-in (login loop), can log as root

Those permissions are at least ok.
Can you:
1. use lightdm to log into an openbox session?
2. "startx xterm"
3. startxfce4 from within that xterm?

Offline

Board footer

Powered by FluxBB