You are not logged in.

#1 2022-11-28 09:41:07

fistrosan
Member
Registered: 2020-04-01
Posts: 156

[SOLVED] setxkbmap grp: not having any effect

Hi all. I am trying to cycle between us,es,de keyboard layouts using setxkbmap -option grp: However it does not matter what combination I chose from the available ones (i.e alt_shift_toggle or whatever) that it simply does not change. I can manually change it using setxkbmap -model pc104 -layout de, but it is the cycling between layouts that is not working. Any ideas as to what might be going on here ?

/etc/X11/xorg.conf.d/00-keyboard.conf

Section "InputClass"
	Identifier "system-keyboard"
	MatchIsKeyboard "on"
	Option "Xkblayout" "de"
EndSection

/etc/vconsole.conf

KEYMAP=de-latin1

~/.xinitrc

setxkbmap -model pc104 -layout de,us,es -option grp:alt_shift_toogle
exec /usr/bin/i3 -c .config/i3/config

Edit: solved by correcting the spelling error in the call to setxkbmap ... it should be "toggle" instead of "toogle"

Last edited by fistrosan (2022-11-29 18:26:26)

Offline

#2 2022-11-28 10:13:40

seth
Member
Registered: 2012-09-03
Posts: 34,920

Re: [SOLVED] setxkbmap grp: not having any effect

vconsole isn't relevant.
What's the output of "setxkbmap -print -query"?

setxkbmap -model pc104 -layout de

This will reconfigure the keyboard to only the "de" layout - cycling will not work afterwards for sure (also it's slow and restricitve)

Also what's the testcase for "is not working"?
Simply qwertz/qwerty or some shortcut (because those have other pitfalls)?

Offline

#3 2022-11-28 10:36:17

fistrosan
Member
Registered: 2020-04-01
Posts: 156

Re: [SOLVED] setxkbmap grp: not having any effect

Hi Seth, let us see.

Seth wrote:

What's the output of "setxkbmap -print -query"?

xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwertz)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+de+us:2+es:3+inet(evdev)"	};
	xkb_geometry  { include "pc(pc104)"	};
};
rules:      evdev
model:      pc104
layout:     de,us,es
options:    grp:alt_shift_toogle
Seth wrote:

Also what's the testcase for "is not working"?

After pressing alt_shift I am still on "de" ... (i.e. "z" is still "z" and not "y")

Seth wrote:

This will reconfigure the keyboard to only the "de" layout - cycling will not work afterwards for sure (also it's slow and restricitve)

What I meant is that if I type only "setxkbmap -model pc104 -layout de" it does change to German and then "setxkbmap -model pc104 -layout en" will change to English ... in other words, setxkbmap is working ... it is grp option that it does not work.

Question: would you suggest maybe modifying keyboard.conf in X11 to include 

Option "XkbLayout" "de,en,es"
Option "XkbOptions" "grp:alt_shift_toggle"

Offline

#4 2022-11-28 11:14:07

seth
Member
Registered: 2012-09-03
Posts: 34,920

Re: [SOLVED] setxkbmap grp: not having any effect

would you suggest maybe modifying keyboard.conf in X11 to include

Whether you change that w/ the server config or the init scripts only impacts the scope - on de-facto single user system it doesn't matter.

After pressing alt_shift I am still on "de" ... (i.e. "z" is still "z" and not "y")

Does that also affect shift+z/shift+y for Z/Y?

Edit: to riff on that, try to run some random xmodmap or just "xkbset -r; xkbset r", https://aur.archlinux.org/packages/xkbset

Last edited by seth (2022-11-28 15:38:46)

Offline

#5 2022-11-29 18:24:41

fistrosan
Member
Registered: 2020-04-01
Posts: 156

Re: [SOLVED] setxkbmap grp: not having any effect

boy oh boy ... this is what happens when one does not pay attention ... it is not toogle but toggle ... now it works ... geeez ....

Offline

Board footer

Powered by FluxBB