You are not logged in.

#1 2022-11-28 17:25:41

Registered: 2022-11-28
Posts: 1

[SOLVED] ASUS ZenBook UM425Q Headset Mic Not Working

Hi, I just adquired this notebook and had problems with the audio driver, specifically by getting no input sound from a connected headset via jack input.
I found that the soundcard ALC294 is known by lots of bugs and I'd like to post how I managed to make it work in my system which is not Arch, but Linux Mint,
however this should be a general solution (which I need to post somewhere)

First of all I installed one of the most recent kernels: 6.0.9-060009-generic version specifically
Next I removed pipewire since somebody commented to have issues while coexisting with pulseaudio
I also added a line to the end of "/etc/modprobe.d/alsa-base.conf" -> "options snd-hda-intel model=asus-zenbook", which probably contributed zero to solve anything
And finally I used HDAjackRetask to configure one of the internal pins of the soundcard.
After a couple of tries I got it to work by setting: PIN 0x19 Override Microphone, et voilà headset mic now WORKING

I hope someone read this post and help people having issues with this laptop model, which is very likely to be the solution in many other models with the same sound card

Last edited by sunshadow (2022-11-28 17:26:12)


#2 2023-01-27 23:15:48

Registered: 2023-01-27
Posts: 7

Re: [SOLVED] ASUS ZenBook UM425Q Headset Mic Not Working

Thanks! This also worked with my diabolical Vivobook m5402, running 6.1.8. Followed exact steps.


#3 2023-03-31 20:18:23

Registered: 2020-04-14
Posts: 5

Re: [SOLVED] ASUS ZenBook UM425Q Headset Mic Not Working

I have an ASUS Vivobook M7400QC running Arch Linux with the same ALC294. The only thing I changed to make it work is to use


> Choose the correct card > "Show Unconnected Pins" > Scroll to 0x19 > Check "Override" > Select "Microphone"

The "Apply Now" didn't work, but if I "Install boot override", then restart, the plugged in microphone now works! Thank you so much!

Now, if I type

pacmd --list-sources

I get two mic sources, one internal, one plugged in:

		analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: no)
				device.icon_name = "audio-input-microphone"
		analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: yes)
				device.icon_name = "audio-input-microphone"


Board footer

Powered by FluxBB