You are not logged in.

#1 2022-12-18 02:49:59

alwaysthesun
Member
Registered: 2022-12-18
Posts: 7

Windows installion is missing in GRUB

At https://wiki.archlinux.org/title/NTFS i'm reading the following:

Since Linux 5.15, ntfs3 provides read and write support for the file system. All officially supported kernels with versions 5.15 or newer are built with CONFIG_NTFS3_FS=m and thus support it.

I have kernel version 6.0.12-arch1-1. After installing os-prober, enableing it in /etc/default/grub and executing the following command sudo grub-mkconfig -o /boot/grub/grub.cfg my Windows installation is missing in the GRUB entry

Offline

#2 2022-12-18 02:55:23

alwaysthesun
Member
Registered: 2022-12-18
Posts: 7

Re: Windows installion is missing in GRUB

I found the ntfs3 package in AUR. Problem is solved.

Offline

#3 2022-12-18 03:08:46

Scimmia
Fellow
Registered: 2012-09-01
Posts: 10,018

Re: Windows installion is missing in GRUB

More likely a reboot or something fixed it. The ntfs3 packages in the AUR wouldn't help in any way.

Online

#4 2022-12-18 03:09:05

alwaysthesun
Member
Registered: 2022-12-18
Posts: 7

Re: Windows installion is missing in GRUB

Installed ntfsprogs-ntfs3 from AUR... Still no luck... Please help

P.S. Do i have to mount the drive where windows is installed???

Last edited by alwaysthesun (2022-12-18 03:10:59)

Offline

#5 2022-12-18 03:13:07

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 7,127

Re: Windows installion is missing in GRUB

Post the complete output of the commands you're using and add --verbose or equivalent to get more detail.

lsblk -f

Last edited by cfr (2022-12-18 03:13:30)


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#6 2022-12-18 03:27:41

alwaysthesun
Member
Registered: 2022-12-18
Posts: 7

Re: Windows installion is missing in GRUB

[Perica@neptun ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
[sudo] password for Perica: 
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
done
[Perica@neptun ~]$ lsblk -f
NAME        FSTYPE FSVER LABEL   UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda                                                                                  
├─sda1      exfat  1.0   Ventoy  4E21-0000                               193G    17% /run/media/Perica/Ventoy
└─sda2      vfat   FAT16 VTOYEFI 9576-3784                               4.7M    85% /run/media/Perica/VTOYEFI
nvme0n1                                                                              
├─nvme0n1p1 vfat   FAT32         F624-077D                                           
├─nvme0n1p2                                                                          
├─nvme0n1p3 ntfs                 86322CBC322CB2DB                                    
├─nvme0n1p4 ntfs                 5A6287A56287850B                                    
├─nvme0n1p5 vfat   FAT32         EE66-C1D9                             299.2M     0% /efi
└─nvme0n1p6 ext4   1.0           8ade34ac-b489-4cec-a3a8-5fa744ed8ac2   87.1G     6% /

Last edited by alwaysthesun (2022-12-18 18:12:35)

Offline

#7 2022-12-18 09:28:34

seth
Member
Registered: 2012-09-03
Posts: 35,051

Re: Windows installion is missing in GRUB

Please stop installing random packages, base on wild guesses and apparent syntactic relations.

The lsblk output looks like
a) you're booting some random live distro?
b) you've two EFI partitions? (nvme0n1p1 & nvme0n1p5)

The former would make any assumptions about the arch kernel irrelevant, since it'd not be the running kernel.

The latter is not recommended at all, https://wiki.archlinux.org/title/Dual_b … FI_systems

An additional EFI system partition should not be created, as it may prevent Windows from booting … Simply mount the existing partition.

Offline

#8 2022-12-18 15:20:36

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 7,127

Re: Windows installion is missing in GRUB

Please edit your posts to use [ code ] tags rather than [ quote ] tags.


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#9 2022-12-18 17:03:20

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,792
Website

Re: Windows installion is missing in GRUB

alwaysthesun wrote:

Installed ntfsprogs-ntfs3

The Windows bootloader is on one of the the EFI system partitions, probably the first one, so NTFS support is irrelevant here.

alwaysthesun wrote:

Do i have to mount the drive where windows is installed?

You have to mount the partition containing bootmgfw.efi (the Windows EFI loader) for os-prober to be able to find it and for grub-mkconfig to add a menuentry.

Multiple EFI system partitions might work as long as the firmware ("BIOS") co-operates. GRUB can certainly handle them.

Online

#10 2022-12-18 17:15:49

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 7,127

Re: Windows installion is missing in GRUB

Head_on_a_Stick wrote:

Multiple EFI system partitions might work as long as the firmware ("BIOS") co-operates. GRUB can certainly handle them.

Even on the same drive? I've seen people use two successfully where each is on a different drive, but are there cases where it can work with two on the same drive?


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#11 2022-12-18 17:22:25

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,792
Website

Re: Windows installion is missing in GRUB

I've had it working on ThinkPads. EDIT: but it's probably best for the OP to just use the Windows ESP, obviously.

Last edited by Head_on_a_Stick (2022-12-18 17:24:07)

Online

#12 2022-12-21 00:41:57

alwaysthesun
Member
Registered: 2022-12-18
Posts: 7

Re: Windows installion is missing in GRUB

I did a new Arch install. I did the same partition sheme as above but this time i additionally mounted the Windows EFI partition (nvme0n1p1) to /efiwin as Head_on_a_Stick suggested

No luck

But the interesting thing is when i installed the ntfs-3g package it worked

Last edited by alwaysthesun (2022-12-21 01:44:00)

Offline

#13 2022-12-21 08:23:29

seth
Member
Registered: 2012-09-03
Posts: 35,051

Re: Windows installion is missing in GRUB

sudo mount -t ntfs3 /dev/nvme0n1p3 /mnt
sudo umount /mnt
sudo mount -t ntfs3 /dev/nvme0n1p4 /mnt
sudo umount /mnt
sudo dmesg | grep -i dirty

Offline

#14 2022-12-21 12:35:39

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,792
Website

Re: Windows installion is missing in GRUB

alwaysthesun wrote:

this time i additionally mounted the Windows EFI partition (nvme0n1p1) to /efiwin as Head_on_a_Stick suggested

So did grub-mkconfig find bootmgfw.efi and add a menu entry to /boot/grub/grub.cfg? Is bootmgfw.efi present on /dev/nvme0n1p1?

alwaysthesun wrote:

when i installed the ntfs-3g package it worked

That seems to suggest that Windows isn't installed in UEFI mode, which shouldn't be that case for a GPT disk. Can you confirm?

Online

#15 2022-12-22 01:13:25

alwaysthesun
Member
Registered: 2022-12-18
Posts: 7

Re: Windows installion is missing in GRUB

I also used (as you can see) additionally the journalctl command (because dmesg gave no output)

[Petar@batman ~]$ sudo mount -t ntfs3 /dev/nvme0n1p3 /mnt
[sudo] Passwort für Petar: 
[Petar@batman ~]$ sudo umount /mnt
[Petar@batman ~]$ sudo mount -t ntfs3 /dev/nvme0n1p4 /mnt
[Petar@batman ~]$ sudo umount /mnt
[Petar@batman ~]$ sudo dmesg | grep -i dirty
[Petar@batman ~]$ sudo journalctl | grep -i dirty
Dez 20 01:19:46 batman kernel: FAT-fs (sda2): unable to read boot sector to mark fs as dirty

Offline

#16 2022-12-22 01:28:38

alwaysthesun
Member
Registered: 2022-12-18
Posts: 7

Re: Windows installion is missing in GRUB

Head_on_a_Stick wrote:

So did grub-mkconfig find bootmgfw.efi and add a menu entry to /boot/grub/grub.cfg? Is bootmgfw.efi present on /dev/nvme0n1p1?

bootmgfw.efi is located at /dev/nvme0n1p1/EFI/Microsoft/Boot/bootmgfw.efi

Head_on_a_Stick wrote:

That seems to suggest that Windows isn't installed in UEFI mode, which shouldn't be that case for a GPT disk. Can you confirm?

It's a UEFI Firmware and not the old BIOS. CSM Mode is disabled and was disabled the whole time.

[Petar@batman ~]$ sudo fdisk -l /dev/nvme0n1
[sudo] Passwort für Petar: 
Festplatte /dev/nvme0n1: 232,89 GiB, 250059350016 Bytes, 488397168 Sektoren
Festplattenmodell: KINGSTON SNVS250G                       
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
Festplattenbezeichnungstyp: gpt
Festplattenbezeichner: 9110B861-CFE5-4089-8E82-EBE859384F15

Gerät             Anfang      Ende  Sektoren  Größe Typ
/dev/nvme0n1p1      2048    206847    204800   100M EFI-System
/dev/nvme0n1p2    206848    239615     32768    16M Microsoft reserviert
/dev/nvme0n1p3    239616 277409592 277169977 132,2G Microsoft Basisdaten
/dev/nvme0n1p4 277409792 278527999   1118208   546M Windows-Wiederherstellungsum
/dev/nvme0n1p5 278528000 279142399    614400   300M EFI-System
/dev/nvme0n1p6 279142400 488396799 209254400  99,8G Linux-Dateisystem

Last edited by alwaysthesun (2022-12-22 01:30:45)

Offline

#17 2022-12-22 02:23:43

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 7,127

Re: Windows installion is missing in GRUB

You still have two EFI partitions which is most unwise.

alwaysthesun wrote:
Gerät             Anfang      Ende  Sektoren  Größe Typ
/dev/nvme0n1p1      2048    206847    204800   100M EFI-System
...
/dev/nvme0n1p5 278528000 279142399    614400   300M EFI-System
...
seth wrote:

The lsblk output looks like
...
b) you've two EFI partitions? (nvme0n1p1 & nvme0n1p5)
...
The latter is not recommended at all, https://wiki.archlinux.org/title/Dual_b … FI_systems

An additional EFI system partition should not be created, as it may prevent Windows from booting … Simply mount the existing partition.


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#18 2022-12-22 07:26:59

seth
Member
Registered: 2012-09-03
Posts: 35,051

Re: Windows installion is missing in GRUB

That aside, there's no problem when mounting w/ ntfs3 - installing ntfs-3g is coincidental and not the salvating move.

It might have been necessary to mount the windows partition, though (possibly b/c of the 2nd efi)

Edit: you might want to force-default to ntfs3, though.
https://wiki.archlinux.org/title/NTFS#E … d_to_mount

Last edited by seth (2022-12-22 07:29:08)

Offline

Board footer

Powered by FluxBB