You are not logged in.

#1 2023-01-08 13:38:46

u21124
Member
Registered: 2023-01-08
Posts: 3

Sound works only the first time on MSI Katana laptop

I recently installed Arch Linux on MSI Katana laptop. The sound chip in this laptop, according to lspci:

00:1f.3 Multimedia audio controller: Intel Corporation Tiger Lake-H HD Audio Controller (rev 11)
        DeviceName: Onboard - Sound
        Subsystem: Micro-Star International Co., Ltd. [MSI] Device 1357
        Flags: bus master, fast devsel, latency 32, IRQ 161
        Memory at 6013148000 (64-bit, non-prefetchable) [size=16K]
        Memory at 6013000000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: [50] Power Management version 3
        Capabilities: [80] Vendor Specific Information: Len=14 <?>
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Kernel driver in use: sof-audio-pci-intel-tgl
        Kernel modules: snd_hda_intel, snd_sof_pci_intel_tgl

If I run `mplayer some.movie.avi` after reboot sound works. If I quit mplayer and then run it again, no sound in it, and also in browser. Until the next reboot.

Offline

#2 2023-01-08 16:26:12

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 18,209

Re: Sound works only the first time on MSI Katana laptop

Post

sudo fuser -v /dev/snd/"

while the issue happens

Offline

#3 2023-01-09 10:26:59

u21124
Member
Registered: 2023-01-08
Posts: 3

Re: Sound works only the first time on MSI Katana laptop

Did you mean `fuser -v /dev/snd/*`? It shows the same as the first time (when sound works):

                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  ilya        737 F.... mate-settings-d
                     ilya        788 F.... mate-volume-con
/dev/snd/pcmC0D0p:   ilya        962 F...m mplayer

Offline

#4 2023-01-09 14:31:43

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 18,209

Re: Sound works only the first time on MSI Katana laptop

Yes I meant that sorry, If you quit does the mplayer disappear and relevantly reappear but the sound doesn't? There's some known problems in that regard with the current LTS kernel, if you're running that, try the current stable release.

Offline

#5 2023-01-09 16:15:24

u21124
Member
Registered: 2023-01-08
Posts: 3

Re: Sound works only the first time on MSI Katana laptop

Thank you, after switching from linux-lts to linux 6.1.4 problem solved.

Offline

Board footer

Powered by FluxBB