You are not logged in.

#1 2023-01-09 19:53:26

Registered: 2018-08-28
Posts: 11

[SOLVED] Touchpad recognized as PS/2 Generic Mouse

Hello everyone,
I'm a new user to linux and I've been trying off and on for a couple of months now to get gestures like two finger scrolling to work on my laptop's touchpad. In that time I've dug through just about every message board post (relevant or not) looking for information that could help me understand how to set up my touchpad. In the time that I've spent looking over this I've learned that this is one of the most difficult questions to answer for linux users, but I really hoped that this might serve as a waypoint for an updated guide in 2023 and that by consulting you, the Arch gurus I might be able to finally figure out once and for all what standard protocol is for setting up my touchpad. I recognize that this is similar to some questions other users have asked but didn't feel that it was a duplicate after following along with the steps those posts suggested and still not arriving at a solution.
I'm using a Dell Inspiron 5515, my xinput reads as the following:

⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ DELL0A78:00 27C6:0D42 Touchpad              id=12    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                          id=15    [slave  pointer  (2)]
⎜   ↳ DELL0A78:00 27C6:0D42 Mouse                 id=11    [slave  pointer  (2)]
⎜   ↳ 04F31234:00 04F3:2C6B                       id=10    [slave  pointer  (2)]

And there it is; My touchpad shows up but doesn't appear to be functioning and instead is being caught as a PS/2 Generic mouse. I've tried using numerous different packages to enable gesture support and to interpret my touchpad as more than just a mouse to no avail, packages such as libinput, libinput-gestures, and synaptics, but I've found that my attempts at following the Arch wiki setup guide for each of these packages still has not enabled me to get this functionality working. The Synaptics/Gestures entry under the wiki states that it's been deprecated but that there may still be reasons to use it, one being for laptop gestures. More reading has suggested that because my laptop supports Microsoft's i2c-hid protocol that this is the culprit of the numerous problems that I've had setting up gestures to work with my laptop.
Because most of the information that I'm finding is outdated I thought this question deserved to be asked again as an updated guide: What is the current standard/working protocol for setting up new touchpads for use with gestures? Is synaptics still recommended for laptop gesture control or is libinput the best and current solution now that synaptics has been deprecated? How do i2c-hid protocols affect the setup of new touchpads? I would appreciate any information anyone has on this topic through either your own experience or what you can find because I feel that I've exhausted my ability to solve this issue, and I hope that the collective sum of our knowledge here will serve as a waypoint for others so no one else has to spend months searching for answers to set this up anymore. Thank you all in advance.

Last edited by 173brian (2023-01-14 05:41:47)


#2 2023-01-14 05:38:19

Registered: 2018-08-28
Posts: 11

Re: [SOLVED] Touchpad recognized as PS/2 Generic Mouse

After several months I've gotten it to work. In case anyone else stumbles upon this thread I wanted to detail what helped me figure out what was going on.
I couple days ago I stumbled upon another post that mentioned reloading the psmouse module that my touchpad was being caught as. When I would utilize the command:
sudo modprobe -rv psmouse; sudo modprobe -v psmouse
I realized that my gesture control worked for a fraction of a second before failing again. I had read in several places about disabling various drivers through the 'blacklist' command in the modprobe.conf. I had tried disabling my I2C_HID drivers, which weren't the source of the problem, and eventually tried blacklisting this psmouse module I had worked with up above. I had tried turning off this module before in my session which caused the mouse to stop working altogether, but when I rebooted after using this blacklist command I found that my touchpad finally worked! I'm using the xf86-input-synaptics package and blacklisting the module that my mouse was being loaded as, which seems to allow the kernel drivers for my touchpad to load correctly. This issue turned out to be one of figuring out what the right module to disable was.
If anyone should stumble upon this thread looking for help I hope this is of use to you: Find the drivers that are being loaded on your touchpad related to the xinput name of your input device that shouldn't exist (PS/2 Mouse for me instead of my touchpad), and blacklist the driver to enable the correct loading of your touchpad.


Board footer

Powered by FluxBB