You are not logged in.

#1 2023-01-13 16:11:50

stonebrakermatt
Member
Registered: 2023-01-09
Posts: 4

Wifi not working on fresh Arch install

I just did a fresh Arch install. Wifi works fine on the Arch ISO, but the wifi card is not recognized in my install.

ip link

does not show my Wifi card. However,

lspci

shows my network adapter just fine. I notice here that the iwlwifi kernel module is not loaded. When I try to manually load this kernel module, it says it's not the right version for my kernel. My kernel modules are for 6.1.5-arch2-1, while my kernel is 6.1.4-arch1-1. This is a fresh install; I am baffled that such an issue would arise right out of the box. I don't know how to install the correct version kernel modules.

Any help would be appreciated, and I'm happy to share the output of any commands to provide more information. Thanks!

Offline

#2 2023-01-13 16:23:17

Scimmia
Fellow
Registered: 2012-09-01
Posts: 10,046

Re: Wifi not working on fresh Arch install

Did you install linux-firmware? Did you reboot after updating the kernel?

Last edited by Scimmia (2023-01-13 16:23:57)

Offline

#3 2023-01-13 16:25:11

stonebrakermatt
Member
Registered: 2023-01-09
Posts: 4

Re: Wifi not working on fresh Arch install

Scimmia wrote:

Did you install linux-firmware? Did you reboot after updating the kernel?

Yes and yes.

Offline

#4 2023-01-13 16:27:26

Scimmia
Fellow
Registered: 2012-09-01
Posts: 10,046

Re: Wifi not working on fresh Arch install

If you rebooted and you're still on 6.1.4-arch1-1, then you didn't have the /boot partition mounted when you updated. Either that or you did have it mounted but your bootloader isn't using it.

Offline

#5 2023-01-13 16:32:14

stonebrakermatt
Member
Registered: 2023-01-09
Posts: 4

Re: Wifi not working on fresh Arch install

I'm pretty sure I had it mounted; maybe the bootloader isn't using it. I'll try some things and get back to you.

Offline

#6 2023-01-13 21:27:55

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,873
Website

Re: Wifi not working on fresh Arch install

Please post the content of /etc/fstab and the full output of

lsblk -f

The bootloader configuration would also be useful.

Offline

Board footer

Powered by FluxBB