You are not logged in.

#1 2023-01-13 23:19:10

commiethecat
Member
Registered: 2022-12-12
Posts: 4

Can't install some packages using yay

I am trying to install the package mindustry, the same problem happens with the package mp3blaster. here is the output of trying to install mindustry

archlinux@archlinux ~/yay (master)> yay -S mindustry
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur:1]  mindustry-1:7.0_141.2-1

  1 mindustry                                (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [ I ]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: PKGBUILD up to date, Skipping (1/0): mindustry
  1 mindustry                                (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [ I ]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: (1/1) Parsing SRCINFO: mindustry
==> Making package: mindustry 1:7.0_141.2-1 (Sat 14 Jan 2023 01:08:43 AM EET)
==> Retrieving sources...
  -> Found mindustry-141.2.tar.gz
  -> Found mindustry.desktop
  -> Found mindustry.sh
  -> Found mindustry-server.desktop
  -> Found mindustry-server.sh
==> Validating source files with sha256sums...
    mindustry-141.2.tar.gz ... Passed
    mindustry.desktop ... Passed
    mindustry.sh ... Passed
    mindustry-server.desktop ... Passed
    mindustry-server.sh ... Passed
==> Making package: mindustry 1:7.0_141.2-1 (Sat 14 Jan 2023 01:08:45 AM EET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found mindustry-141.2.tar.gz
  -> Found mindustry.desktop
  -> Found mindustry.sh
  -> Found mindustry-server.desktop
  -> Found mindustry-server.sh
==> Validating source files with sha256sums...
    mindustry-141.2.tar.gz ... Passed
    mindustry.desktop ... Passed
    mindustry.sh ... Passed
    mindustry-server.desktop ... Passed
    mindustry-server.sh ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting mindustry-141.2.tar.gz with bsdtar
==> Sources are ready.
==> Making package: mindustry 1:7.0_141.2-1 (Sat 14 Jan 2023 01:08:49 AM EET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Removing existing $pkgdir/ directory...
==> Starting build()...
To honour the JVM settings for this build a single-use Daemon process will be forked. See https://docs.gradle.org/7.5.1/userguide/gradle_daemon.html#sec:disabling_the_daemon.
Daemon will be stopped at the end of the build 

FAILURE: Build failed with an exception.

* What went wrong:
Could not open settings generic class cache for settings file '/home/archlinux/.cache/yay/mindustry/src/Mindustry-141.2/settings.gradle' (/home/archlinux/.gradle/caches/7.5.1/scripts/clf09az73rlspqa616etzu9h7).
> BUG! exception in phase 'semantic analysis' in source unit '_BuildScript_' Unsupported class file major version 63

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 4s
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: mindustry

can anyone help me to fix it? thanks in advance to anyone who answers!

Offline

#2 2023-01-13 23:43:47

loqs
Member
Registered: 2014-03-06
Posts: 15,623

Re: Can't install some packages using yay

For mindustry change the version requirement of both java-runtime and java-environment to 17 in the PKGBUILD.
mpf3blaster has a completely different issue:

nmixer.cc: In member function ‘void NMixer::DrawScrollbar(short int, int)’:
nmixer.cc:219:26: error: format not a string literal and no format arguments [-Werror=format-security]
  219 |                 mvwprintw(mixwin, my_y - 1, my_x, (char*)source);
      |                 ~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I suggest you report that to the package maintainer.

Offline

#3 2023-01-14 00:25:30

commiethecat
Member
Registered: 2022-12-12
Posts: 4

Re: Can't install some packages using yay

Sorry, I'm not that experienced, could you please instruct me on how I can access that and change those? thanks in advance!
edit: either way, I'm happy that this is not a general yay error, and only localised to these specific packages.

Last edited by commiethecat (2023-01-14 00:37:21)

Offline

#4 2023-01-14 00:38:52

Adriik
Member
From: Argentina
Registered: 2022-03-10
Posts: 107

Re: Can't install some packages using yay

Edit the pkgbuild and change what loqs says.
It's better if you use makepkg instead of yay or some aur helper. So you learn how building packages from aur works.
Then if you want, use an aur helper. I don't know, but I think yay before building the package, it asks you if you want to edit the pkgbuild.

Last edited by Adriik (2023-01-16 03:41:31)


I'm just someone. Please use [code] [/code] tags.
Command cheatsheetCommand not found?
If I write something wrong in English, please correct me.
♪ Muchachos, ahora nos volvimos a ilusionar ★★★ ♪

Offline

#5 2023-01-14 03:04:56

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,993

Re: Can't install some packages using yay

Moving to AUR issues


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#6 2023-01-14 18:29:17

commiethecat
Member
Registered: 2022-12-12
Posts: 4

Re: Can't install some packages using yay

I have git cloned mindustry and looked in the pkgbuild but I don't know how to read this stuff so I don't know where I can change the version of java_runtime and java_environment

Offline

#7 2023-01-14 21:18:25

loqs
Member
Registered: 2014-03-06
Posts: 15,623

Re: Can't install some packages using yay

The format for PKGBUILD is covered in PKGBUILD.
In this case

depends=("java-runtime>=8" "sh" "hicolor-icon-theme")
makedepends=("java-environment>=16" "libicns" "alsa-lib")

Means there is a dependency on java-runtime with a version greater than or equal to 8 and there is a makedepends on java-environment greater than or equal to 16.

depends=("java-runtime=17" "sh" "hicolor-icon-theme")
makedepends=("java-environment=17" "libicns" "alsa-lib")

Now they both require version 17.  If after that change the build still fails,  it is probably because you have a different default version of java set.  Then try building it in a clean chroot.

Offline

#8 2023-01-15 11:52:29

commiethecat
Member
Registered: 2022-12-12
Posts: 4

Re: Can't install some packages using yay

Well, I have changed those and the output was

archlinux@archlinux ~/mindustry (master)> makepkg -si
==> Making package: mindustry 1:7.0_141.2-1 (Sun 15 Jan 2023 01:34:33 PM EET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found mindustry-141.2.tar.gz
  -> Found mindustry.desktop
  -> Found mindustry.sh
  -> Found mindustry-server.desktop
  -> Found mindustry-server.sh
==> Validating source files with sha256sums...
    mindustry-141.2.tar.gz ... Passed
    mindustry.desktop ... Passed
    mindustry.sh ... Passed
    mindustry-server.desktop ... Passed
    mindustry-server.sh ... Passed
==> Extracting sources...
  -> Extracting mindustry-141.2.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...
To honour the JVM settings for this build a single-use Daemon process will be forked. See https://docs.gradle.org/7.5.1/userguide/gradle_daemon.html#sec:disabling_the_daemon.
Daemon will be stopped at the end of the build 

FAILURE: Build failed with an exception.

* What went wrong:
Could not open settings generic class cache for settings file '/home/archlinux/mindustry/src/Mindustry-141.2/settings.gradle' (/home/archlinux/.gradle/caches/7.5.1/scripts/clf09az73rlspqa616etzu9h7).
> BUG! exception in phase 'semantic analysis' in source unit '_BuildScript_' Unsupported class file major version 63

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 4s
==> ERROR: A failure occurred in build().
    Aborting... 

Then I followed the instructions for the clean chroot from the link you provided and the output was

archlinux@archlinux ~/mindustry (master)> makechrootpkg -c -r $CHROOT
==> Synchronizing chroot copy [/home/archlinux/chroot/root] -> [archlinux]...done
==> Making package: mindustry 1:7.0_141.2-1 (Sun Jan 15 13:41:20 2023)
==> Retrieving sources...
  -> Found mindustry-141.2.tar.gz
  -> Found mindustry.desktop
  -> Found mindustry.sh
  -> Found mindustry-server.desktop
  -> Found mindustry-server.sh
==> Validating source files with sha256sums...
    mindustry-141.2.tar.gz ... Passed
    mindustry.desktop ... Passed
    mindustry.sh ... Passed
    mindustry-server.desktop ... Passed
    mindustry-server.sh ... Passed
==> Making package: mindustry 1:7.0_141.2-1 (Sun Jan 15 13:41:23 2023)
==> Checking runtime dependencies...
==> Installing missing dependencies...
:: There are 2 providers available for java-runtime>=17:
:: Repository extra
   1) jre-openjdk  2) jre17-openjdk

Enter a number (default=1): 
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency

Packages (15) freetype2-2.12.1-1  giflib-5.2.1-2  graphite-1:1.3.14-2  harfbuzz-6.0.0-1  java-runtime-common-3-3  jre-openjdk-headless-19.0.1.u10-3
              lcms2-2.14-2  libjpeg-turbo-2.1.4-2  libnet-1:1.1.6-1  libpng-1.6.39-1  libtiff-4.5.0-1  nspr-4.35-1  nss-3.87-1  hicolor-icon-theme-0.17-2
              jre-openjdk-19.0.1.u10-3

Total Installed Size:  202.41 MiB

:: Proceed with installation? [Y/n] 
(15/15) checking keys in keyring                                                              [#######################################################] 100%
(15/15) checking package integrity                                                            [#######################################################] 100%
(15/15) loading package files                                                                 [#######################################################] 100%
(15/15) checking for file conflicts                                                           [#######################################################] 100%
(15/15) checking available disk space                                                         [#######################################################] 100%
:: Processing package changes...
( 1/15) installing java-runtime-common                                                        [#######################################################] 100%
For the complete set of Java binaries to be available in your PATH,
you need to re-login or source /etc/profile.d/jre.sh
Please note that this package does not support forcing JAVA_HOME as former package java-common did
( 2/15) installing nspr                                                                       [#######################################################] 100%
( 3/15) installing nss                                                                        [#######################################################] 100%
( 4/15) installing libjpeg-turbo                                                              [#######################################################] 100%
Optional dependencies for libjpeg-turbo
    java-runtime>11: for TurboJPEG Java wrapper [pending]
( 5/15) installing libtiff                                                                    [#######################################################] 100%
Optional dependencies for libtiff
    freeglut: for using tiffgt
( 6/15) installing lcms2                                                                      [#######################################################] 100%
( 7/15) installing libnet                                                                     [#######################################################] 100%
( 8/15) installing libpng                                                                     [#######################################################] 100%
( 9/15) installing graphite                                                                   [#######################################################] 100%
(10/15) installing harfbuzz                                                                   [#######################################################] 100%
Optional dependencies for harfbuzz
    cairo: hb-view program
    chafa: hb-view program
(11/15) installing freetype2                                                                  [#######################################################] 100%
(12/15) installing jre-openjdk-headless                                                       [#######################################################] 100%
Optional dependencies for jre-openjdk-headless
    java-rhino: for some JavaScript support
(13/15) installing giflib                                                                     [#######################################################] 100%
(14/15) installing jre-openjdk                                                                [#######################################################] 100%
when you use a non-reparenting window manager,
set _JAVA_AWT_WM_NONREPARENTING=1 in /etc/profile.d/jre.sh
Optional dependencies for jre-openjdk
    alsa-lib: for basic sound support
    gtk2: for the Gtk+ 2 look and feel - desktop usage
    gtk3: for the Gtk+ 3 look and feel - desktop usage
(15/15) installing hicolor-icon-theme                                                         [#######################################################] 100%
==> Checking buildtime dependencies...
==> Installing missing dependencies...
:: There are 2 providers available for java-environment>=17:
:: Repository extra
   1) jdk-openjdk  2) jdk17-openjdk

Enter a number (default=1): 
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency

Packages (35) alsa-topology-conf-1.2.5.1-1  alsa-ucm-conf-1.2.8-1  default-cursors-2-1  freeglut-3.4.0-1  glu-9.0.2-3  jasper-4.0.0-1
              java-environment-common-3-3  libdrm-2.4.114-1  libedit-20210910_3.1-2  libglvnd-1.6.0-1  libomxil-bellagio-0.9.3-4  libpciaccess-0.17-1
              libunwind-1.6.2-2  libx11-1.8.3-5  libxau-1.0.11-1  libxcb-1.15-2  libxdamage-1.1.6-1  libxdmcp-1.1.4-1  libxext-1.3.5-1  libxfixes-6.0.0-2
              libxi-1.8-2  libxrandr-1.5.3-1  libxrender-0.9.11-1  libxshmfence-1.3.2-1  libxxf86vm-1.1.5-1  llvm-libs-14.0.6-4
              lm_sensors-1:3.6.0.r41.g31d1f125-2  mesa-22.3.3-1  vulkan-icd-loader-1.3.235-1  wayland-1.21.0-2  xcb-proto-1.15.2-2  xorgproto-2022.2-1
              alsa-lib-1.2.8-1  jdk-openjdk-19.0.1.u10-3  libicns-0.8.1-10

Total Installed Size:  309.90 MiB

:: Proceed with installation? [Y/n] 
(35/35) checking keys in keyring                                                              [#######################################################] 100%
(35/35) checking package integrity                                                            [#######################################################] 100%
(35/35) loading package files                                                                 [#######################################################] 100%
(35/35) checking for file conflicts                                                           [#######################################################] 100%
(35/35) checking available disk space                                                         [#######################################################] 100%
:: Processing package changes...
( 1/35) installing java-environment-common                                                    [#######################################################] 100%
( 2/35) installing jdk-openjdk                                                                [#######################################################] 100%
( 3/35) installing xcb-proto                                                                  [#######################################################] 100%
( 4/35) installing libxdmcp                                                                   [#######################################################] 100%
( 5/35) installing libxau                                                                     [#######################################################] 100%
( 6/35) installing libxcb                                                                     [#######################################################] 100%
( 7/35) installing xorgproto                                                                  [#######################################################] 100%
( 8/35) installing libx11                                                                     [#######################################################] 100%
( 9/35) installing libxext                                                                    [#######################################################] 100%
(10/35) installing libxi                                                                      [#######################################################] 100%
(11/35) installing libxrender                                                                 [#######################################################] 100%
(12/35) installing libxrandr                                                                  [#######################################################] 100%
(13/35) installing libpciaccess                                                               [#######################################################] 100%
(14/35) installing libdrm                                                                     [#######################################################] 100%
(15/35) installing default-cursors                                                            [#######################################################] 100%
Optional dependencies for default-cursors
    adwaita-cursors: default cursor theme
(16/35) installing wayland                                                                    [#######################################################] 100%
(17/35) installing libxxf86vm                                                                 [#######################################################] 100%
(18/35) installing libxfixes                                                                  [#######################################################] 100%
(19/35) installing libxdamage                                                                 [#######################################################] 100%
(20/35) installing libxshmfence                                                               [#######################################################] 100%
(21/35) installing libomxil-bellagio                                                          [#######################################################] 100%
(22/35) installing libunwind                                                                  [#######################################################] 100%
(23/35) installing libedit                                                                    [#######################################################] 100%
(24/35) installing llvm-libs                                                                  [#######################################################] 100%
(25/35) installing lm_sensors                                                                 [#######################################################] 100%
Optional dependencies for lm_sensors
    rrdtool: for logging with sensord
    perl: for sensor detection and configuration convert [installed]
(26/35) installing vulkan-icd-loader                                                          [#######################################################] 100%
Optional dependencies for vulkan-icd-loader
    vulkan-driver: packaged vulkan driver
(27/35) installing mesa                                                                       [#######################################################] 100%
Optional dependencies for mesa
    opengl-man-pages: for the OpenGL API man pages
    mesa-vdpau: for accelerated video playback
    libva-mesa-driver: for accelerated video playback
(28/35) installing libglvnd                                                                   [#######################################################] 100%
(29/35) installing freeglut                                                                   [#######################################################] 100%
(30/35) installing glu                                                                        [#######################################################] 100%
(31/35) installing jasper                                                                     [#######################################################] 100%
Optional dependencies for jasper
    jasper-doc: documentation
(32/35) installing libicns                                                                    [#######################################################] 100%
(33/35) installing alsa-topology-conf                                                         [#######################################################] 100%
(34/35) installing alsa-ucm-conf                                                              [#######################################################] 100%
(35/35) installing alsa-lib                                                                   [#######################################################] 100%
==> Retrieving sources...
  -> Found mindustry-141.2.tar.gz
  -> Found mindustry.desktop
  -> Found mindustry.sh
  -> Found mindustry-server.desktop
  -> Found mindustry-server.sh
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
  -> Extracting mindustry-141.2.tar.gz with bsdtar
==> Starting build()...
Downloading https://services.gradle.org/distributions/gradle-7.5.1-bin.zip
...........10%............20%...........30%............40%...........50%............60%...........70%............80%...........90%............100%

Welcome to Gradle 7.5.1!

Here are the highlights of this release:
 - Support for Java 18
 - Support for building with Groovy 4
 - Much more responsive continuous builds
 - Improved diagnostics for dependency resolution

For more details see https://docs.gradle.org/7.5.1/release-notes.html

To honour the JVM settings for this build a single-use Daemon process will be forked. See https://docs.gradle.org/7.5.1/userguide/gradle_daemon.html#sec:disabling_the_daemon.
Daemon will be stopped at the end of the build 

FAILURE: Build failed with an exception.

* What went wrong:
Could not open settings generic class cache for settings file '/build/mindustry/src/Mindustry-141.2/settings.gradle' (/build/.gradle/caches/7.5.1/scripts/clf09az73rlspqa616etzu9h7).
> BUG! exception in phase 'semantic analysis' in source unit '_BuildScript_' Unsupported class file major version 63

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 8s
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Build failed, check /home/archlinux/chroot/archlinux/build 

Offline

#9 2023-01-15 13:25:38

loqs
Member
Registered: 2014-03-06
Posts: 15,623

Re: Can't install some packages using yay

Please post the PKGBUILD with the changes you made.

Offline

#10 2023-01-15 13:26:03

seth
Member
Registered: 2012-09-03
Posts: 34,931

Re: Can't install some packages using yay

:: There are 2 providers available for java-environment>=17:
:: Repository extra
   1) jre-openjdk  2) jre17-openjdk
…
jre-openjdk-19.0.1.u10-3
loqs wrote:
depends=("java-runtime=17" "sh" "hicolor-icon-theme")
makedepends=("java-environment=17" "libicns" "alsa-lib")

Now they both require version 17.

(( 17 == 19 )) && echo "17 and 19 are equal" || echo "no, they're not"

Last edited by seth (2023-01-15 13:26:20)

Offline

Board footer

Powered by FluxBB