You are not logged in.

#1 2023-02-20 01:17:19

Registered: 2023-01-04
Posts: 2

I installed linux-zen and now it won't boot

I saw someone mention Waydroid yesterday and decided to give it a go.  ArchWiki said it required a kernel with Android support enabled and recommended linux-zen if I didn't want to compile one myself.  Thinking nothing of it, and secure in the knowledge that I could simply revert to my previous kernel if things went sideways, I installed the `linux-zen` package and rebooted.

linux-zen failed to locate my root partition (I use btrfs with a mounted subvolume for backup purposes) and tried to drop me to a root shell, but my keyboard was unresponsive.  I held down the power button and booted my previous kernel, which failed to mount my /boot partition and then refused to drop me to a root shell because the root account was disabled.  After a large deal of fiddling with my Arch installation media, including trying to reinstall `linux` (which produced an ominous error message but seemed to work okay) and running `pacman -Syu`, neither of which made any change, I set a password on the root account, booted the `linux` kernel (the keyboard was still unresponsive in linux-zen's root shell after I had done that), entered the root shell, tried to `mount /boot`, and received the error message `unknown filesystem type vfat`.  So it had forgotten how to mount a fatfs.  Worrying.

Unsure what else to do, I commented out the /boot line from fstab and exited the root shell.  The system booted as normal and I made it to a desktop, with the exception that Wi-Fi, Bluetooth, my webcam, and my laptop trackpad (possibly others -- I didn't check) had stopped working.  I suspect this is because installing `linux-zen` overwrote the kernel modules that make those things work with Zen-specific versions, but I have no way to verify this and wouldn't know how to fix it if it was in fact the problem.  I've reinstalled the `linux` package several times, both booted from the `linux` kernel on my SSD and from the live installation image, to no avail.  I also uninstalled the `linux-zen` package while booted from the SSD, which seemingly had no effect (it was still on the EFI system partition and rEFInd still defaulted to booting it) as the /boot partition (which is my EFI system partition) wasn't mounted when I ran sudo pacman -R.

Also of note is that while I was arch-chrooted into my root partition from the live media trying to figure out why /boot wasn't mounting the first time, I noticed that the /boot directory had files in it before I typed mount /boot, but it let me mount it anyway.  I'm not sure why, but my best guess is that at some point I tried to reinstall the kernel without that partition mounted.  I renamed the /boot directory to boot.old and created a new, empty one.

I'm now staring down the shell of the live image with my rootfs mounted, at a complete loss as to what I'm supposed to do.

I no longer care about getting Linux Zen working.  I have learned a valuable lesson in making backups before making wide system changes like replacing the kernel.  Can someone please help me get my system back to how it was?

Last edited by wallefan (2023-02-20 01:32:44)


#2 2023-02-20 07:22:23

Registered: 2019-05-10
Posts: 637

Re: I installed linux-zen and now it won't boot

wallefan wrote:

Unsure what else to do, I commented out the /boot line from fstab and exited the root shell.  The system booted as normal and I made it to a desktop


I don't think something went wrong because of linux-zen, that0s unlikely...
What's your configuration?

# cat /etc/fstab
# cat /etc/default/grub
# cat /proc/cmdline
# mount
# btrfs subvolume list -p /
WIKI wrote:

Changing the default subvolume with btrfs subvolume set-default will make the top level of the filesystem inaccessible, except by use of the subvol=/ or subvolid=5 mount options

( … sub-volume)

<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.


#3 2023-02-26 00:05:43

Registered: 2023-01-04
Posts: 2

Re: I installed linux-zen and now it won't boot

I fixed it.  Somehow or other, my kernel version (6.1.11) had gotten out of sync with my modules version in /lib/modules (6.1.12).  I ran `pacman -S linux` from the live image (which I swore I had already done -- maybe /boot wasn't mounted the other times?) and rebooted and it started up just fine.  Weird.


Board footer

Powered by FluxBB