You are not logged in.

#1 2023-03-09 16:42:22

Registered: 2012-02-08
Posts: 26

[SOLVED] Gnome / Wayland session freezing upon launching […]

I'm very puzzled about my Gnome/Wayland session freezing when I launch either `gedit` or `qalculate-gtk`. No other application seems affected.

This is a journal log from a boot where I

  • logged into gnome+wayland, opened a gnome-terminal, launched gedit > gedit.log 2> gedit.err from there -> gnome session freezes.

  • switched to gdm on tty1 and rebooted from here

On the next boot I executed

$ sudo journaltcl -b -1

which gave the following output

There is nothing in there that looks suspicious to me.
The gedit.log and gedit.err are empty.

coredumpctl only lists core dumps of baloo which happen independently of the sesison freeze.

I can reproduce the same session freeze with linux-lts 6.1.15-1 or when launching qalculate-gtk 4.6.0-1
However, launching gedit or qalculate-gtk from a gnome/xorg session works without any issue.

Can anyone help me troubleshoot this?

Versions possibly relevant for the linked journal:
gedit 44.2-1
gnome-shell 1:43.3-2
linux-zen 6.2.2-zen1-1
mesa 22.3.6-1

AMD Ryzen 7 2700X
AMD Radeon RX 6700 XT

Last edited by adoa (2023-03-15 16:42:07)


#2 2023-03-15 16:41:26

Registered: 2012-02-08
Posts: 26

Re: [SOLVED] Gnome / Wayland session freezing upon launching […]

After yet another application started to cause similar trouble, I dug a bit deeper. Especially trying to understand why it still worked on Xorg. I uninstalled the amdgpu drivers (which for some reason were still on my system) and removed the according xorg conf file (which should not matter for wayland sesisons). In a working gnome/xorg session I also once launched every application and changed their positioning.

I'm not sure exactly which action ultimately fixed it, but now everything works as expected under gnome/wayland. So most likely a misconfiguration on my end.


Board footer

Powered by FluxBB