You are not logged in.

#1 2023-03-12 17:49:22

Registered: 2023-02-20
Posts: 13

[SOLVED]mythplugins-mytharchive depends on obsolete package?

I see that the Ubuntu mythmusic depends on:

The AUR packagemythplugins-mytharchive depends on qtwebkit (not listed here), which is apparently based on QT4 and no longer builds.  I verified the comments about this package that it does not build:

Does that just mean the AUR package for mythplugins-mytharchive is out of date?

I installed  qt5-webkit 5.212.0alpha4-18.

But I still see in the mythplugin build:

==> Starting build()...
MythBrowser requires QtWebkit.
MythMusic requires QtWebkit.

Configuration settings:

        Qt minimum     5.9
        Qt installed   5.15.8
        qmake          /usr/bin/qmake-qt5

        MythArchive    plugin will be built
        MythBrowser    plugin will not be built
        MythGame       plugin will be built
        MythMusic      plugin will not be built

Last edited by klugja (2023-03-14 04:41:21)


#2 2023-03-12 20:06:28

Registered: 2014-03-06
Posts: 17,114

Re: [SOLVED]mythplugins-mytharchive depends on obsolete package?

You need to build mythtv with qt5-webkit installed so it is built with webkit support then the check … igure#L575 will pass.
mythplugins has missing makedepends on git and python-mysqlclient in addition to qt5-webkit

Last edited by loqs (2023-03-12 23:44:28)


#3 2023-03-14 04:40:23

Registered: 2023-02-20
Posts: 13

Re: [SOLVED]mythplugins-mytharchive depends on obsolete package?

I rebuilt and reinstalled mythtv with qt5-webkit installed, then got into more dependencies with mythplugins.

The last one was zoneinfo, which alone has a large dependency tree.

Thanks, mythmusic is now working.  I'll check the rest later.

This could use a wiki, or a greatly expanded mythtv wiki.

qt5-webkit is not mentioned.

Last edited by klugja (2023-03-14 04:43:27)


Board footer

Powered by FluxBB