You are not logged in.

#1 2023-03-18 16:25:27

Registered: 2023-03-18
Posts: 2

[Solved] systemctl suspend, hibernate, and hybrid-sleep all fail

I am trying to make my system suspend, but all of the


commands fail. If I try

 systemctl suspend 

I get a black screen on my monitors, fans and LEDs in my PC are still on, and the system is completely unresponsive. Holding down the power button to power down my PC doesn't work, and the reset button also does nothing, too. The only way I found to get back into to my PC is to flip the power switch on my PSU to power down my machine and then just power it on normally.

 systemctl hybrid-sleep 

results in the exact same thing, and

 systemctl hibernate 

just causes my computer to reboot.

Any suggestions?

Arch Linux
Kernel: 6.2.6-zen1-1-zen
linux-firmware version: 20230210.bf4115c-1
Motherboard: Gigabyte B550 Aorus Pro AC
CPU: R7 5800X
GPU: RX 7900 XTX
Mesa version: Mesa 23.1.0-devel (git-b190d08a8a)

Last edited by DoomPenguin (2023-03-26 11:08:48)


#2 2023-03-19 15:12:51

Registered: 2008-10-17
Posts: 23

Re: [Solved] systemctl suspend, hibernate, and hybrid-sleep all fail

Could be related to this:

My workaround for now was to disable the `wakeup` for my touchpad (i2c device). Then it should suspend.

If, after waking up you have a blank screen, switching to another TTY (ctr-alt-f2, ...) and then back again. That works for me until the driver is updated.



#3 2023-03-26 11:08:07

Registered: 2023-03-18
Posts: 2

Re: [Solved] systemctl suspend, hibernate, and hybrid-sleep all fail

I found a solution to this. It turns out that the GPP bridge has been causing this. If I run

$ cat /proc/acpi/wakeup
Device	S-state	  Status   Sysfs node
GP12	  S4	*enabled   pci:0000:00:07.1
GP13	  S4	*enabled   pci:0000:00:08.1
XHC0	  S4	*enabled   pci:0000:0a:00.3
GP30	  S4	*disabled
GP31	  S4	*disabled
PS2K	  S3	*disabled
GPP0	  S4	*enabled  pci:0000:00:01.1
GPP8	  S4	*enabled  pci:0000:00:03.1
SWUS	  S4	*enabled   pci:0000:06:00.0
SWDS	  S4	*enabled   pci:0000:07:00.0
PTXH	  S4	*enabled   pci:0000:02:00.0
PT20	  S4	*disabled
PT24	  S4	*disabled
PT26	  S4	*disabled
PT27	  S4	*disabled
PT28	  S4	*enabled   pci:0000:03:08.0
PT29	  S4	*enabled   pci:0000:03:09.0

I see that GPP0 and GPP8 can wake up my system. You can toggle these between enabled and disabled by simply running

$ sudo sh -c "echo GPP0 > /proc/acpi/wakeup"
$ sudo sh -c "echo GPP8 > /proc/acpi/wakeup"

This fixed the issue for me. To make this persistent, I think one should write a systemd service that toggles the problematic device's ability to wake up the computer off on boot.


Board footer

Powered by FluxBB