You are not logged in.

#1 2023-05-05 03:47:09

jorgemota
Member
Registered: 2013-08-12
Posts: 42

[SOLVED] Problem with gcc13 and WebSphere 8.5.5.19

Hi, I upgraded yesterday and got gcc update from 12.2.1.2 to 13.1.1 and now WebSphere fails with a

ADMU0116I: Tool information is being logged in file
           /opt/IBM/WebSphere/AppServer/profiles/AppSrv01/logs/server1/startServer.log
ADMU0128I: Starting tool with the AppSrv01 profile
ADMU3100I: Reading configuration for server: server1
JVMDUMP039I Processing dump event "abort", detail "" at 2023/05/04 21:44:30 - please wait.
JVMDUMP032I JVM requested System dump using '/home/jorge/core.20230504.214430.56004.0001.dmp' in response to an event
JVMPORT030W /proc/sys/kernel/core_pattern setting "|/usr/lib/systemd/systemd-coredump %P %u %g %s %t %c %h" specifies that the core dump is to be piped to an external program.  Attempting to rename either core or core.56117.

JVMDUMP012E Error in System dump: The core file created by child process with pid = 56117 was not found. Expected to find core file with name "/home/jorge/core.56117"
JVMDUMP032I JVM requested Java dump using '/home/jorge/javacore.20230504.214430.56004.0002.txt' in response to an event
/opt/IBM/WebSphere/AppServer/bin/startServer.sh: line 158: 56004 Aborted                 (core dumped) "$JAVA_EXE" "$OSGI_INSTALL" "$OSGI_CFG" $X_ARGS $WAS_DEBUG $CONSOLE_ENCODING $D_ARGS -classpath "$WAS_CLASSPATH" $USER_INSTALL_PROP $JVM_EXTRA_CMD_ARGS com.ibm.ws.bootstrap.WSLauncher $APP_EXT_ID "$CONFIG_ROOT" "$WAS_CELL" "$WAS_NODE" "$@" $WORKSPACE_ROOT_PROP

After a review I found that reinstalling with downgrade Gcc 12.2.X the problem it's gone so I tried to install gcc12 but only found gcc11

Is there any guide I can follow to create a gcc12 package for all computers in my organization to have the 2 versions installed without conflict?

Thanks for your response.

Last edited by jorgemota (2023-05-07 06:05:46)

Offline

#2 2023-05-06 22:05:00

ajgringo619
Member
Registered: 2023-05-06
Posts: 15

Re: [SOLVED] Problem with gcc13 and WebSphere 8.5.5.19

Since there are already gcc10 and gcc11 AUR packages, I'd be willing to bet that a gcc12 version is on the way. I'd consult both of the aforementioned package maintainers, at a minimum you can look at their package builds for a starting point.

Offline

#3 2023-05-06 22:12:41

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,639

Re: [SOLVED] Problem with gcc13 and WebSphere 8.5.5.19

ajgringo619 wrote:

Since there are already gcc10 and gcc11 AUR packages, I'd be willing to bet that a gcc12 version is on the way. I'd consult both of the aforementioned package maintainers, at a minimum you can look at their package builds for a starting point.

Not until it's dropped from the community repo, where it's already packaged (after the OP here).

Offline

#4 2023-05-06 22:51:33

ajgringo619
Member
Registered: 2023-05-06
Posts: 15

Re: [SOLVED] Problem with gcc13 and WebSphere 8.5.5.19

Scimmia wrote:
ajgringo619 wrote:

Since there are already gcc10 and gcc11 AUR packages, I'd be willing to bet that a gcc12 version is on the way. I'd consult both of the aforementioned package maintainers, at a minimum you can look at their package builds for a starting point.

Not until it's dropped from the community repo, where it's already packaged (after the OP here).

Hmmm...while I see the package on the Arch site (dated today, so it's brand-new), I did not see it when searching with pacman. Tried pacseek as well, not there either. Guess the mirrors haven't caught up yet.

Offline

#5 2023-05-07 03:28:18

jorgemota
Member
Registered: 2013-08-12
Posts: 42

Re: [SOLVED] Problem with gcc13 and WebSphere 8.5.5.19

ajgringo619 wrote:

Since there are already gcc10 and gcc11 AUR packages, I'd be willing to bet that a gcc12 version is on the way. I'd consult both of the aforementioned package maintainers, at a minimum you can look at their package builds for a starting point.

Thanks, I  just installed gcc12 but I still need to seek a way to run again websphere. Installed gcc12 gcc12-libs and gcc gcc-libs (13 version) but same error on websphere, maybe I need to set a path or something before launch.

Offline

#6 2023-05-07 06:04:17

jorgemota
Member
Registered: 2013-08-12
Posts: 42

Re: [SOLVED] Problem with gcc13 and WebSphere 8.5.5.19

Ok, I wrote a script called _start and this just run /opt/IBM/WebSphere/AppServer/bin/startServer.sh  with sudo
my script it's pretty simple: (./_start server1 server2 server3)

PATH=$PATH:/opt/IBM/WebSphere/AppServer/profiles/AppSrv01/bin
for SERVER in "$@"
 do
 sudo startServer.sh $SERVER
 done

Running startServer with sudo fails with same error.

Installed gcc12 gcc12-libs then I ran visudo

added LD_LIBRARY_PATH to defaults Env keep path

Defaults env_keep += "XDG_SESSION_COOKIE http_proxy HTTP_PROXY https_proxy HTTPS_PROXY LD_LIBRARY_PATH"

changed my _start script:

export LD_LIBRARY_PATH=/usr/lib/gcc/x86_64-pc-linux-gnu/12.2.1
PATH=$PATH:/opt/IBM/WebSphere/AppServer/profiles/AppSrv01/bin
 for SERVER in "$@"
 do
 sudo startServer.sh $SERVER
 done

Now I can run again WebSphere on arch linux.

In my latest tests I found that the env keep var is not needed
So you can replace for this

sudo LD_LIBRARY_PATH=/usr/lib/gcc/x86_64-pc-linux-gnu/12.2.1 startServer.sh $SERVER

I left this in case anyone can need this.

Last edited by jorgemota (2023-05-07 06:46:49)

Offline

Board footer

Powered by FluxBB