You are not logged in.

#1 2023-05-11 17:19:08

rudolf_schlepke
Member
From: Ukraine
Registered: 2021-02-27
Posts: 20
Website

[SOLVED] Firefox does not launch properly the first time after reboot

After reboot, Firefox won't launch properly. Just a black window, that's all. When you close it and run again, it runs correctly but all pinned and opened tabs are gone.
I'm using GNOME, and this issue started after the update to 44.

Here's the journal with two launches of FF:

May 11 20:11:41 ? systemd[1154]: Started Application launched by gnome-shell.
May 11 20:11:41 ? gnome-shell[1240]: Could not issue 'GetUnit' systemd call
May 11 20:11:41 ? systemd[1154]: Reached target GNOME session X11 services.
May 11 20:11:41 ? gnome-shell[2147]: The XKEYBOARD keymap compiler (xkbcomp) reports:
May 11 20:11:41 ? gnome-shell[2147]: > Warning:          Unsupported maximum keycode 708, clipping.
May 11 20:11:41 ? gnome-shell[2147]: >                   X11 cannot support keycodes above 255.
May 11 20:11:41 ? gnome-shell[2147]: Errors from xkbcomp are not fatal to the X server
May 11 20:11:41 ? gnome-shell[1240]: Failed to launch ibus-daemon: Failed to execute child process “ibus-daemon” (No such file or directory)
May 11 20:11:41 ? systemd[1154]: Starting GNOME XSettings service...
May 11 20:11:41 ? busctl[2160]: Call failed: Failed to execute child process “/usr/bin/dbus-broker-launch” (No such file or directory)
May 11 20:11:42 ? systemd[1154]: Started GNOME XSettings service.
May 11 20:11:42 ? systemd[1154]: Reached target GNOME session X11 services.
May 11 20:11:42 ? firefox.desktop[2130]: ATTENTION: default value of option mesa_glthread overridden by environment.
May 11 20:11:42 ? firefox.desktop[2130]: ATTENTION: default value of option mesa_glthread overridden by environment.
May 11 20:11:42 ? firefox.desktop[2130]: ATTENTION: default value of option mesa_glthread overridden by environment.
May 11 20:11:58 ? gnome-software[1565]: failed to get updates: no plugin could handle get-updates
May 11 20:13:04 ? systemd[1154]: app-gnome-firefox-2130.scope: Consumed 3.001s CPU time.
May 11 20:13:04 ? systemd[1154]: Started Application launched by gnome-shell.
May 11 20:13:04 ? firefox.desktop[2449]: ATTENTION: default value of option mesa_glthread overridden by environment.
May 11 20:13:04 ? firefox.desktop[2449]: ATTENTION: default value of option mesa_glthread overridden by environment.
May 11 20:13:04 ? firefox.desktop[2449]: ATTENTION: default value of option mesa_glthread overridden by environment.
May 11 20:13:05 ? firefox.desktop[2449]: [ERROR glean_core] Error setting metrics feature config: Json(Error("EOF while parsing a value", line: 1, column: 0))

Last edited by rudolf_schlepke (2023-05-15 16:27:11)

Offline

#2 2023-05-11 18:40:20

GreenTable
Member
Registered: 2023-05-11
Posts: 2

Re: [SOLVED] Firefox does not launch properly the first time after reboot

I have the same problem.

Mai 11 20:37:03 ? systemd[907]: Started Application launched by gnome-shell.
Mai 11 20:37:03 ? gnome-shell[1002]: Could not issue 'GetUnit' systemd call
Mai 11 20:37:03 ? systemd[907]: Reached target GNOME session X11 services.
Mai 11 20:37:03 ? gnome-shell[1673]: The XKEYBOARD keymap compiler (xkbcomp) reports:
Mai 11 20:37:03 ? gnome-shell[1673]: > Warning:          Unsupported maximum keycode 708, clipping.
Mai 11 20:37:03 ? gnome-shell[1673]: >                   X11 cannot support keycodes above 255.
Mai 11 20:37:03 ? gnome-shell[1673]: Errors from xkbcomp are not fatal to the X server
Mai 11 20:37:03 ? gnome-shell[1002]: Failed to launch ibus-daemon: Failed to execute child process “ibus-daemon” (No such file or directory)
Mai 11 20:37:03 ? systemd[907]: Starting GNOME XSettings service...
Mai 11 20:37:03 ? gsd-xsettings[1695]: Connection failure: Connection refused
Mai 11 20:37:03 ? gsd-xsettings[1695]: pa_context_connect() failed: Connection refused
Mai 11 20:37:03 ? systemd[907]: Started GNOME XSettings service.
Mai 11 20:37:03 ? systemd[907]: Reached target GNOME session X11 services.
Mai 11 20:37:03 ? firefox.desktop[1649]: [GFX1-]: glxtest: VA-API test failed: failed to initialise VAAPI connection.
Mai 11 20:37:03 ? firefox.desktop[1649]: ATTENTION: default value of option mesa_glthread overridden by environment.
Mai 11 20:37:03 ? firefox.desktop[1649]: ATTENTION: default value of option mesa_glthread overridden by environment.
Mai 11 20:37:03 ? firefox.desktop[1649]: ATTENTION: default value of option mesa_glthread overridden by environment.
Mai 11 20:37:10 ? systemd[907]: app-gnome-firefox-1649.scope: Consumed 1.238s CPU time.
Mai 11 20:37:12 ? systemd[907]: Started Application launched by gnome-shell.
Mai 11 20:37:12 ? firefox.desktop[1943]: [GFX1-]: glxtest: VA-API test failed: failed to initialise VAAPI connection.
Mai 11 20:37:12 ? firefox.desktop[1943]: ATTENTION: default value of option mesa_glthread overridden by environment.
Mai 11 20:37:12 ? firefox.desktop[1943]: ATTENTION: default value of option mesa_glthread overridden by environment.
Mai 11 20:37:12 ? firefox.desktop[1943]: ATTENTION: default value of option mesa_glthread overridden by environment.
Mai 11 20:37:13 ? firefox.desktop[1943]: [ERROR glean_core] Error setting metrics feature config: Json(Error("EOF while parsing a value", line: 1, column: 0))
Mai 11 20:37:16 ? systemd[907]: Started Application launched by gsd-media-keys.
Mai 11 20:37:16 ? systemd[907]: Started VTE child process 2297 launched by kgx process 2288.

Offline

#3 2023-05-12 22:08:48

rudolf_schlepke
Member
From: Ukraine
Registered: 2021-02-27
Posts: 20
Website

Re: [SOLVED] Firefox does not launch properly the first time after reboot

Seems to be resolved by latest FF update.

Edit: Nope. It did not.

Last edited by rudolf_schlepke (2023-05-13 19:58:37)

Offline

#4 2023-05-13 15:44:24

gps1539
Member
From: Los Gatos, CA
Registered: 2013-11-06
Posts: 134

Re: [SOLVED] Firefox does not launch properly the first time after reboot

I'm also seeing the same issue, even after I updated Firefox to 113.0.1. (Gnome 44.1)

Offline

#5 2023-05-14 06:22:04

seth
Member
Registered: 2012-09-03
Posts: 53,203

Re: [SOLVED] Firefox does not launch properly the first time after reboot

Does FF start properly outside a gnome session?

This is gnome on wayland?
Is gnome on X11 affected?
Is https://wiki.archlinux.org/title/Firefox#Wayland ?

Offline

#6 2023-05-15 05:01:59

astrank
Member
Registered: 2023-05-15
Posts: 2

Re: [SOLVED] Firefox does not launch properly the first time after reboot

I'm having the same issue. It is only happening me on Wayland.

Offline

#7 2023-05-15 06:14:41

seth
Member
Registered: 2012-09-03
Posts: 53,203

Re: [SOLVED] Firefox does not launch properly the first time after reboot

W/ FF on xwayland or the native backend (see the link in #5)?

Offline

#8 2023-05-15 07:23:06

astrank
Member
Registered: 2023-05-15
Posts: 2

Re: [SOLVED] Firefox does not launch properly the first time after reboot

I was using xwayland. Enabling the native backend solves the problem. Thank you!

Offline

#9 2023-05-15 16:26:37

rudolf_schlepke
Member
From: Ukraine
Registered: 2021-02-27
Posts: 20
Website

Re: [SOLVED] Firefox does not launch properly the first time after reboot

Starting FF with

MOZ_ENABLE_WAYLAND=1

solves the issue.

Offline

#10 2023-05-15 18:33:32

seth
Member
Registered: 2012-09-03
Posts: 53,203

Re: [SOLVED] Firefox does not launch properly the first time after reboot

Do you have issues w/ other X11/GLX clients (eg. glxgears)?

Offline

#11 2023-05-15 18:53:13

rudolf_schlepke
Member
From: Ukraine
Registered: 2021-02-27
Posts: 20
Website

Re: [SOLVED] Firefox does not launch properly the first time after reboot

No, doesn't seem like it. I mean, Steam works fine. Chrome, Electron-based apps, all work as expected.

Offline

#12 2023-05-26 13:06:30

GreenTable
Member
Registered: 2023-05-11
Posts: 2

Re: [SOLVED] Firefox does not launch properly the first time after reboot

Just to expand on the solution above:

To persist the environment  variable it can be set in the file /etc/environment.

Just add the following line

MOZ_ENABLE_WAYLAND=1

Offline

Board footer

Powered by FluxBB