You are not logged in.

#1 2023-05-17 18:10:18

solarisfire
Member
Registered: 2023-05-17
Posts: 3

Can't upgrade 525xx driver due to nvidia dependency issues

If I run yay -Syu I can see a load of Nvidia stuff needs updating:

:: 8 Packages to upgrade/install.
8  aur/lib32-nvidia-525xx-utils   525.116.03-1 -> 525.116.04-1
7  aur/lib32-opencl-nvidia-525xx  525.116.03-1 -> 525.116.04-1
6  aur/libxnvctrl-525xx                        -> 525.116.04-1
5  aur/nvidia-525xx-dkms          525.116.03-1 -> 525.116.04-1
4  aur/nvidia-525xx-settings      525.116.03-1 -> 525.116.04-1
3  aur/nvidia-525xx-utils                      -> 525.116.04-1
   (Make Dependency of nvidia-525xx-dkms, libxnvctrl-525xx, ...)
2  aur/opencl-nvidia-525xx        525.116.03-1 -> 525.116.04-1

Or I can run yay -S nvidia-525xx-dkms nvidia-525xx-utils nvidia-525xx-settings libxnvctrl-525xx lib32-nvidia-525xx-utils lib32-nvidia-525xx-utils opencl-nvidia-525xx lib32-opencl-nvidia-525xx to try and do the same thing.

Both throw the same error:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-525xx-utils (525.116.04-1) breaks dependency 'nvidia-utils=525.116.03' required by lib32-nvidia-525xx-utils
:: installing nvidia-525xx-utils (525.116.04-1) breaks dependency 'nvidia-utils=525.116.03' required by nvidia-525xx-dkms
:: installing nvidia-525xx-utils (525.116.04-1) breaks dependency 'nvidia-utils=525.116.03' required by nvidia-525xx-settings
 -> Failed to install layer, rolling up to next layer.error:error installing: [/home/solarisfire/.cache/yay/nvidia-525xx-utils/nvidia-525xx-utils-525.116.04-1-x86_64.pkg.tar.zst] - exit status 1

Which makes no sense... I'm upgrading those packages as part of the transaction to a version that is compatible...

Seems like a bit of a chicken and egg scenario, but it usually means I have to totally remove the nvidia driver package and then install it again fresh.

Is there a better solution?

Offline

#2 2023-05-17 18:21:27

seth
Member
Registered: 2012-09-03
Posts: 53,312

Re: Can't upgrade 525xx driver due to nvidia dependency issues

Remove the lib32 ones, update the reaining, then re-install the lib32 ones.
Or makepkg all pacakges (there're actually just two, the others are part of the same PKGBUILD) and "pacman -U" them en block.

Offline

#3 2023-05-17 19:09:14

solarisfire
Member
Registered: 2023-05-17
Posts: 3

Re: Can't upgrade 525xx driver due to nvidia dependency issues

Didn't help, removed the lib32 packages, then tried to yay -Syu:

:: 5 Packages to upgrade/install.
5  aur/libxnvctrl-525xx                    -> 525.116.04-1
4  aur/nvidia-525xx-dkms      525.116.03-1 -> 525.116.04-1
3  aur/nvidia-525xx-settings  525.116.03-1 -> 525.116.04-1
2  aur/nvidia-525xx-utils     525.116.03-1 -> 525.116.04-1
1  aur/opencl-nvidia-525xx    525.116.03-1 -> 525.116.04-1

And same error:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-525xx-utils (525.116.04-1) breaks dependency 'nvidia-utils=525.116.03' required by nvidia-525xx-dkms
:: installing nvidia-525xx-utils (525.116.04-1) breaks dependency 'nvidia-utils=525.116.03' required by nvidia-525xx-settings
 -> Failed to install layer, rolling up to next layer.error:error installing: [/home/solarisfire/.cache/yay/nvidia-525xx-utils/nvidia-525xx-utils-525.116.04-1-x86_64.pkg.tar.zst] - exit status 1

Offline

#4 2023-05-17 19:19:18

seth
Member
Registered: 2012-09-03
Posts: 53,312

Re: Can't upgrade 525xx driver due to nvidia dependency issues

seth wrote:

makepkg all packages (there're actually just two, the others are part of the same PKGBUILD) and "pacman -U" them en block.

Offline

#5 2023-05-18 16:34:44

solarisfire
Member
Registered: 2023-05-17
Posts: 3

Re: Can't upgrade 525xx driver due to nvidia dependency issues

A guide on how to do that would be helpful...

And not a great user experience. Surely it should just work? Or is that more of an issue with yay than with AUR?

Offline

#6 2023-05-18 16:44:39

Fuxino
Member
From: Slovakia
Registered: 2014-09-26
Posts: 191

Re: Can't upgrade 525xx driver due to nvidia dependency issues

solarisfire wrote:

A guide on how to do that would be helpful...

https://wiki.archlinux.org/title/Arch_User_Repository
https://wiki.archlinux.org/title/Makepkg


Arch + XMonad

Dotfiles: https://github.com/Fuxino/dotfiles

Offline

#7 2023-05-18 18:13:10

seth
Member
Registered: 2012-09-03
Posts: 53,312

Re: Can't upgrade 525xx driver due to nvidia dependency issues

A guide on how to do that would be helpful...

How did you install yay? What distro is this?

Offline

Board footer

Powered by FluxBB