You are not logged in.

#1 2023-05-22 17:19:18

A simple duck
Member
Registered: 2023-05-12
Posts: 18

Bluetooth earbud issues

I recently reinstalled arch Linux (decided to switch from btrfs to ext4 if that has anything to do with this issue), but strangely after reinstalling my earbuds have lost some functionality.

My two main issues are that

  • When the earbuds are taken out of their case they automatically pair with the computer, but when it auto pairs with the computer the audio does not get rerouted to it and I have to manually disconnect and reconnect it for audio to come through.

  • The touch controls have also stopped working.

System config that I think is relevant to this issue

  • My system is up to date.

  • Using pipewire as my sound system 

  • Contents of /etc/pulse/default.pa

    ❯ cat /etc/pulse/default.pa
    ### Automatically switch to newly-connected devices
    load-module module-switch-on-connect

    .

  • Relevant dmesg output

    ❯ sudo dmesg | grep Airdopes
    [ 4910.343042] input: Airdopes 141 (AVRCP) as /devices/virtual/input/input32

I am also certain that the issue lies with Linux and not the earbuds as they still work flawlessly on windows.

Last edited by A simple duck (2023-05-22 17:19:51)

Offline

#2 2023-05-23 06:56:06

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,110

Re: Bluetooth earbud issues

pipewire as my sound system and having that default.pa file existing are conflicting statements. What's the status here

pacman -Qs 'pipewire|pulseaudio'
systemctl --user status pipewire{,-pulse,-media-session} wireplumber pulseaudio

Offline

#3 2023-05-23 10:20:53

A simple duck
Member
Registered: 2023-05-12
Posts: 18

Re: Bluetooth earbud issues

OH lol had a bit of a small brain moment there , i was probably reading the wiki wrong

❯ pacman -Qs 'pipewire|pulseaudio'
local/gst-plugin-pipewire 1:0.3.70-2
    Multimedia graph framework - pipewire plugin
local/libpipewire 1:0.3.70-2
    Low-latency audio/video router and processor - client library
local/libwireplumber 0.4.14-1
    Session / policy manager implementation for PipeWire - client library
local/pavucontrol 1:5.0+r61+gee77d86-2
    PulseAudio Volume Control
local/pipewire 1:0.3.70-2
    Low-latency audio/video router and processor
local/pipewire-alsa 1:0.3.70-2
    Low-latency audio/video router and processor - ALSA configuration
local/pipewire-audio 1:0.3.70-2
    Low-latency audio/video router and processor - Audio support
local/pipewire-jack 1:0.3.70-2
    Low-latency audio/video router and processor - JACK support
local/pipewire-pulse 1:0.3.70-2
    Low-latency audio/video router and processor - PulseAudio replacement
local/wireplumber 0.4.14-1
    Session / policy manager implementation for PipeWire

Output of systemctl --user status pipewire{,-pulse,-media-session} wireplumber pulseaudio

● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; preset: enabled)
     Active: active (running) since Tue 2023-05-23 08:12:46 IST; 7h ago
TriggeredBy: ● pipewire.socket
   Main PID: 1647 (pipewire)
      Tasks: 3 (limit: 18977)
     Memory: 10.5M
        CPU: 2min 5.997s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─1647 /usr/bin/pipewire

May 23 08:12:46 hp-pav systemd[1472]: Started PipeWire Multimedia Service.
May 23 08:12:46 hp-pav pipewire[1647]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
May 23 08:12:46 hp-pav pipewire[1647]: mod.rt: found session bus but no portal
May 23 08:12:47 hp-pav pipewire[1647]: [0:01:29.444082663] [1647]  INFO Camera camera_manager.cpp:298 libcamera v0.0.5
May 23 15:11:53 hp-pav pipewire[1647]: pw.node: (bluez_output.F1_EE_69_FF_FC_E4.1-52) running -> error (Received error event)

● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; preset: enabled)
     Active: active (running) since Tue 2023-05-23 08:12:46 IST; 7h ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 1660 (pipewire-pulse)
      Tasks: 2 (limit: 18977)
     Memory: 27.3M
        CPU: 24.124s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─1660 /usr/bin/pipewire-pulse

May 23 08:12:46 hp-pav systemd[1472]: Started PipeWire PulseAudio.
May 23 08:12:46 hp-pav pipewire-pulse[1660]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
May 23 08:12:46 hp-pav pipewire-pulse[1660]: mod.rt: found session bus but no portal

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; preset: enabled)
     Active: active (running) since Tue 2023-05-23 08:12:46 IST; 7h ago
   Main PID: 1659 (wireplumber)
      Tasks: 6 (limit: 18977)
     Memory: 21.2M
        CPU: 3min 58.358s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─1659 /usr/bin/wireplumber

May 23 14:38:17 hp-pav wireplumber[1659]: RFCOMM receive command but modem not available: AT+CHLD=?
May 23 14:38:17 hp-pav wireplumber[1659]: RFCOMM receive command but modem not available: AT+CCWA=1
May 23 14:38:17 hp-pav wireplumber[1659]: RFCOMM receive command but modem not available: AT+NREC=0
May 23 14:38:17 hp-pav wireplumber[1659]: RFCOMM receive command but modem not available: AT+CGMI?
May 23 14:38:17 hp-pav wireplumber[1659]: Failed to register battery provider. Error: org.freedesktop.DBus.Error.UnknownMethod
May 23 14:38:17 hp-pav wireplumber[1659]: BlueZ Battery Provider is not available, won't retry to register it. Make sure you are running BlueZ 5.56+ with experimental features to use Battery Provider.
May 23 15:11:53 hp-pav wireplumber[1659]: 0x55cc47fb8738: error 24
May 23 15:11:53 hp-pav wireplumber[1659]: (bluez_output.F1_EE_69_FF_FC_E4.1-21) running -> error (Received error event)
May 23 15:11:53 hp-pav wireplumber[1659]: Failure in Bluetooth audio transport /org/bluez/hci0/dev_F1_EE_69_FF_FC_E4/sep2/fd2
May 23 15:40:05 hp-pav wireplumber[1659]: <WpPortalPermissionStorePlugin:0x55cc477b1250> Failed to call Lookup: GDBus.Error:org.freedesktop.portal.Error.NotFound: No entry for camera

Last edited by A simple duck (2023-05-23 10:23:04)

Offline

Board footer

Powered by FluxBB