You are not logged in.

#1 2023-05-31 23:36:19

From: Arizona
Registered: 2023-05-31
Posts: 1

AMDGPU Driver causes Kernel OOPS and system hang

Hello, I am trying to use a very unorthodox setup to get extra monitor space.  I have created a script to add an extra 1920x1080 screen to the right of my main screen (HDMI-A-0, 2560x1080), this extra screen is running on the unused DVI port (DVI-D-0).
I am then using the AMD AMF package from the AUR as an encoder for `ffmpeg`, in order to transfer my X display (+ 2560 to the width to only transmit the virtual second screen.
I am able to use this setup for a small (seemingly random) amount, before my system completely (in a weird way) locks up.
For example, when the system locked up, here's a rundown of what still worked and what didn't
- The display was completely frozen
- The keyboard and mouse did nothing, even for example the numlock/capslock keys did not turn on the respective lights, and attemptting to switch to a different virtual console did nothing (I tried CTRL+Alt+F3 ad well as F12)
+ Audio did still work, I could still hear my music playing, and my friends on Discord could still here my microphone
+ Network still worked, I was able to log in to my PC via SSH, and execute commands
- No matter what I tried, I could not end the Xorg process, even `sudo killall -9 Xorg` did nothing.

Ultimately it required me to forcibly shut down the PC, as a graceful shutdown did nothing, when I tried, it did kick me out of SSH, and the Audio stopped, however the system never shut down until I held the power button to force it off.
Note that this behavior is inconsistent, i.e it happened the first time that this error occurred to me, but not the last boot (the log in this message).

Here are some of the related things:
The script I was using to add the extra 1080p screen:

xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode DVI-D-0 1920x1080_60.00
xrandr --fb 4480x1080 --output HDMI-A-0 --mode 2560x1080 --pos 0x0 --output DVI-D-0 --mode 1920x1080_60.00 --pos 2560x0

My `ffmpeg` command:

sudo ffmpeg -hwaccel vdpau  -video_size 1920x1080 -framerate 30 -f x11grab -i :0.0+2560,0 -vcodec h264_amf  -f mpegts -preset ultrafast -fflags nobuffer tcp://\?listen

The log from last boot, the errors + kernel OOPS are at the end

My system information:
- Custom built PC
- Intel Core i3-12110f
- 16GB DDR4-3200MHz Overclocked (I believe to 4200MHz, the RAM's default XMP 1 Profile)
- Gigabyte Radeon RX 560 4GB
- Arch Linux with testing repos

Does anyone know how this could be solved?
I would be glad to provide any additional system information if it would be necessary.

Last edited by Techflash (2023-05-31 23:46:06)


Board footer

Powered by FluxBB