You are not logged in.

#1 2023-09-07 11:41:20

Soultrigger
Member
From: Brazil
Registered: 2021-11-04
Posts: 102

[Solved] Pacman -U aurpackage error - tldr makepkg -sc instead of -Sc

I installed a VM and I also installed a new machine and I was getting errors while trying to install a package from AUR, after that I tried to redo the same thing on my machine where makepkg and pacman -U always worked flawlessly and I am getting the same error, so I dediced to ask for help since I am lost on what to do. (I did read pacman, makepkg, abs, aur wikis, but I didnt find the right answer).

So just to make sure I wiped the directory and started from scratch.

    ~/build  git clone https://aur.archlinux.org/paru-bin.git                                                                                                                                                               ✔  08:26:07 
Cloning into 'paru-bin'...
remote: Enumerating objects: 132, done.
remote: Counting objects: 100% (132/132), done.
remote: Compressing objects: 100% (87/87), done.
remote: Total 132 (delta 45), reused 132 (delta 45), pack-reused 0
Receiving objects: 100% (132/132), 40.36 KiB | 176.00 KiB/s, done.
Resolving deltas: 100% (45/45), done.

    ~/build  cd paru-bin/                                                                                                                                                                                                   ✔  08:26:47 

    ~/build/paru-bin   master  makepkg -Scc                                                                                                                                                                               ✔  08:26:51 
==> Criando o pacote: paru-bin 1.11.2-1 (qui 07 set 2023 08:27:06)
==> Obtendo fontes...
  -> Baixando paru-v1.11.2-x86_64.tar.zst...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 2910k  100 2910k    0     0  4246k      0 --:--:-- --:--:-- --:--:-- 4246k
  -> Baixando paru-v1.11.2-aarch64.tar.zst...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 2772k  100 2772k    0     0  2061k      0  0:00:01  0:00:01 --:--:-- 12.8M
  -> Baixando paru-v1.11.2-armv7h.tar.zst...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 2775k  100 2775k    0     0  2610k      0  0:00:01  0:00:01 --:--:-- 37.4M
==> Validando source_x86_64 arquivos com sha256sums...
    paru-v1.11.2-x86_64.tar.zst ... Passou
==> Validando source_aarch64 arquivos com sha256sums...
    paru-v1.11.2-aarch64.tar.zst ... Passou
==> Validando source_armv7h arquivos com sha256sums...
    paru-v1.11.2-armv7h.tar.zst ... Passou
==> Entrando no ambiente de fakeroot...
==> Criando o pacote fonte...
  -> Adicionando PKGBUILD...
  -> Gerando o arquivo .SRCINFO...
  -> Compactando o pacote fonte...
==> Saindo do ambiente de fakeroot.
==> Pacote fonte criado: paru-bin (qui 07 set 2023 08:27:15)

    ~/build/paru-bin   master ?4  sudo pacman -U paru-v1.11.2-x86_64.tar.zst                                                                                                                                      ✔   12s  08:27:15 
carregando pacotes...
erro: faltando metadados do pacote em paru-v1.11.2-x86_64.tar.zst
erro: 'paru-v1.11.2-x86_64.tar.zst': pacote inválido ou corrompido

The silly squares is just fish "pretty" stuff.

I would also like to ask if I just installed a clean machine with base and base-devel it should make the package without issues even if I dont edit makepkg.conf for optimizations, righ?

As a side information, I tried other packages from AUR and I get the same erros. I am stuck, since I dont think it is all the AUR packages that broke, but something on my end that is screwed.

As for translation, pacman -U reports missing package metadata and invalid or corrupt package.

I also searched a package using paru on the machine that I put the outputs above as to show that I compiled it with success before and  installed, and now I cant on the same machine.

    ~/build/paru-bin   master ?4  paru -Ss brave                                                                                                                                                                        ✘ 1  08:28:21 
extra/python-adblock 0.6.0-2 [1.29MiB 7.15MiB]
    Brave's adblock library in Python
aur/brave-bin 1:1.57.57-1 [+710 ~17.24] [Desatualizado desde: 2023-09-06] [Instalado: 1:1.57.53-1]
    Web browser that blocks ads and trackers by default (binary release)
aur/brave 1.52.129-1 [+142 ~3.63] [Desatualizado desde: 2023-08-08]
    Web browser that blocks ads and trackers by default
aur/brave-beta-bin 1.58.116-1 [+40 ~0.28]
    Web browser that blocks ads and trackers by default (beta binary release).
aur/brave-git 1.25.33.g0126e4e-1 [+27 ~1.17] [Desatualizado desde: 2022-12-31] [Órfão]
    A web browser that stops ads and trackers by default. Master branch.
aur/brave-nightly-bin 1.60.1-1 [+23 ~1.04]
    Web browser that blocks ads and trackers by default (nightly binary release).
aur/brave-dev-bin 1.58.111-1 [+13 ~0.16]
    Web browser that blocks ads and trackers by default (dev binary release).
aur/profile-sync-daemon-brave 2022.08.18-1 [+3 ~0.01]
    Brave browser support for profile-sync-daemon
aur/unbrave-git r5046.f567e657-1 [+2 ~0.00] [Desatualizado desde: 2023-04-22]
    A web browser that stops ads and trackers by default
aur/brave-extension-bitwarden-git 2023.8.3.r13084.g6f82a99-1 [+1 ~0.49]
    Bitwarden browser extension for Brave
aur/suave 2.0-1 [+1 ~0.00]
    Sport Utility Assault Vehicle Extreme. Drive very small, but very brave tank.
aur/mermaid-cli-brave 10.1.0-1 [+0 ~0.00]
    CLI for mermaid, generates diagrams and flowcharts (depends on brave rather then chromium)

Last edited by Soultrigger (2023-09-07 12:45:07)

Offline

#2 2023-09-07 11:44:28

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,639

Re: [Solved] Pacman -U aurpackage error - tldr makepkg -sc instead of -Sc

You tried to install the source tarball, not the package. Check the file name.

Offline

#3 2023-09-07 11:59:33

Soultrigger
Member
From: Brazil
Registered: 2021-11-04
Posts: 102

Re: [Solved] Pacman -U aurpackage error - tldr makepkg -sc instead of -Sc

Thanks for the fast reply, but I tried all four files there just to make sure and the same error:

    ~/build/paru-bin   master ?4  ls                                                                                                                                                                              ✔   23s  08:43:39 
paru-bin-1.11.2-1.src.tar.gz  paru-v1.11.2-aarch64.tar.zst  paru-v1.11.2-armv7h.tar.zst  paru-v1.11.2-x86_64.tar.zst  PKGBUILD  src/

    ~/build/paru-bin   master ?4  sudo pacman -U paru-bin-1.11.2-1.src.tar.gz                                                                                                                                             ✔  08:55:40 
[sudo] senha para soultrigger: 
carregando pacotes...
erro: faltando metadados do pacote em paru-bin-1.11.2-1.src.tar.gz
erro: 'paru-bin-1.11.2-1.src.tar.gz': pacote inválido ou corrompido

    ~/build/paru-bin   master ?4  sudo pacman -U paru-v1.11.2-aarch64.tar.zst                                                                                                                                    ✘ 1   3s  08:57:41 
carregando pacotes...
erro: faltando metadados do pacote em paru-v1.11.2-aarch64.tar.zst
erro: 'paru-v1.11.2-aarch64.tar.zst': pacote inválido ou corrompido

    ~/build/paru-bin   master ?4  sudo pacman -U paru-v1.11.2-armv7h.tar.zst                                                                                                                                            ✘ 1  08:57:58 
carregando pacotes...
erro: faltando metadados do pacote em paru-v1.11.2-armv7h.tar.zst
erro: 'paru-v1.11.2-armv7h.tar.zst': pacote inválido ou corrompido

    ~/build/paru-bin   master ?4  sudo pacman -U paru-v1.11.2-x86_64.tar.zst                                                                                                                                            ✘ 1  08:58:08 
carregando pacotes...
erro: faltando metadados do pacote em paru-v1.11.2-x86_64.tar.zst
erro: 'paru-v1.11.2-x86_64.tar.zst': pacote inválido ou corrompido

Offline

#4 2023-09-07 12:10:55

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 11,936
Website

Re: [Solved] Pacman -U aurpackage error - tldr makepkg -sc instead of -Sc

Where did you read that you should run 'makepkg -Scc'?

man makepkg wrote:
       -S, --source 
           Do not actually build the package, but build a source-only tarball that does not include sources that can
           be fetched via a download URL. This is useful for passing a single tarball to another program such as a
           chroot, remote builder, or a tarball upload. Because integrity checks are verified, all source files of
           the package need to be present or downloadable.

Read https://wiki.archlinux.org/title/Makepkg and try again. Also, please post commands and their output in English: https://wiki.archlinux.org/title/Genera … s_and_code

Mod note: Moving to AUR Issues.


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#5 2023-09-07 12:41:55

Soultrigger
Member
From: Brazil
Registered: 2021-11-04
Posts: 102

Re: [Solved] Pacman -U aurpackage error - tldr makepkg -sc instead of -Sc

Thanks WorMzy,  Sorry to trouble you over nothing.

It was already worth it to learn that with LC_ALL=C outputs the verbose from commands in english, it will be useful and I will read the guidelines to make sure I dont violate them.

I was using -Scc because my mind bugged, since I use it on pacman to clean package cache.... On makepkg it is just with a lower case -sc or even works with -scc but I dont know if the extra c would do anything. Since you asked why I used it, it is because of item 2.4 here: https://wiki.archlinux.org/title/Arch_User_Repository

But unfortunately I kept spamming it with a capital S and I was too much focused to notice, and another person with a better and clear perspective could notice what I would not.

Thanks a lot.

(I also failed to notice that it is not the .zst at the end that matters, but the pkg.tar.zst and all other files are just tar balls).

I am marking this as solved, and probably others wont be as newbe as I am, but it might be useful for someone someday.

(I slept over it after a few hours trying it and even when I woke up I still tried a few more hours before posting, and I can just laught at myself haha)

Last edited by Soultrigger (2023-09-07 12:47:22)

Offline

Board footer

Powered by FluxBB